aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-04-15 03:48:00 +0800
committermarcus <marcus@FreeBSD.org>2003-04-15 03:48:00 +0800
commite40fa306c476a1d86ae006700baba75b89874366 (patch)
tree607067e8c07ce9527c2cc9acb7c8b28be2af114c /www
parentfff9365a1bc03774b39d0db85eb786e0a6be9948 (diff)
downloadfreebsd-ports-gnome-e40fa306c476a1d86ae006700baba75b89874366.tar.gz
freebsd-ports-gnome-e40fa306c476a1d86ae006700baba75b89874366.tar.zst
freebsd-ports-gnome-e40fa306c476a1d86ae006700baba75b89874366.zip
Do not enable -O2 optimization by default. Instead, allow the user
to enable it by specifying -DWITH_OPTIMIZED_CFLAGS or definining WITH_OPTIMIZED_CFLAGS in /etc/make.conf. Note, this is the same flag mplayer users. Requested by: sobomax
Diffstat (limited to 'www')
-rw-r--r--www/mozilla/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 5e2b53870915..7650823984d9 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -155,7 +155,7 @@ ALL_TARGET= default
CONFIGURE_ARGS+= --enable-reorder
.endif
-.if !defined(WITHOUT_OPTIMIZE) && ${ARCH} != "alpha"
+.if defined(WITH_OPTIMIZED_CFLAGS) && ${ARCH} != "alpha"
CFLAGS+= -O2
CONFIGURE_ARGS+= --enable-optimize=-O2
.endif
@@ -180,7 +180,7 @@ pre-everything::
@${ECHO_MSG} " WITHOUT_LDAP=yes Disables LDAP support within the Mailnews module"
@${ECHO_MSG} " WITHOUT_CHATZILLA=yes Disable the Chatzilla IRC module"
@${ECHO_MSG} " WITH_JAVASCRIPT_DEBUGGER=yes Enable the DTD and JavaScript debuggers"
- @${ECHO_MSG} " WITHOUT_OPTIMIZE=yes Disable -O2 optimization"
+ @${ECHO_MSG} " WITH_OPTIMIZED_CFLAGS=yes Enable -O2 optimization"
@${ECHO_MSG} ""
.if defined(WITH_CALENDAR)
@${ECHO_MSG} "Calendar is still beta software."