aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-03-12 19:10:58 +0800
committermarcus <marcus@FreeBSD.org>2005-03-12 19:10:58 +0800
commitf0784df238f53142ad4f468dfec98defc56b674b (patch)
treeb054224ca644bbcc25328c6c2d9d81dd88aef39f /www
parentd3bf8e378c06188ec7a958abfa7449c20426ee33 (diff)
downloadfreebsd-ports-gnome-f0784df238f53142ad4f468dfec98defc56b674b.tar.gz
freebsd-ports-gnome-f0784df238f53142ad4f468dfec98defc56b674b.tar.zst
freebsd-ports-gnome-f0784df238f53142ad4f468dfec98defc56b674b.zip
Add pyphany, a set of Python bindings for building extensions to the
Epiphany web browser.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/pyphany/Makefile31
-rw-r--r--www/pyphany/distinfo2
-rw-r--r--www/pyphany/pkg-descr2
-rw-r--r--www/pyphany/pkg-plist19
5 files changed, 55 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 39db6176c308..d76f998c060a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -634,6 +634,7 @@
SUBDIR += py-scgi
SUBDIR += py-websvcs
SUBDIR += py-webware
+ SUBDIR += pyphany
SUBDIR += pyweblib
SUBDIR += qdecoder
SUBDIR += quixote
diff --git a/www/pyphany/Makefile b/www/pyphany/Makefile
new file mode 100644
index 000000000000..baf50efe0a2f
--- /dev/null
+++ b/www/pyphany/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: pyphany
+# Date created: 28 January 2005
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyphany
+PORTVERSION= 0.1.2
+CATEGORIES= www python gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.1
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A set of Python bindings for Epiphany
+
+BUILD_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
+RUN_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PYTHON= yes
+USE_GNOME= gnomehack gnometarget intlhack pygnome2
+USE_LIBTOOL_VER=15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_SUB= VERSION="1.5"
+
+.include <bsd.port.mk>
diff --git a/www/pyphany/distinfo b/www/pyphany/distinfo
new file mode 100644
index 000000000000..93698ef9c6a4
--- /dev/null
+++ b/www/pyphany/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome2/pyphany-0.1.2.tar.bz2) = e81edbe2fc46034a9d90098f7dc62f03
+SIZE (gnome2/pyphany-0.1.2.tar.bz2) = 305090
diff --git a/www/pyphany/pkg-descr b/www/pyphany/pkg-descr
new file mode 100644
index 000000000000..5b02d8c2a6e4
--- /dev/null
+++ b/www/pyphany/pkg-descr
@@ -0,0 +1,2 @@
+Pyphany is a set of Python bindings for Epiphany as well as an Epiphany
+extensions loader written in Python.
diff --git a/www/pyphany/pkg-plist b/www/pyphany/pkg-plist
new file mode 100644
index 000000000000..0ccd2b8e4bb4
--- /dev/null
+++ b/www/pyphany/pkg-plist
@@ -0,0 +1,19 @@
+%%PYTHON_SITELIBDIR%%/gtk-2.0/epiphany.so
+share/pygtk/2.0/defs/epiphany.defs
+@cwd %%X11BASE%%
+lib/epiphany-%%VERSION%%/extensions/gtkcons.py
+lib/epiphany-%%VERSION%%/extensions/gtkcons.xml
+lib/epiphany-%%VERSION%%/extensions/sample-python-location.py
+lib/epiphany-%%VERSION%%/extensions/sample-python-location.xml
+lib/epiphany-%%VERSION%%/extensions/sample-python-menu.py
+lib/epiphany-%%VERSION%%/extensions/sample-python-menu.xml
+lib/epiphany-%%VERSION%%/extensions/sample-python-statusbar.py
+lib/epiphany-%%VERSION%%/extensions/sample-python-statusbar.xml
+lib/epiphany-%%VERSION%%/extensions/sample-python.py
+lib/epiphany-%%VERSION%%/extensions/sample-python.xml
+lib/epiphany-%%VERSION%%/loaders/libpythonloader.a
+lib/epiphany-%%VERSION%%/loaders/libpythonloader.so
+lib/epiphany-%%VERSION%%/loaders/libpythonloader.so.0
+@dirrm lib/epiphany-%%VERSION%%/loaders
+@unexec rmdir %D/lib/epiphany-%%VERSION%%/extensions 2>/dev/null || true
+@unexec rmdir %D/lib/epiphany-%%VERSION%% 2>/dev/null || true