aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2015-01-13 20:41:25 +0800
committervanilla <vanilla@FreeBSD.org>2015-01-13 20:41:25 +0800
commitf0936946d5c9473f47cb955c1736f280b9ababb0 (patch)
treeef4b836073057869f7dccc513f4d11c0cc759c2e /www
parent48691a8f875cfb448a5b2167380638422d64a61a (diff)
downloadfreebsd-ports-gnome-f0936946d5c9473f47cb955c1736f280b9ababb0.tar.gz
freebsd-ports-gnome-f0936946d5c9473f47cb955c1736f280b9ababb0.tar.zst
freebsd-ports-gnome-f0936946d5c9473f47cb955c1736f280b9ababb0.zip
1: Add www/pecl-http1, repo copy from www/pecl-http
2: add CONFLICTS. PR: ports/96677 Submitted by: Bernard Spil <spil.oss at gmail.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/pecl-http/Makefile1
-rw-r--r--www/pecl-http1/Makefile31
-rw-r--r--www/pecl-http1/distinfo2
-rw-r--r--www/pecl-http1/pkg-descr19
5 files changed, 54 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index cda82624acec..71fe41f4fb76 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1388,6 +1388,7 @@
SUBDIR += pecl-APC
SUBDIR += pecl-amfext
SUBDIR += pecl-http
+ SUBDIR += pecl-http1
SUBDIR += pecl-solr
SUBDIR += pecl-sphinx
SUBDIR += pecl-swish
diff --git a/www/pecl-http/Makefile b/www/pecl-http/Makefile
index fc18b9c5a498..724084470983 100644
--- a/www/pecl-http/Makefile
+++ b/www/pecl-http/Makefile
@@ -23,6 +23,7 @@ LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
USES= tar:tgz
USE_PHP= yes
USE_PHPEXT= yes
+CONFLICTS= pecl-http-1*
CONFIGURE_ARGS+= --with-http-curl-requests \
--with-http-zlib-compression \
diff --git a/www/pecl-http1/Makefile b/www/pecl-http1/Makefile
new file mode 100644
index 000000000000..ab0c8ba64a60
--- /dev/null
+++ b/www/pecl-http1/Makefile
@@ -0,0 +1,31 @@
+# Created by: Wen Heping <wenheping@gmail.com>
+# $FreeBSD$
+
+PORTNAME= http
+PORTVERSION= 1.7.6
+CATEGORIES= www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+PKGNAMESUFFIX= 1
+DISTNAME= pecl_http-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Extended HTTP Support
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+
+USES= tar:tgz
+USE_PHP= yes
+USE_PHPEXT= yes
+PHP_MODNAME= http
+IGNORE_WITH_PHP= 56
+CONFLICTS= pecl-http-2*
+
+CONFIGURE_ARGS+= --with-http-curl-requests \
+ --with-http-zlib-compression \
+ --with-http-magic-mime
+
+.include <bsd.port.mk>
diff --git a/www/pecl-http1/distinfo b/www/pecl-http1/distinfo
new file mode 100644
index 000000000000..4e252126e53e
--- /dev/null
+++ b/www/pecl-http1/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pecl_http-1.7.6.tgz) = e87207a7dcd713bef0eb3701b552e0d173fbd73dbd52f9d3968851112e899983
+SIZE (pecl_http-1.7.6.tgz) = 174722
diff --git a/www/pecl-http1/pkg-descr b/www/pecl-http1/pkg-descr
new file mode 100644
index 000000000000..0a262775cd41
--- /dev/null
+++ b/www/pecl-http1/pkg-descr
@@ -0,0 +1,19 @@
+pecl-http extension aims to provide a convenient and
+powerful set of functionality for one of PHPs major
+applications. It eases handling of HTTP URLs, dates,
+redirects, headers and messages, provides means for
+negotiation of clients preferred language and charset,
+as well as a convenient way to send any arbitrary data
+with caching and resuming capabilities. It provides
+powerful request functionality too.
+
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+
+This the deprecated version 1 branch of this package
+as the current 2.x branch is described as
+"completely incompatible to previous version."
+Please upgrade to www/pecl-http as soon as possible!
+
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+
+WWW: http://pecl.php.net/package/pecl_http/