aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2017-09-27 20:19:27 +0800
committermadpilot <madpilot@FreeBSD.org>2017-09-27 20:19:27 +0800
commitf0fe3cfc4134242f3588d4efbba72bf150bb0f3a (patch)
treef953bc1b64fe8fb24214ff5ec5f705b3a661b95c /www
parent366f0cf0ab8c5a190d14271b97c1964c42580217 (diff)
downloadfreebsd-ports-gnome-f0fe3cfc4134242f3588d4efbba72bf150bb0f3a.tar.gz
freebsd-ports-gnome-f0fe3cfc4134242f3588d4efbba72bf150bb0f3a.tar.zst
freebsd-ports-gnome-f0fe3cfc4134242f3588d4efbba72bf150bb0f3a.zip
- Fix build with upcoming vala 0.36 [1]
While here: - Indentition fixes - Silence portlint warning about variables ordering - Convert to USES=localbase PR: 222015 [1] Submitted by: cpm
Diffstat (limited to 'www')
-rw-r--r--www/midori/Makefile9
-rw-r--r--www/midori/files/patch-config__search6
-rw-r--r--www/midori/files/patch-extensions__external-download-manager.vala19
-rw-r--r--www/midori/files/patch-extensions_adblock_widgets.vala14
-rw-r--r--www/midori/files/patch-extensions_apps.vala14
-rw-r--r--www/midori/files/patch-extensions_history-list.vala14
-rw-r--r--www/midori/files/patch-extensions_notes.vala14
-rw-r--r--www/midori/files/patch-extensions_transfers.vala27
-rw-r--r--www/midori/files/patch-midori_midori-notebook.vala29
9 files changed, 128 insertions, 18 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index e1245c355967..791fdee7ae92 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -5,7 +5,7 @@ PORTNAME= midori
PORTVERSION= 0.5.11
CATEGORIES= www xfce
MASTER_SITES= https://launchpadlibrarian.net/215909491/ \
- https://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/
+ https://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
@@ -21,17 +21,16 @@ LIB_DEPENDS= libnotify.so:devel/libnotify \
libgcr-3.so:security/gcr
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -Wno-return-type
CMAKE_ARGS= -DUSE_APIDOCS:BOOL=OFF \
- -DUSE_GRANITE:BOOL=OFF
+ -DUSE_GRANITE:BOOL=OFF
+USES= cmake desktop-file-utils gettext localbase:ldflags pkgconfig \
+ sqlite tar:bzip2
USE_GNOME= glib20 intltool libxml2
USE_XORG= xscrnsaver
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-USES= cmake desktop-file-utils gettext pkgconfig sqlite tar:bzip2
PLIST_SUB= VERSION="${PORTVERSION:R}"
diff --git a/www/midori/files/patch-config__search b/www/midori/files/patch-config__search
index e8380b36fc88..2b05de9684cc 100644
--- a/www/midori/files/patch-config__search
+++ b/www/midori/files/patch-config__search
@@ -1,6 +1,6 @@
---- ./config/search.orig 2013-11-20 01:26:52.000000000 +0000
-+++ ./config/search 2013-11-20 18:03:47.000000000 +0000
-@@ -16,6 +16,12 @@
+--- config/search.orig 2015-08-30 11:56:26 UTC
++++ config/search
+@@ -16,6 +16,12 @@ text=Web Search
uri=http://www.google.com/search?q=%s
token=g
diff --git a/www/midori/files/patch-extensions__external-download-manager.vala b/www/midori/files/patch-extensions__external-download-manager.vala
index d5a89213d552..e4d4cc526fee 100644
--- a/www/midori/files/patch-extensions__external-download-manager.vala
+++ b/www/midori/files/patch-extensions__external-download-manager.vala
@@ -1,7 +1,7 @@
---- ./extensions/external-download-manager.vala.orig 2013-03-07 17:44:14.000000000 +0000
-+++ ./extensions/external-download-manager.vala 2013-03-11 06:50:27.000000000 +0000
-@@ -16,7 +16,7 @@
- using WebKit;
+--- extensions/external-download-manager.vala.orig 2015-08-30 11:56:26 UTC
++++ extensions/external-download-manager.vala
+@@ -10,7 +10,7 @@
+ */
namespace EDM {
-#if !HAVE_WIN32
@@ -9,7 +9,7 @@
[DBus (name = "net.launchpad.steadyflow.App")]
interface SteadyflowInterface : GLib.Object {
public abstract void AddFile (string url) throws IOError;
-@@ -183,6 +183,7 @@
+@@ -203,6 +203,7 @@ namespace EDM {
}
}
@@ -17,22 +17,21 @@
private class SteadyFlow : ExternalDownloadManager {
public override bool download (DownloadRequest dlReq) {
try {
-@@ -210,6 +211,7 @@
+@@ -230,6 +231,7 @@ namespace EDM {
}
}
#endif
+#endif
private class CommandLinePreferences : Gtk.Dialog {
- protected Entry input;
-@@ -339,8 +341,10 @@
+ protected Gtk.Entry input;
+@@ -359,7 +361,9 @@ public Katze.Array extension_init () {
var extensions = new Katze.Array( typeof (Midori.Extension));
#if !HAVE_WIN32
extensions.add_item (new EDM.Aria2 ());
+ #if HAVE_GTK3
extensions.add_item (new EDM.SteadyFlow ());
- #endif
+ #endif
+ #endif
extensions.add_item (new EDM.CommandLine ());
return extensions;
- }
diff --git a/www/midori/files/patch-extensions_adblock_widgets.vala b/www/midori/files/patch-extensions_adblock_widgets.vala
new file mode 100644
index 000000000000..1b0a81e2bbc5
--- /dev/null
+++ b/www/midori/files/patch-extensions_adblock_widgets.vala
@@ -0,0 +1,14 @@
+--- extensions/adblock/widgets.vala.orig 2015-08-30 11:56:26 UTC
++++ extensions/adblock/widgets.vala
+@@ -227,7 +227,11 @@ namespace Adblock {
+ liststore.get (iter, 0, out sub);
+ if (sub.mutable) {
+ config.remove (sub);
++#if VALA_0_36
++ liststore.remove (ref iter);
++#else
+ liststore.remove (iter);
++#endif
+ return true;
+ }
+ }
diff --git a/www/midori/files/patch-extensions_apps.vala b/www/midori/files/patch-extensions_apps.vala
new file mode 100644
index 000000000000..4e87e8823443
--- /dev/null
+++ b/www/midori/files/patch-extensions_apps.vala
@@ -0,0 +1,14 @@
+--- extensions/apps.vala.orig 2015-08-30 11:56:26 UTC
++++ extensions/apps.vala
+@@ -265,7 +265,11 @@ namespace Apps {
+ store.get (iter, 0, out launcher);
+ try {
+ launcher.file.trash (null);
++#if VALA_0_36
++ store.remove (ref iter);
++#else
+ store.remove (iter);
++#endif
+
+ string filename = Midori.Download.clean_filename (launcher.name);
+ #if HAVE_WIN32
diff --git a/www/midori/files/patch-extensions_history-list.vala b/www/midori/files/patch-extensions_history-list.vala
new file mode 100644
index 000000000000..604d312f9836
--- /dev/null
+++ b/www/midori/files/patch-extensions_history-list.vala
@@ -0,0 +1,14 @@
+--- extensions/history-list.vala.orig 2015-08-30 11:56:26 UTC
++++ extensions/history-list.vala
+@@ -223,7 +223,11 @@ namespace HistoryList {
+ FixMe: the retrun value of `Gtk.ListStore.remove` should be checked
+ Note: in some cases the return value of `Gtk.ListStore.remove` is wrong
+ */
++#if VALA_0_36
++ model.remove (ref iter);
++#else
+ model.remove (iter);
++#endif
+ this.browser.close_tab (view);
+ if (length > 2)
+ this.resize_treeview ();
diff --git a/www/midori/files/patch-extensions_notes.vala b/www/midori/files/patch-extensions_notes.vala
new file mode 100644
index 000000000000..bf3265cb10b0
--- /dev/null
+++ b/www/midori/files/patch-extensions_notes.vala
@@ -0,0 +1,14 @@
+--- extensions/notes.vala.orig 2015-08-30 11:56:26 UTC
++++ extensions/notes.vala
+@@ -116,7 +116,11 @@ namespace ClipNotes {
+ if (current_note == note) {
+ current_note = null;
+ }
++#if VALA_0_36
++ notes_list_store.remove (ref iter);
++#else
+ notes_list_store.remove (iter);
++#endif
+ break;
+ }
+ } while (notes_list_store.iter_next (ref iter));
diff --git a/www/midori/files/patch-extensions_transfers.vala b/www/midori/files/patch-extensions_transfers.vala
new file mode 100644
index 000000000000..619410857c48
--- /dev/null
+++ b/www/midori/files/patch-extensions_transfers.vala
@@ -0,0 +1,27 @@
+--- extensions/transfers.vala.orig 2015-08-30 11:56:26 UTC
++++ extensions/transfers.vala
+@@ -275,7 +275,11 @@ namespace Transfers {
+ Transfer found;
+ store.get (iter, 0, out found);
+ if (transfer == found) {
++#if VALA_0_36
++ store.remove (ref iter);
++#else
+ store.remove (iter);
++#endif
+ break;
+ }
+ } while (store.iter_next (ref iter));
+@@ -455,7 +459,11 @@ namespace Transfers {
+ if (notifications.length () == 1)
+ msg = _("The file '<b>%s</b>' has been downloaded.").printf (filename);
+ else
+- msg = _("'<b>%s</b>' and %d other files have been downloaded.").printf (filename, notifications.length ());
++#if VALA_0_36
++ msg = _("'<b>%s</b>' and %d other files have been downloaded.").printf (filename, (int) notifications.length ());
++#else
++ msg = _("'<b>%s</b>' and %d other files have been downloaded.").printf (filename, notifications.length ());
++#endif
+ get_app ().send_notification (_("Transfer completed"), msg);
+ notifications = new GLib.List<string> ();
+ }
diff --git a/www/midori/files/patch-midori_midori-notebook.vala b/www/midori/files/patch-midori_midori-notebook.vala
new file mode 100644
index 000000000000..9462f2083fa0
--- /dev/null
+++ b/www/midori/files/patch-midori_midori-notebook.vala
@@ -0,0 +1,29 @@
+--- midori/midori-notebook.vala.orig 2015-08-30 11:56:26 UTC
++++ midori/midori-notebook.vala
+@@ -10,7 +10,7 @@
+ */
+
+ namespace Midori {
+- protected class Tally : Gtk.EventBox {
++ internal class Tally : Gtk.EventBox {
+ public Midori.Tab tab { get; set; }
+ Gtk.Spinner spinner;
+ public Gtk.Label label;
+@@ -22,7 +22,7 @@ namespace Midori {
+ public bool close_button_left { get; set; default = false; }
+ public bool close_button_visible { get; set; default = false; }
+
+- protected Tally (Midori.Tab tab) {
++ internal Tally (Midori.Tab tab) {
+ this.tab = tab;
+ box = new Gtk.HBox (false, 1);
+ add (box);
+@@ -155,7 +155,7 @@ namespace Midori {
+ int last_tab_size = 0;
+
+ #if !HAVE_GTK3
+- static const string style_fixup = """
++ const string style_fixup = """
+ style "midori-close-button-style"
+ {
+ GtkWidget::focus-padding = 0