aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-12-12 09:39:37 +0800
committerclsung <clsung@FreeBSD.org>2006-12-12 09:39:37 +0800
commitf391c196e794b59f2c486fa547852c0871ea08d6 (patch)
tree80d1d1920fadb0cf2fbaae0774d0e53cbccf6055 /www
parentb651be08e91b3d4d14dfe63efc02056dba540876 (diff)
downloadfreebsd-ports-gnome-f391c196e794b59f2c486fa547852c0871ea08d6.tar.gz
freebsd-ports-gnome-f391c196e794b59f2c486fa547852c0871ea08d6.tar.zst
freebsd-ports-gnome-f391c196e794b59f2c486fa547852c0871ea08d6.zip
Add p5-CGI-Application-Plugin-DebugScreen 0.06, this plug-in add
DebugScreen support to CGI::Application. PR: ports/103377 Submitted by: George Hartzell <hartzell at alerce.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-CGI-Application-Plugin-DebugScreen/Makefile33
-rw-r--r--www/p5-CGI-Application-Plugin-DebugScreen/distinfo3
-rw-r--r--www/p5-CGI-Application-Plugin-DebugScreen/pkg-descr4
-rw-r--r--www/p5-CGI-Application-Plugin-DebugScreen/pkg-plist9
5 files changed, 50 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 28d7e65e1bfb..0067856b1dfc 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -515,6 +515,7 @@
SUBDIR += p5-CGI-Application-Plugin-AnyTemplate
SUBDIR += p5-CGI-Application-Plugin-AutoRunmode
SUBDIR += p5-CGI-Application-Plugin-DBH
+ SUBDIR += p5-CGI-Application-Plugin-DebugScreen
SUBDIR += p5-CGI-Application-Plugin-DevPopup
SUBDIR += p5-CGI-Application-Plugin-Forward
SUBDIR += p5-CGI-Application-Plugin-HTDot
diff --git a/www/p5-CGI-Application-Plugin-DebugScreen/Makefile b/www/p5-CGI-Application-Plugin-DebugScreen/Makefile
new file mode 100644
index 000000000000..aad803685615
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-DebugScreen/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: www/p5-CGI-Application-Plugin-DebugScreen
+# Date created: 14 September 2005
+# Whom: George Hartzell <hartzell@alerce.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Application-Plugin-DebugScreen
+PORTVERSION= 0.06
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hartzell@alerce.com
+COMMENT= This plug-in add DebugScreen support to CGI::Application
+
+BUILD_DEPENDS= ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application \
+ ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
+ ${SITE_PERL}/CGI/Application/Plugin/ViewCode.pm:${PORTSDIR}/www/p5-CGI-Application-Plugin-ViewCode \
+ ${SITE_PERL}/Devel/StackTrace.pm:${PORTSDIR}/devel/p5-Devel-StackTrace \
+ ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI::Application::Plugin::DebugScreen.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or newer. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-CGI-Application-Plugin-DebugScreen/distinfo b/www/p5-CGI-Application-Plugin-DebugScreen/distinfo
new file mode 100644
index 000000000000..63346de83847
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-DebugScreen/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Application-Plugin-DebugScreen-0.06.tar.gz) = e696350727a676fcc335bc04188972ac
+SHA256 (CGI-Application-Plugin-DebugScreen-0.06.tar.gz) = 28a9fc1fd1f5a1836fa6fe32b84eef3535214ae9930d45588258888ed1a2a077
+SIZE (CGI-Application-Plugin-DebugScreen-0.06.tar.gz) = 4723
diff --git a/www/p5-CGI-Application-Plugin-DebugScreen/pkg-descr b/www/p5-CGI-Application-Plugin-DebugScreen/pkg-descr
new file mode 100644
index 000000000000..8905ad336635
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-DebugScreen/pkg-descr
@@ -0,0 +1,4 @@
+This plug-in add Debug support to CGI::Application. This plug-in like
+Catalyst debug mode.
+
+WWW: http://search.cpan.org/dist/CGI-Application-Plugin-DebugScreen/
diff --git a/www/p5-CGI-Application-Plugin-DebugScreen/pkg-plist b/www/p5-CGI-Application-Plugin-DebugScreen/pkg-plist
new file mode 100644
index 000000000000..43f4d6d02f5e
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-DebugScreen/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/CGI/Application/Plugin/DebugScreen.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Application/Plugin/DebugScreen/.packlist
+@dirrmtry %%SITE_PERL%%/CGI/Application/Plugin
+@dirrmtry %%SITE_PERL%%/CGI/Application
+@dirrmtry %%SITE_PERL%%/CGI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Application/Plugin/DebugScreen
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Application/Plugin/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Application/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/