aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-07-07 21:33:18 +0800
committerwg <wg@FreeBSD.org>2014-07-07 21:33:18 +0800
commitf85156ff1ac8aed064606a2e9199b5ba79c5ba49 (patch)
tree71e5af6b77ece75458a62099277b0e3bd671b447 /www
parent9e7c46d475a5997f32902eeabfea984a92a19545 (diff)
downloadfreebsd-ports-gnome-f85156ff1ac8aed064606a2e9199b5ba79c5ba49.tar.gz
freebsd-ports-gnome-f85156ff1ac8aed064606a2e9199b5ba79c5ba49.tar.zst
freebsd-ports-gnome-f85156ff1ac8aed064606a2e9199b5ba79c5ba49.zip
www/phpmustache: update to 2.6.0
- Support stage PR: 190439 Submitted by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/phpmustache/Makefile24
-rw-r--r--www/phpmustache/distinfo4
-rw-r--r--www/phpmustache/pkg-plist74
3 files changed, 53 insertions, 49 deletions
diff --git a/www/phpmustache/Makefile b/www/phpmustache/Makefile
index 00f9037dd699..8293f6a9495f 100644
--- a/www/phpmustache/Makefile
+++ b/www/phpmustache/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= phpmustache
-PORTVERSION= 2.4.0
+PORTVERSION= 2.6.0
CATEGORIES= www
MASTER_SITES= GH
-MAINTAINER= spolyack@collaborativefusion.com
+MAINTAINER= steve.polyack@intermedix.com
COMMENT= PHP5 code for Mustache
LICENSE= MIT
@@ -14,27 +14,23 @@ LICENSE= MIT
USE_GITHUB= yes
GH_ACCOUNT= bobthecow
GH_PROJECT= mustache.php
-GH_TAGNAME= v2.4.0
-GH_COMMIT= 8433da6
+GH_TAGNAME= v2.6.0
+GH_COMMIT= 152c315
USE_PHP= yes
USE_PHP_BUILD= yes
SUB_FILES= pkg-message
-NO_STAGE= yes
+OPTIONS_DEFINE= EXAMPLES
+
do-build:
@${WRKSRC}/bin/build_bootstrap.php
do-install:
- @${MKDIR} ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/mustache.php ${DATADIR}
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- @${CP} -R ${WRKSRC}/test/fixtures/examples/* ${EXAMPLESDIR}
-.endif
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/mustache.php ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/test/fixtures/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/www/phpmustache/distinfo b/www/phpmustache/distinfo
index 64f974fc64ef..3bee5853c9e4 100644
--- a/www/phpmustache/distinfo
+++ b/www/phpmustache/distinfo
@@ -1,2 +1,2 @@
-SHA256 (phpmustache-2.4.0.tar.gz) = 132439e9fa7a9cf23b0329049c707312848c066e7842c6e892af1c3a02fe341d
-SIZE (phpmustache-2.4.0.tar.gz) = 44139
+SHA256 (phpmustache-2.6.0.tar.gz) = c4120dbcec4d44061ba86066c7736ebb7e1421adb96d3894f1651adf60b88685
+SIZE (phpmustache-2.6.0.tar.gz) = 48770
diff --git a/www/phpmustache/pkg-plist b/www/phpmustache/pkg-plist
index 9ef6c65d9ad3..e8c92786742e 100644
--- a/www/phpmustache/pkg-plist
+++ b/www/phpmustache/pkg-plist
@@ -1,4 +1,3 @@
-%%DATADIR%%/mustache.php
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/child_context/ChildContext.php
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/child_context/child_context.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/child_context/child_context.txt
@@ -35,12 +34,18 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inverted_section/InvertedSection.php
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inverted_section/inverted_section.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inverted_section/inverted_section.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials/partials/header.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nested_partials/NestedPartials.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nested_partials/nested_partials.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nested_partials/nested_partials.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nested_partials/partials/fourth.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nested_partials/partials/second.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nested_partials/partials/third.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials/Partials.php
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials/partials.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials/partials.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/recursive_partials/partials/child.mustache
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/partials/partials/header.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/recursive_partials/RecursivePartials.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/recursive_partials/partials/child.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/recursive_partials/recursive_partials.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/recursive_partials/recursive_partials.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/section_iterator_objects/SectionIteratorObjects.php
@@ -70,36 +75,39 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/utf8_unescaped/UTF8Unescaped.php
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/utf8_unescaped/utf8_unescaped.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/utf8_unescaped/utf8_unescaped.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/whitespace/partials/alphabet.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/whitespace/Whitespace.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/whitespace/partials/alphabet.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/whitespace/whitespace.mustache
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/whitespace/whitespace.txt
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/child_context
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/comments
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/complex
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/delimiters
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/dot_notation
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/double_section
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/escaped
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/grand_parent_context
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/i18n
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/implicit_iterator
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/inverted_double_section
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/inverted_section
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/partials/partials
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/partials
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/recursive_partials/partials
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/recursive_partials
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/section_iterator_objects
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/section_magic_objects
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/section_objects
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/sections
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/sections_nested
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/simple
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/unescaped
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/utf8
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/utf8_unescaped
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/whitespace/partials
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/whitespace
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-@dirrm %%DATADIR%%
+%%DATADIR%%/mustache.php
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/child_context
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/comments
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/complex
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/delimiters
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/dot_notation
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/double_section
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/escaped
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/grand_parent_context
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/i18n
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/implicit_iterator
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/inverted_double_section
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/inverted_section
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/nested_partials/partials
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/nested_partials
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/partials/partials
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/partials
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/recursive_partials/partials
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/recursive_partials
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/section_iterator_objects
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/section_magic_objects
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/section_objects
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/sections
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/sections_nested
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/simple
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/unescaped
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/utf8
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/utf8_unescaped
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/whitespace/partials
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/whitespace
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
+@dirrmtry %%DATADIR%%