aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoralex <alex@FreeBSD.org>2000-07-29 20:22:39 +0800
committeralex <alex@FreeBSD.org>2000-07-29 20:22:39 +0800
commitfa83f374cea9868be9ee9666c0bc73d881282c8e (patch)
treee41dc24ce6e71b611ea659b71fce3e5e0eb2d7b1 /www
parent0f7131f21826b4a8227fe68c4a4d7d6dda09e10c (diff)
downloadfreebsd-ports-gnome-fa83f374cea9868be9ee9666c0bc73d881282c8e.tar.gz
freebsd-ports-gnome-fa83f374cea9868be9ee9666c0bc73d881282c8e.tar.zst
freebsd-ports-gnome-fa83f374cea9868be9ee9666c0bc73d881282c8e.zip
Add http_load 1.0, a load-tester for WWW servers.
PR: 18463 Submitted by: Ask Bjoern Hansen <ask@valueclick.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/http_load/Makefile20
-rw-r--r--www/http_load/distinfo1
-rw-r--r--www/http_load/pkg-comment1
-rw-r--r--www/http_load/pkg-descr8
-rw-r--r--www/http_load/pkg-plist1
6 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2bca7372a3cb..2162f888ccc5 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -58,6 +58,7 @@
SUBDIR += hotjava
SUBDIR += htmlpp
SUBDIR += http-analyze
+ SUBDIR += http_load
SUBDIR += httperf
SUBDIR += httptunnel
SUBDIR += hypermail
diff --git a/www/http_load/Makefile b/www/http_load/Makefile
new file mode 100644
index 000000000000..4c988c5fb204
--- /dev/null
+++ b/www/http_load/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: http_load
+# Date created: 9 May 2000
+# Whom: Ask Bjoern Hansen <ask@valueclick.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= http_load
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= http://www.acme.com/software/http_load/
+DISTNAME= http_load_10nov99
+
+MAINTAINER= ask@valueclick.com
+
+WRKSRC= ${WRKDIR}/http_load
+
+MAN1= http_load.1
+
+.include <bsd.port.mk>
diff --git a/www/http_load/distinfo b/www/http_load/distinfo
new file mode 100644
index 000000000000..a7610bd6a381
--- /dev/null
+++ b/www/http_load/distinfo
@@ -0,0 +1 @@
+MD5 (http_load_10nov99.tar.gz) = 0a673461ba291c2070f9b93015bf85bf
diff --git a/www/http_load/pkg-comment b/www/http_load/pkg-comment
new file mode 100644
index 000000000000..ebd292b113ea
--- /dev/null
+++ b/www/http_load/pkg-comment
@@ -0,0 +1 @@
+Multiprocessing http performance test client
diff --git a/www/http_load/pkg-descr b/www/http_load/pkg-descr
new file mode 100644
index 000000000000..70588ba35491
--- /dev/null
+++ b/www/http_load/pkg-descr
@@ -0,0 +1,8 @@
+http_load runs multiple http fetches in parallel, to test the throughput of
+a web server.
+
+However unlike most such test clients, it runs in a single process, so it
+doesn't bog down the client machine. It can be configured to do https
+fetches as well.
+
+WWW: http://www.acme.com/software/http_load/
diff --git a/www/http_load/pkg-plist b/www/http_load/pkg-plist
new file mode 100644
index 000000000000..f0df23721520
--- /dev/null
+++ b/www/http_load/pkg-plist
@@ -0,0 +1 @@
+bin/http_load