aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-01 21:15:36 +0800
committermat <mat@FreeBSD.org>2016-06-01 21:15:36 +0800
commit2ad878233fa86f2aee5ae47da931d181ba41c6f6 (patch)
tree494feb823c7a0efa6fafeacaa9d18f03e331ae4d /www
parentcbe4fd39f2a61769e5e93323bfcf79f6a3b2f9f5 (diff)
downloadfreebsd-ports-gnome-2ad878233fa86f2aee5ae47da931d181ba41c6f6.tar.gz
freebsd-ports-gnome-2ad878233fa86f2aee5ae47da931d181ba41c6f6.tar.zst
freebsd-ports-gnome-2ad878233fa86f2aee5ae47da931d181ba41c6f6.zip
Github cleanup.
- Use the version tag instead of commit hash when they're the same. - Remove unnneeded variables. - Simplify go- ports when possible. - Various fixes. Sponsored by: Absolight
Diffstat (limited to 'www')
-rw-r--r--www/bareos-webui/Makefile10
-rw-r--r--www/bareos-webui/distinfo5
-rw-r--r--www/mod_rpaf2/Makefile4
-rw-r--r--www/mod_rpaf2/distinfo5
-rw-r--r--www/py-MechanicalSoup/Makefile2
-rw-r--r--www/py-MechanicalSoup/distinfo5
-rw-r--r--www/py-slumber/Makefile1
-rw-r--r--www/py-slumber/distinfo5
-rw-r--r--www/redmine-sidebar_hide/Makefile1
-rw-r--r--www/redmine-sidebar_hide/distinfo5
-rw-r--r--www/rtv/Makefile2
-rw-r--r--www/rtv/distinfo5
-rw-r--r--www/tidy-html5/Makefile1
-rw-r--r--www/tidy-html5/distinfo5
14 files changed, 30 insertions, 26 deletions
diff --git a/www/bareos-webui/Makefile b/www/bareos-webui/Makefile
index 9a184de8da5d..6b75d21575d8 100644
--- a/www/bareos-webui/Makefile
+++ b/www/bareos-webui/Makefile
@@ -2,21 +2,21 @@
# $FreeBSD$
PORTNAME= bareos-webui
+DISTVERSIONPREFIX= Release/
DISTVERSION= 15.2.2
PORTREVISION= 0
CATEGORIES= www sysutils
-USE_GITHUB= yes
-GH_ACCOUNT= bareos
-GH_PROJECT= bareos-webui
-GH_TAGNAME= 27fbfd02ab64d54e92457f0eda6ef2fd60c0cd70
-
MAINTAINER= acm@FreeBSD.org
COMMENT= A PHP-Frontend to manage Bareos over the web
LICENSE= AGPLv3 # or later
LICENSE_FILE= ${WRKSRC}/LICENSE
+USE_GITHUB= yes
+GH_ACCOUNT= bareos
+GH_PROJECT= bareos-webui
+
USES= tar:tgz
USE_PHP= openssl
NO_BUILD= yes
diff --git a/www/bareos-webui/distinfo b/www/bareos-webui/distinfo
index 865091169c0e..030f18423dc6 100644
--- a/www/bareos-webui/distinfo
+++ b/www/bareos-webui/distinfo
@@ -1,2 +1,3 @@
-SHA256 (bareos-bareos-webui-15.2.2-27fbfd02ab64d54e92457f0eda6ef2fd60c0cd70_GH0.tar.gz) = e6038b7aecf6449c4d5afa14824ab4d91c27b15ee4e97bbd4fc15b743c145a50
-SIZE (bareos-bareos-webui-15.2.2-27fbfd02ab64d54e92457f0eda6ef2fd60c0cd70_GH0.tar.gz) = 1417723
+TIMESTAMP = 1464785057
+SHA256 (bareos-bareos-webui-Release-15.2.2_GH0.tar.gz) = 6beb1fa2acfada71a241025d328f80ea585705d5428370cbf1af398c5beaa707
+SIZE (bareos-bareos-webui-Release-15.2.2_GH0.tar.gz) = 1417035
diff --git a/www/mod_rpaf2/Makefile b/www/mod_rpaf2/Makefile
index 080e6e39f3b4..193da87ff967 100644
--- a/www/mod_rpaf2/Makefile
+++ b/www/mod_rpaf2/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= mod_rpaf
-PORTVERSION= 0.6
+PORTVERSION= 0.6.0
+DISTVERSIONPREFIX= v
PORTREVISION= 3
CATEGORIES= www
PKGNAMESUFFIX= 2
@@ -12,7 +13,6 @@ COMMENT= Make proxied requests appear with client IP
USE_GITHUB= yes
GH_ACCOUNT= gnif
-GH_TAGNAME= bc7a495
USE_APACHE= 22+
AP_FAST_BUILD= yes
diff --git a/www/mod_rpaf2/distinfo b/www/mod_rpaf2/distinfo
index 24c53b9e811a..0a81ac43bdb1 100644
--- a/www/mod_rpaf2/distinfo
+++ b/www/mod_rpaf2/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gnif-mod_rpaf-0.6-bc7a495_GH0.tar.gz) = 051b7c21ee72c96d95e43eba6ff8eeb6979da3b70c9e9b300b38f3074514a2ae
-SIZE (gnif-mod_rpaf-0.6-bc7a495_GH0.tar.gz) = 7645
+TIMESTAMP = 1464785880
+SHA256 (gnif-mod_rpaf-v0.6.0_GH0.tar.gz) = f89e51d7331d336a00833d6dc1cc786430d9f9c53bbbac97f22a96dbe803c7e7
+SIZE (gnif-mod_rpaf-v0.6.0_GH0.tar.gz) = 7643
diff --git a/www/py-MechanicalSoup/Makefile b/www/py-MechanicalSoup/Makefile
index 336ecdbc9240..601f570bd90a 100644
--- a/www/py-MechanicalSoup/Makefile
+++ b/www/py-MechanicalSoup/Makefile
@@ -3,6 +3,7 @@
PORTNAME= MechanicalSoup
PORTVERSION= 0.4.0
+DISTVERSIONPREFIX= v
CATEGORIES= www python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,7 +19,6 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.7.0:www/py-requests \
USE_GITHUB= yes
GH_ACCOUNT= hickford
-GH_TAGNAME= cb0c94d
USES= python
USE_PYTHON= distutils autoplist
diff --git a/www/py-MechanicalSoup/distinfo b/www/py-MechanicalSoup/distinfo
index 8c24df6ef86c..1aac78027463 100644
--- a/www/py-MechanicalSoup/distinfo
+++ b/www/py-MechanicalSoup/distinfo
@@ -1,2 +1,3 @@
-SHA256 (hickford-MechanicalSoup-0.4.0-cb0c94d_GH0.tar.gz) = 8a5940aed5513288c2b88120f6d3b31b9f71154a523d535db02fa227c9e42792
-SIZE (hickford-MechanicalSoup-0.4.0-cb0c94d_GH0.tar.gz) = 12029
+TIMESTAMP = 1464785996
+SHA256 (hickford-MechanicalSoup-v0.4.0_GH0.tar.gz) = 51ea6f65c997e8a81d71db48255ef8134746bc53bff5a1e998f6a3999301bf5c
+SIZE (hickford-MechanicalSoup-v0.4.0_GH0.tar.gz) = 12034
diff --git a/www/py-slumber/Makefile b/www/py-slumber/Makefile
index 53600a6a94bd..5e003719d562 100644
--- a/www/py-slumber/Makefile
+++ b/www/py-slumber/Makefile
@@ -26,7 +26,6 @@ USE_GITHUB= yes
USE_PYTHON= autoplist distutils
GH_ACCOUNT= samgiles
-GH_TAGNAME= d84e140
NO_ARCH= yes
diff --git a/www/py-slumber/distinfo b/www/py-slumber/distinfo
index 9290617ff728..37f685cccad4 100644
--- a/www/py-slumber/distinfo
+++ b/www/py-slumber/distinfo
@@ -1,2 +1,3 @@
-SHA256 (samgiles-slumber-0.7.1-d84e140_GH0.tar.gz) = cbf8955b6b8cbca18e1b79f499e281c59845e5619a3f09fd8fa3c5097d276746
-SIZE (samgiles-slumber-0.7.1-d84e140_GH0.tar.gz) = 16672
+TIMESTAMP = 1464786054
+SHA256 (samgiles-slumber-0.7.1_GH0.tar.gz) = a9a8494d2a0686260407c8fc3cceb981c55d3dc94203c6d28e738739fe1d511d
+SIZE (samgiles-slumber-0.7.1_GH0.tar.gz) = 16673
diff --git a/www/redmine-sidebar_hide/Makefile b/www/redmine-sidebar_hide/Makefile
index d041ecee56d3..caac16e9567b 100644
--- a/www/redmine-sidebar_hide/Makefile
+++ b/www/redmine-sidebar_hide/Makefile
@@ -12,7 +12,6 @@ NO_ARCH= yes
USE_GITHUB= YES
GH_ACCOUNT= bdemirkir
-GH_TAGNAME= aa19281
REDMINE_PLUGIN_NAME= sidebar_hide
diff --git a/www/redmine-sidebar_hide/distinfo b/www/redmine-sidebar_hide/distinfo
index 836909be8314..41953c87159e 100644
--- a/www/redmine-sidebar_hide/distinfo
+++ b/www/redmine-sidebar_hide/distinfo
@@ -1,2 +1,3 @@
-SHA256 (bdemirkir-sidebar_hide-0.0.7-aa19281_GH0.tar.gz) = 536dde06bf5797ab761018f0c7d34870e28f85383fe1ed3b457b0a661281091f
-SIZE (bdemirkir-sidebar_hide-0.0.7-aa19281_GH0.tar.gz) = 2808
+TIMESTAMP = 1464786128
+SHA256 (bdemirkir-sidebar_hide-0.0.7_GH0.tar.gz) = 827478b0a3d8c20d752b65314d256c34244df331c1c14bfa486dfabfdb4aade0
+SIZE (bdemirkir-sidebar_hide-0.0.7_GH0.tar.gz) = 2809
diff --git a/www/rtv/Makefile b/www/rtv/Makefile
index de6e01f38014..9f7bb5bfcfd3 100644
--- a/www/rtv/Makefile
+++ b/www/rtv/Makefile
@@ -2,6 +2,7 @@
PORTNAME= rtv
PORTVERSION= 1.9.0
+DISTVERSIONPREFIX= v
CATEGORIES= www
MAINTAINER= arved@FreeBSD.org
@@ -18,7 +19,6 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tornado>=3.2:www/py-tornado \
USE_GITHUB= yes
GH_ACCOUNT= michael-lazar
-GH_TAGNAME= fc8d70f
USES= tar:xz python:3.3+
USE_PYTHON= distutils autoplist
diff --git a/www/rtv/distinfo b/www/rtv/distinfo
index 05fad8014535..5ed9c05cc633 100644
--- a/www/rtv/distinfo
+++ b/www/rtv/distinfo
@@ -1,2 +1,3 @@
-SHA256 (michael-lazar-rtv-1.9.0-fc8d70f_GH0.tar.gz) = 0a599d2790b1ef8bb29daaa2b6082f79fa01c024b238f32150266d0db62998db
-SIZE (michael-lazar-rtv-1.9.0-fc8d70f_GH0.tar.gz) = 2294344
+TIMESTAMP = 1464786201
+SHA256 (michael-lazar-rtv-v1.9.0_GH0.tar.gz) = 6d14e3995840a3e427761824250688c4bcba76c31fdf17ffe96e41ddf427aed3
+SIZE (michael-lazar-rtv-v1.9.0_GH0.tar.gz) = 2294363
diff --git a/www/tidy-html5/Makefile b/www/tidy-html5/Makefile
index fb35087b77a8..1aedaa4b1a0d 100644
--- a/www/tidy-html5/Makefile
+++ b/www/tidy-html5/Makefile
@@ -13,7 +13,6 @@ LICENSE_FILE= ${WRKSRC}/README/LICENSE.txt
USE_GITHUB= yes
GH_ACCOUNT= htacg
-GH_TAGNAME= abb0316
USES= cmake
USE_GNOME= libxslt
diff --git a/www/tidy-html5/distinfo b/www/tidy-html5/distinfo
index e5010b91d43b..57647ffe7513 100644
--- a/www/tidy-html5/distinfo
+++ b/www/tidy-html5/distinfo
@@ -1,2 +1,3 @@
-SHA256 (htacg-tidy-html5-5.2.0-abb0316_GH0.tar.gz) = 300cbc108d9d29d45ee944602a3c68923492b3fcf8f53cd05a7033b9b0174525
-SIZE (htacg-tidy-html5-5.2.0-abb0316_GH0.tar.gz) = 529048
+TIMESTAMP = 1464786241
+SHA256 (htacg-tidy-html5-5.2.0_GH0.tar.gz) = 80533415acf11ac55f24b874ab39448e390ffec3c2b93df4b857d15602fc7c4d
+SIZE (htacg-tidy-html5-5.2.0_GH0.tar.gz) = 529016