aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-09-21 19:06:03 +0800
committerdinoex <dinoex@FreeBSD.org>2013-09-21 19:06:03 +0800
commit2b046d64117ade41e336404023c6f8150293fc4a (patch)
tree2051ba0023bbf060fa37051dc7fc6990710a53b1 /www
parenta68540824c2afc9f423babe69b1494598b151be9 (diff)
downloadfreebsd-ports-gnome-2b046d64117ade41e336404023c6f8150293fc4a.tar.gz
freebsd-ports-gnome-2b046d64117ade41e336404023c6f8150293fc4a.tar.zst
freebsd-ports-gnome-2b046d64117ade41e336404023c6f8150293fc4a.zip
- fix misplaced NO_STAGE in slaveports and ifdefs
Diffstat (limited to 'www')
-rw-r--r--www/geolizer/Makefile1
-rw-r--r--www/mod_ruby/Makefile3
-rw-r--r--www/opera-linuxplugins/Makefile3
-rw-r--r--www/opera/Makefile3
-rw-r--r--www/smb_auth/Makefile3
-rw-r--r--www/thumbnail_index/Makefile6
-rw-r--r--www/tidy/Makefile3
-rw-r--r--www/twig/Makefile5
-rw-r--r--www/webalizer/Makefile2
9 files changed, 17 insertions, 12 deletions
diff --git a/www/geolizer/Makefile b/www/geolizer/Makefile
index 810d28fed5b4..3e52d5617080 100644
--- a/www/geolizer/Makefile
+++ b/www/geolizer/Makefile
@@ -9,7 +9,6 @@ MASTERDIR?= ${.CURDIR}/../webalizer
WITH_GEOIP= yes
.if exists(${.CURDIR}/Makefile.local)
-NO_STAGE= yes
.include "${.CURDIR}/Makefile.local"
.endif
diff --git a/www/mod_ruby/Makefile b/www/mod_ruby/Makefile
index 7adf03b5c86d..25d7477e390b 100644
--- a/www/mod_ruby/Makefile
+++ b/www/mod_ruby/Makefile
@@ -12,6 +12,8 @@ DIST_SUBDIR= ruby
MAINTAINER= dinoex@FreeBSD.org
COMMENT= An Apache module that embeds Ruby interpreter within
+NO_STAGE= yes
+
USES= perl5
USE_APACHE= 22
USE_RUBY= yes
@@ -28,7 +30,6 @@ DOCS_EN= COPYING ChangeLog LEGAL LICENSE.apreq NOTICE \
README.en doc/default.css doc/*.en.*
DOCS_JA= README.ja doc/default.css doc/*.ja.*
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${APACHE_VERSION} > 20
diff --git a/www/opera-linuxplugins/Makefile b/www/opera-linuxplugins/Makefile
index 628f15c7d9c4..e91b9a34a597 100644
--- a/www/opera-linuxplugins/Makefile
+++ b/www/opera-linuxplugins/Makefile
@@ -20,6 +20,8 @@ COMMENT= Linux plugin support for the native Opera browser
RUN_DEPENDS= ${LOCALBASE}/lib/opera/pluginwrapper/operapluginwrapper:${PORTSDIR}/${PKGCATEGORY}/opera
+NO_STAGE= yes
+
OPERA_VER?= 12.16
OPERA_BUILD?= 1860
MASTER_SITES_VER_PATH= linux/${OPERA_VER:S/.//}/
@@ -35,7 +37,6 @@ EXPLICIT_PACKAGE_DEPENDS= yes
PLIST_FILES= lib/opera/pluginwrapper/operapluginwrapper-ia32-linux
-NO_STAGE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/lib/opera/pluginwrapper/operapluginwrapper-native \
${PREFIX}/lib/opera/pluginwrapper/operapluginwrapper-ia32-linux
diff --git a/www/opera/Makefile b/www/opera/Makefile
index 496a1564a454..efc093a02730 100644
--- a/www/opera/Makefile
+++ b/www/opera/Makefile
@@ -21,6 +21,8 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
BUILD_DEPENDS= ${LOCALBASE}/bin/update-mime-database:${PORTSDIR}/misc/shared-mime-info
RUN_DEPENDS= ${LOCALBASE}/bin/update-mime-database:${PORTSDIR}/misc/shared-mime-info
+NO_STAGE= yes
+
OPERA_VER?= 12.16
OPERA_BUILD?= 1860
MASTER_SITES_VER_PATH= unix/${OPERA_VER:S/.//}
@@ -42,7 +44,6 @@ OPTIONS_DEFAULT= CUPS VIDEO
CUPS_DESC= support for printing (requires CUPS)
VIDEO_DESC= support for HTML5 video (requires GStreamer)
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if defined(FETCH_ALL)
diff --git a/www/smb_auth/Makefile b/www/smb_auth/Makefile
index 69b0ea8b0e5b..8e4d505c9fe6 100644
--- a/www/smb_auth/Makefile
+++ b/www/smb_auth/Makefile
@@ -15,10 +15,11 @@ COMMENT= A proxy authentication module against an SMB server
RUN_DEPENDS= ${LOCALBASE}/sbin/smbd:${PORTSDIR}/${SAMBA_PORT}
.endif
+NO_STAGE= yes
+
ALL_TARGET= smb_auth
SAMBA_PORT?= net/samba36
-NO_STAGE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/smb_auth ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/smb_auth.sh ${PREFIX}/bin
diff --git a/www/thumbnail_index/Makefile b/www/thumbnail_index/Makefile
index 5bb95c322bfe..a35fb16f5f32 100644
--- a/www/thumbnail_index/Makefile
+++ b/www/thumbnail_index/Makefile
@@ -14,10 +14,10 @@ COMMENT= Make an HTML index file for a bunch of images
RUN_DEPENDS= djpeg:${PORTSDIR}/graphics/jpeg \
pnmscale:${PORTSDIR}/graphics/netpbm
+NO_STAGE= yes
+NO_BUILD= yes
+
WRKSRC= ${WRKDIR}/${PORTNAME}
MAN1= thumbnail_index.1
-NO_BUILD= yes
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/www/tidy/Makefile b/www/tidy/Makefile
index 82459fb8701e..47e6185373f6 100644
--- a/www/tidy/Makefile
+++ b/www/tidy/Makefile
@@ -15,11 +15,12 @@ COMMENT= Fixes and tidies up HTML files
LICENSE= BSD
LICENSE_FILE= ${FILESDIR}/COPYRIGHT
+NO_STAGE= yes
+
MAN1= tidy4.1
ALL_TARGET= tidy
DOCFILES= Overview.html tidy.gif release-notes.html grid.gif
-NO_STAGE= yes
do-configure:
${REINPLACE_CMD} -e 's|tidy|tidy4|' ${WRKSRC}/man_page.txt
diff --git a/www/twig/Makefile b/www/twig/Makefile
index 667a73d2ddda..486829d48cb6 100644
--- a/www/twig/Makefile
+++ b/www/twig/Makefile
@@ -13,7 +13,9 @@ COMMENT= Web Based Email Client and Scheduler
USE_PHP= ctype imap openssl pgsql pcre posix session tokenizer xml zlib
.endif
-NO_BUILD= YES
+NO_STAGE= yes
+NO_BUILD= yes
+
TWIG?= www/twig
PLIST_SUB+= TWIG=${TWIG}
ROOTFILES= index.php test.php goto.php
@@ -23,7 +25,6 @@ USERFILES= announcements.inc.php3 config.inc.php3 dbconfig.inc.php3 \
images.inc.php3 login.footer.inc.php3 login.form.php3 \
login.header.inc.php3 mainmenu.inc.php3 newusergroups.inc.php3
-NO_STAGE= yes
do-install:
-${MKDIR} ${PREFIX}/${TWIG}/config
@(cd ${WRKSRC} && ${CP} ${ROOTFILES} ${PREFIX}/${TWIG}/ )
diff --git a/www/webalizer/Makefile b/www/webalizer/Makefile
index 32e9125caa88..b62ef11152e7 100644
--- a/www/webalizer/Makefile
+++ b/www/webalizer/Makefile
@@ -23,6 +23,7 @@ EXAMPLESDIR?= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
GD_PORT?= graphics/gd
CONFLICTS= geolizer-2*
+NO_STAGE= yes
.if defined(BATCH)
# no cosmetique spaces allowed
@@ -39,7 +40,6 @@ FULL_CGI_REFS_DESC=Show full cgi parameters in referers
CLICKABLE_REFERER_DESC=Make referers clickable
LARGE_URL_DESC=Enable URLs longer 512 bytes
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGEODB} || ${PORT_OPTIONS:MGEOIP} || make(makesum) || defined(FETCH_ALL)