aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-02-25 13:38:30 +0800
committerpat <pat@FreeBSD.org>2002-02-25 13:38:30 +0800
commit3002e47079f28b9b0214cb6438f855a58cbbaa95 (patch)
tree5ef24184695d90dd11afc79a6a78f8567e68a674 /www
parente173a5a4a2df6e84fd2615e9a91658c53cb6e4e9 (diff)
downloadfreebsd-ports-gnome-3002e47079f28b9b0214cb6438f855a58cbbaa95.tar.gz
freebsd-ports-gnome-3002e47079f28b9b0214cb6438f855a58cbbaa95.tar.zst
freebsd-ports-gnome-3002e47079f28b9b0214cb6438f855a58cbbaa95.zip
- Update to 0.94.12.r2
- Give maintainership to Alex Dupre who requested it PR: 35065, 35279 Submitted by: Paul Marquis <pmarquis@pobox.com>, Alex Dupre <sysadmin@alexdupre.com>
Diffstat (limited to 'www')
-rw-r--r--www/boa/Makefile33
-rw-r--r--www/boa/distinfo2
-rw-r--r--www/boa/files/boa.sh.sample20
-rw-r--r--www/boa/files/patch-aa13
-rw-r--r--www/boa/files/patch-ab4
-rw-r--r--www/boa/files/patch-boa.conf11
-rw-r--r--www/boa/pkg-descr18
-rw-r--r--www/boa/pkg-plist4
8 files changed, 67 insertions, 38 deletions
diff --git a/www/boa/Makefile b/www/boa/Makefile
index 7f2d3774f9ed..e77593f2c51e 100644
--- a/www/boa/Makefile
+++ b/www/boa/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= boa
-PORTVERSION= 0.94.8.3
+PORTVERSION= 0.94.12.r2
CATEGORIES= www
MASTER_SITES= http://www.boa.org/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sysadmin@alexdupre.com
WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_GMAKE= yes
@@ -19,18 +20,28 @@ GNU_CONFIGURE= yes
MAN8= boa.8
post-patch:
- @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/defines.h
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/defines.h \
+ ${WRKSRC}/../boa.conf
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/boa ${PREFIX}/sbin
- ${INSTALL_MAN} ${WRKSRC}/../docs/boa.8 ${PREFIX}/man/man8
- ${INSTALL_DATA} ${WRKSRC}/../boa.conf ${PREFIX}/etc/boa.conf.sample
- @${MKDIR} ${PREFIX}/share/examples/boa
- ${INSTALL_DATA} ${WRKSRC}/../examples/* ${PREFIX}/share/examples/boa
+ @${INSTALL_PROGRAM} ${WRKSRC}/boa ${PREFIX}/sbin
+ @${INSTALL_PROGRAM} ${WRKSRC}/boa_indexer ${PREFIX}/sbin
+ @${INSTALL_MAN} ${WRKSRC}/../docs/boa.8 ${PREFIX}/man/man8
+ @${INSTALL_DATA} ${WRKSRC}/../boa.conf ${PREFIX}/etc/boa.conf.sample
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/../examples/* ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/boa
- ${INSTALL_DATA} ${WRKSRC}/../docs/boa.sgml ${PREFIX}/share/doc/boa
- ${INSTALL_DATA} ${WRKSRC}/../docs/boa_banner.png ${PREFIX}/share/doc/boa
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/../docs/boa.texi ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/../docs/boa_banner.png ${DOCSDIR}
.endif
+post-install:
+ @if [ ! -f ${PREFIX}/etc/rc.d/boa.sh ]; then \
+ ${ECHO} "Installing ${PREFIX}/etc/rc.d/boa.sh.sample \
+ startup file."; \
+ ${INSTALL_SCRIPT} ${FILESDIR}/boa.sh.sample \
+ ${PREFIX}/etc/rc.d; \
+ fi
+
.include <bsd.port.mk>
diff --git a/www/boa/distinfo b/www/boa/distinfo
index 62dad7733a5d..a9ac66756638 100644
--- a/www/boa/distinfo
+++ b/www/boa/distinfo
@@ -1 +1 @@
-MD5 (boa-0.94.8.3.tar.gz) = 492b474bf0adf9e00e6289fe70b104ef
+MD5 (boa-0.94.12rc2.tar.gz) = db9c924b542dc44fe9cae459bbbb4faa
diff --git a/www/boa/files/boa.sh.sample b/www/boa/files/boa.sh.sample
new file mode 100644
index 000000000000..8693df9b9202
--- /dev/null
+++ b/www/boa/files/boa.sh.sample
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ [ -x ${PREFIX}/sbin/boa ] && ${PREFIX}/sbin/boa & && echo -n ' boa'
+ ;;
+stop)
+ killall boa && echo -n ' boa'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0
diff --git a/www/boa/files/patch-aa b/www/boa/files/patch-aa
deleted file mode 100644
index 9c2edcc10473..000000000000
--- a/www/boa/files/patch-aa
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.in.orig Sun Feb 13 06:52:45 2000
-+++ Makefile.in Thu Mar 30 20:22:55 2000
-@@ -12,8 +12,8 @@
- # Add -lefence to LDFLAGS to link with ElectricFence
- # Add -pg to CFLAGS and LDFLAGS to get profiling output with gcc/gprof
-
--LDFLAGS = @LIBS@ -g
--CFLAGS = -O -Wall -g
-+LDFLAGS = @LIBS@
-+CFLAGS = @CFLAGS@
-
- # Change these if necessary
-
diff --git a/www/boa/files/patch-ab b/www/boa/files/patch-ab
index f325e4723132..9fec127bd36f 100644
--- a/www/boa/files/patch-ab
+++ b/www/boa/files/patch-ab
@@ -1,5 +1,5 @@
---- defines.h.orig Fri Feb 18 13:18:42 2000
-+++ defines.h Thu Mar 30 20:31:43 2000
+--- defines.h.orig Thu Nov 1 23:37:46 2001
++++ defines.h Sun Feb 17 13:40:30 2002
@@ -27,7 +27,7 @@
/***** Change this, or use -c on the command line to specify it *****/
diff --git a/www/boa/files/patch-boa.conf b/www/boa/files/patch-boa.conf
new file mode 100644
index 000000000000..a84412f66eb7
--- /dev/null
+++ b/www/boa/files/patch-boa.conf
@@ -0,0 +1,11 @@
+--- ../boa.conf.orig Mon Sep 24 23:28:30 2001
++++ ../boa.conf Sun Feb 17 16:33:43 2002
+@@ -127,7 +127,7 @@
+ # DirectoryIndex are commented out, accessing a directory will give
+ # an error (though accessing files in the directory are still ok).
+
+-DirectoryMaker /usr/lib/boa/boa_indexer
++DirectoryMaker %%PREFIX%%/sbin/boa_indexer
+
+ # DirectoryCache: If DirectoryIndex doesn't exist, and DirectoryMaker
+ # has been commented out, the the on-the-fly indexing of Boa can be used
diff --git a/www/boa/pkg-descr b/www/boa/pkg-descr
index de0ce0c42669..d4a6aac5bdd2 100644
--- a/www/boa/pkg-descr
+++ b/www/boa/pkg-descr
@@ -6,13 +6,11 @@ connections, and forks only for CGI programs (which must be separate
processes.) Preliminary tests show boa is about twice as fast as
Apache, and is capable of handling 50 hits per second on a 66 MHz '486.
-The primary design goals of Boa are speed and security. Security, in
-the sense of "can't be subverted by a malicious user", not "fine
-grained access control and encrypted communications". Boa is not
-intended as a feature-packed server; if you want one of those, check
-out WN from John Franks. Modifications to Boa that improve its speed,
-security, robustness, and portability, are eagerly sought. Other
-features may be added if they can be achieved without hurting the
-primary goals.
-
-WWW: http://www.boa.org
+The primary design goals of Boa are speed and security. Security,
+in the sense of "can't be subverted by a malicious user", not "fine
+grained access control and encrypted communications".
+
+WWW: http://www.boa.org/
+
+- Alex Dupre
+sysadmin@alexdupre.com
diff --git a/www/boa/pkg-plist b/www/boa/pkg-plist
index 1af0920d6d00..dea29627bee9 100644
--- a/www/boa/pkg-plist
+++ b/www/boa/pkg-plist
@@ -1,6 +1,8 @@
etc/boa.conf.sample
+etc/rc.d/boa.sh.sample
sbin/boa
-%%PORTDOCS%%share/doc/boa/boa.sgml
+sbin/boa_indexer
+%%PORTDOCS%%share/doc/boa/boa.texi
%%PORTDOCS%%share/doc/boa/boa_banner.png
share/examples/boa/cgi-test.cgi
share/examples/boa/nph-test.cgi