aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2014-04-09 07:33:57 +0800
committerohauer <ohauer@FreeBSD.org>2014-04-09 07:33:57 +0800
commit4b9d0caec96e82ca254ec6c6f70c49f6601667d6 (patch)
tree8f7f1965aa4290ced8de31e88a7d8236c061a7be /www
parentd7b8ba77682c8c2b32c2d5587fd536327fe26227 (diff)
downloadfreebsd-ports-gnome-4b9d0caec96e82ca254ec6c6f70c49f6601667d6.tar.gz
freebsd-ports-gnome-4b9d0caec96e82ca254ec6c6f70c49f6601667d6.tar.zst
freebsd-ports-gnome-4b9d0caec96e82ca254ec6c6f70c49f6601667d6.zip
- fix build on FreeBSD-10+ with OpenSSL from ports
- bump PORTVERSION because of CVE-2014-0076 / CVE-2014-0160 Special Thanks to Philip Jocks for reporting and testing! http://lists.freebsd.org/pipermail/freebsd-apache/2014-April/003483.html with hat apache@
Diffstat (limited to 'www')
-rw-r--r--www/apache22/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 79fafe0a1591..db1cf7116a29 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -2,7 +2,7 @@
PORTNAME= apache22
PORTVERSION= 2.2.27
-#PORTREVISION?= 1
+PORTREVISION?= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
@@ -149,6 +149,15 @@ post-patch:
@${RM} -rf ${WRKSRC}/srclib
@${REINPLACE_CMD} -e 's/srclib//' ${WRKSRC}/Makefile.in
+# Fix build on FreeBSD-10+ with OpenSSL from ports
+.if ${PORT_OPTIONS:MSSL}
+. if ${OPSYS} == FreeBSD && ${OSVERSION} > 1000000
+. if defined(OPENSSL_INSTALLED) && ${OPENSSL_INSTALLED} != ""
+ ${REINPLACE_CMD} -e "s|(ALL_CFLAGS)|(ALL_CFLAGS) -L${OPENSSLLIB}|" ${WRKSRC}/build/rules.mk.in
+. endif
+. endif
+.endif
+
post-configure:
@FTPUSERS=`${EGREP} -v '^#' /etc/ftpusers| ${TR} -s "\n" " "` ;\
${REINPLACE_CMD} -e "s,%%FTPUSERS%%,$${FTPUSERS}," ${WRKSRC}/docs/conf/extra/httpd-userdir.conf