aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2016-05-26 07:43:23 +0800
committerosa <osa@FreeBSD.org>2016-05-26 07:43:23 +0800
commit53f09f62f632a1c4bd954f4f9dc3f19c6746d24a (patch)
tree4efaf79ba99cf8f394dc47645b0435a296b334ad /www
parentf188578bbf80d6659c5a37ea617b74f7577595db (diff)
downloadfreebsd-ports-gnome-53f09f62f632a1c4bd954f4f9dc3f19c6746d24a.tar.gz
freebsd-ports-gnome-53f09f62f632a1c4bd954f4f9dc3f19c6746d24a.tar.zst
freebsd-ports-gnome-53f09f62f632a1c4bd954f4f9dc3f19c6746d24a.zip
Upgrade from 1.10.0 to 1.11.0.
<ChangeLog> *) Feature: the "transparent" parameter of the "proxy_bind", "fastcgi_bind", "memcached_bind", "scgi_bind", and "uwsgi_bind" directives. *) Feature: the $request_id variable. *) Feature: the "map" directive supports combinations of multiple variables as resulting values. *) Feature: now nginx checks if EPOLLRDHUP events are supported by kernel, and optimizes connection handling accordingly if the "epoll" method is used. *) Feature: the "ssl_certificate" and "ssl_certificate_key" directives can be specified multiple times to load certificates of different types (for example, RSA and ECDSA). *) Feature: the "ssl_ecdh_curve" directive now allows specifying a list of curves when using OpenSSL 1.0.2 or newer; by default a list built into OpenSSL is used. *) Change: to use DHE ciphers it is now required to specify parameters using the "ssl_dhparam" directive. *) Feature: the $proxy_protocol_port variable. *) Feature: the $realip_remote_port variable in the ngx_http_realip_module. *) Feature: the ngx_http_realip_module is now able to set the client port in addition to the address. *) Change: the "421 Misdirected Request" response now used when rejecting requests to a virtual server different from one negotiated during an SSL handshake; this improves interoperability with some HTTP/2 clients when using client certificates. *) Change: HTTP/2 clients can now start sending request body immediately; the "http2_body_preread_size" directive controls size of the buffer used before nginx will start reading client request body. *) Bugfix: cached error responses were not updated when using the "proxy_cache_bypass" directive. </ChangeLog>
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile6
-rw-r--r--www/nginx-devel/distinfo5
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_inet_slab.c29
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_rtmp_core_module.c20
-rw-r--r--www/nginx-devel/files/extra-patch-src-c-ngx_http_clojure_socket.c11
5 files changed, 67 insertions, 4 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index c34b68370a96..d76e1a993805 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nginx
-PORTVERSION= 1.10.0
-PORTREVISION= 3
+PORTVERSION= 1.11.0
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
MASTER_SITES+= LOCAL/osa
@@ -412,6 +411,7 @@ GH_PROJECT+= nginx-clojure:clojure
GH_TAGNAME+= v${NGINX_CLOJURE_VERSION}:clojure
CONFIGURE_ENV+= "JNI_INCS=-I${LOCALBASE}/openjdk8/include -I${LOCALBASE}/openjdk8/include/freebsd"
CONFIGURE_ARGS+=--add-module=${WRKSRC_clojure}/src/c
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src-c-ngx_http_clojure_socket.c
.endif
.if ${PORT_OPTIONS:MCT}
@@ -747,6 +747,7 @@ CONFIGURE_ARGS+=--add-dynamic-module=${WRKSRC_dyn_upstream}
.else
CONFIGURE_ARGS+=--add-module=${WRKSRC_dyn_upstream}
.endif
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_inet_slab.c
.endif
.if ${PORT_OPTIONS:MARRAYVAR} || ${PORT_OPTIONS:MENCRYPTSESSION} || ${PORT_OPTIONS:MFORMINPUT} || ${PORT_OPTIONS:MICONV} || ${PORT_OPTIONS:MLUA} || ${PORT_OPTIONS:MSET_MISC}
@@ -894,6 +895,7 @@ GH_ACCOUNT+= arut:rtmp
GH_PROJECT+= nginx-rtmp-module:rtmp
GH_TAGNAME+= v${NGINX_RTMP_VERSION}:rtmp
CONFIGURE_ARGS+=--add-module=${WRKSRC_rtmp}
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_rtmp_core_module.c
.endif
.if ${PORT_OPTIONS:MSET_MISC}
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 07d32ab5c2a5..76348331b320 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,5 +1,6 @@
-SHA256 (nginx-1.10.0.tar.gz) = 8ed647c3dd65bc4ced03b0e0f6bf9e633eff6b01bac772bcf97077d58bc2be4d
-SIZE (nginx-1.10.0.tar.gz) = 908954
+TIMESTAMP = 1464123738
+SHA256 (nginx-1.11.0.tar.gz) = 6ca0e7bf540cdae387ce9470568c2c3a826bc7e7f12def1ae7d20b66f4065a99
+SIZE (nginx-1.11.0.tar.gz) = 913282
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
SIZE (nginx-accesskey-2.0.3.tar.gz) = 2632
SHA256 (ngx_http_auth_pam_module-1.2.tar.gz) = 5a85970ba61a99f55a26d2536a11d512b39bbd622f5737d25a9a8c10db81efa9
diff --git a/www/nginx-devel/files/extra-patch-ngx_inet_slab.c b/www/nginx-devel/files/extra-patch-ngx_inet_slab.c
new file mode 100644
index 000000000000..74855f083e11
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-ngx_inet_slab.c
@@ -0,0 +1,29 @@
+--- ../ngx_dynamic_upstream-0.1.3/src/ngx_inet_slab.c.orig 2016-05-25 19:27:27.204200000 -0400
++++ ../ngx_dynamic_upstream-0.1.3/src/ngx_inet_slab.c 2016-05-25 19:28:07.177622000 -0400
+@@ -250,7 +250,7 @@
+ return NGX_ERROR;
+ }
+
+- ngx_memcpy(sin, u->sockaddr, sizeof(struct sockaddr_in));
++ ngx_memcpy(sin, &u->sockaddr, sizeof(struct sockaddr_in));
+
+ u->addrs[0].sockaddr = (struct sockaddr *) sin;
+ u->addrs[0].socklen = sizeof(struct sockaddr_in);
+@@ -277,7 +277,7 @@
+
+ u->family = u->addrs[0].sockaddr->sa_family;
+ u->socklen = u->addrs[0].socklen;
+- ngx_memcpy(u->sockaddr, u->addrs[0].sockaddr, u->addrs[0].socklen);
++ ngx_memcpy(&u->sockaddr, u->addrs[0].sockaddr, u->addrs[0].socklen);
+
+ switch (u->family) {
+
+@@ -405,7 +405,7 @@
+ return NGX_ERROR;
+ }
+
+- ngx_memcpy(sin6, u->sockaddr, sizeof(struct sockaddr_in6));
++ ngx_memcpy(sin6, &u->sockaddr, sizeof(struct sockaddr_in6));
+
+ u->addrs[0].sockaddr = (struct sockaddr *) sin6;
+ u->addrs[0].socklen = sizeof(struct sockaddr_in6);
diff --git a/www/nginx-devel/files/extra-patch-ngx_rtmp_core_module.c b/www/nginx-devel/files/extra-patch-ngx_rtmp_core_module.c
new file mode 100644
index 000000000000..91d82da948a8
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-ngx_rtmp_core_module.c
@@ -0,0 +1,20 @@
+--- ../nginx-rtmp-module-1.1.7/ngx_rtmp_core_module.c.orig 2016-05-25 19:25:35.779720000 -0400
++++ ../nginx-rtmp-module-1.1.7/ngx_rtmp_core_module.c 2016-05-25 19:26:28.055352000 -0400
+@@ -545,7 +545,7 @@
+ break;
+ }
+
+- if (ngx_memcmp(ls[i].sockaddr + off, u.sockaddr + off, len) != 0) {
++ if (ngx_memcmp(ls[i].sockaddr + off, &u.sockaddr + off, len) != 0) {
+ continue;
+ }
+
+@@ -565,7 +565,7 @@
+
+ ngx_memzero(ls, sizeof(ngx_rtmp_listen_t));
+
+- ngx_memcpy(ls->sockaddr, u.sockaddr, u.socklen);
++ ngx_memcpy(ls->sockaddr, &u.sockaddr, u.socklen);
+
+ ls->socklen = u.socklen;
+ ls->wildcard = u.wildcard;
diff --git a/www/nginx-devel/files/extra-patch-src-c-ngx_http_clojure_socket.c b/www/nginx-devel/files/extra-patch-src-c-ngx_http_clojure_socket.c
new file mode 100644
index 000000000000..9ed68350ee74
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-src-c-ngx_http_clojure_socket.c
@@ -0,0 +1,11 @@
+--- ../nginx-clojure-0.4.4/src/c/ngx_http_clojure_socket.c.orig 2016-05-24 17:39:48.898351000 -0400
++++ ../nginx-clojure-0.4.4/src/c/ngx_http_clojure_socket.c 2016-05-25 19:23:44.584704000 -0400
+@@ -317,7 +317,7 @@
+ }
+ u->resolved->host.data = url->host.data;
+ u->resolved->host.len = url->host.len;
+- ngx_http_clojure_socket_upstream_connect(u, (struct sockaddr *)url->sockaddr, url->socklen);
++ ngx_http_clojure_socket_upstream_connect(u, &url->sockaddr, url->socklen);
+ }
+
+ static void ngx_http_clojure_socket_upstream_connect_inner(ngx_http_clojure_socket_upstream_t *u) {