aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-01-13 00:11:30 +0800
committermiwi <miwi@FreeBSD.org>2008-01-13 00:11:30 +0800
commit600cb67e94b4d49622b9d450eecea72efda68f24 (patch)
tree1e24e5628130bdb17b7deea50ff64683c1b9de50 /www
parent49aecb609d27d2781550bc4ac392491e699971dd (diff)
downloadfreebsd-ports-gnome-600cb67e94b4d49622b9d450eecea72efda68f24.tar.gz
freebsd-ports-gnome-600cb67e94b4d49622b9d450eecea72efda68f24.tar.zst
freebsd-ports-gnome-600cb67e94b4d49622b9d450eecea72efda68f24.zip
FCGI::Spawn is used to serve as a FastCGI process manager. Besides
the features the FCGI::ProcManager posess itself, the FCGI::Spawn is targeted as web server admin understandable instance for building the own fastcgi server with copy-on-write memory sharing among forks and with single input parameters like socket path and processes number. Another thing to mention is that it is able to execute any file pointed by Web server. So we have the daemon that is hot ready for hosting providing. WWW: http://search.cpan.org/dist/FCGI-ProcManager/ PR: ports/119010 Submitted by: Peter <peter at vereshagin.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-FCGI-Spawn/Makefile24
-rw-r--r--www/p5-FCGI-Spawn/distinfo3
-rw-r--r--www/p5-FCGI-Spawn/pkg-descr10
-rw-r--r--www/p5-FCGI-Spawn/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a87391ef25b9..9fb82c922296 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -699,6 +699,7 @@
SUBDIR += p5-FAQ-OMatic
SUBDIR += p5-FCGI-Async
SUBDIR += p5-FCGI-ProcManager
+ SUBDIR += p5-FCGI-Spawn
SUBDIR += p5-FEAR-API
SUBDIR += p5-FastCGI
SUBDIR += p5-FastCGI-ProcManager
diff --git a/www/p5-FCGI-Spawn/Makefile b/www/p5-FCGI-Spawn/Makefile
new file mode 100644
index 000000000000..262a08b14b0f
--- /dev/null
+++ b/www/p5-FCGI-Spawn/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-FCGI-Spawn
+# Date created: 2007-12-28
+# Whom: Peter <peter@vereshagin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= FCGI-Spawn
+PORTVERSION= 0.1
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= FCGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= peter@vereshagin.org
+COMMENT= Process manager/application server for FastCGI protocol
+
+RUN_DEPENDS= ${SITE_PERL}/FCGI/ProcManager.pm:${PORTSDIR}/www/p5-FCGI-ProcManager
+
+PERL_CONFIGURE= yes
+
+MAN3= FCGI::Spawn.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-FCGI-Spawn/distinfo b/www/p5-FCGI-Spawn/distinfo
new file mode 100644
index 000000000000..2f062febaace
--- /dev/null
+++ b/www/p5-FCGI-Spawn/distinfo
@@ -0,0 +1,3 @@
+MD5 (FCGI-Spawn-0.1.tar.gz) = 356d9d34f37ae06c40a463fae325c82b
+SHA256 (FCGI-Spawn-0.1.tar.gz) = 807b16e6aa1d65432457a78627b09e14a97631cde4f19691f6f9c8a4ff1e323e
+SIZE (FCGI-Spawn-0.1.tar.gz) = 3729
diff --git a/www/p5-FCGI-Spawn/pkg-descr b/www/p5-FCGI-Spawn/pkg-descr
new file mode 100644
index 000000000000..cfbf33387e86
--- /dev/null
+++ b/www/p5-FCGI-Spawn/pkg-descr
@@ -0,0 +1,10 @@
+FCGI::Spawn is used to serve as a FastCGI process manager. Besides
+the features the FCGI::ProcManager posess itself, the FCGI::Spawn
+is targeted as web server admin understandable instance for building
+the own fastcgi server with copy-on-write memory sharing among forks
+and with single input parameters like socket path and processes number.
+Another thing to mention is that it is able to execute any file pointed
+by Web server. So we have the daemon that is hot ready for hosting
+providing.
+
+WWW: http://search.cpan.org/dist/FCGI-ProcManager/
diff --git a/www/p5-FCGI-Spawn/pkg-plist b/www/p5-FCGI-Spawn/pkg-plist
new file mode 100644
index 000000000000..d40f25c682aa
--- /dev/null
+++ b/www/p5-FCGI-Spawn/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/FCGI/Spawn.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI/Spawn/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI/Spawn
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI
+@dirrmtry %%SITE_PERL%%/FCGI