aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
committertijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
commit6255104baacfdd2c23e07550f90d2f9a7020ca87 (patch)
tree516db145d6cf5fd4d2666f811272aad577272ac5 /www
parent016de2316ed16336a58b66dafd7f332614a041ac (diff)
downloadfreebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.gz
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.zst
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.zip
- Replace Mk/bsd.linux-apps.mk and Mk/bsd.linux-rpm.mk with
Mk/Uses/linux.mk. - Replace USE_LINUX=yes with USES+=linux and USE_LINUX=(.*) with USES+=linux:\1 in all ports. - Replace USE_LINUX_APPS with USE_LINUX in all ports. - Use INSTALL_SCRIPT instead of INSTALL_PROGRAM to install scripts in some ports. - When USE_LINUX_RPM is defined, simplify the way DISTFILES and EXTRACT_ONLY are defined. - Remove BRANDELF_DIRS and BRANDELF_FILES handling. In the very rare cases that it is still necessary ports can run ${BRANDELF} from post-patch. - Remove AUTOMATIC_PLIST handling. Only one port used it. - Fix Linux MASTER_SITES. - Replace OVERRIDE_LINUX_BASE_PORT and OVERRIDE_LINUX_NONBASE_PORTS with default versions framework. - bsd.port.mk: - Move Linux related bits to Uses/linux.mk, except USE_LINUX_PREFIX. - Put USE_LINUX_PREFIX handling after USES processing. - Define DOCSDIR, DATADIR, etc. after handling USE_LINUX_PREFIX so it can give these variables a different default value. - When a package needs to run Linux ldconfig check before installation if Linux support is enabled. - emulators/linux_base-*: - Use USES=linux and remove duplication. - Remove files/lp. FreeBSD or CUPS lp(1) should work. - Remove files/yp.conf. No longer seems to be used. - Remove pkg-deinstall and move pkg-install into pkg-plist. - Update pkg-descr and pkg-message. - Fix handling of ldconfig cache in pkg-plist. - devel/fb-adb: Use a Linux shell to run a Linux script but patch the script to use FreeBSD mkdir so mkdir -p $path creates $path and not /compat/linux/$path. PR: 211645 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'www')
-rw-r--r--www/linux-c6-flashplugin11/Makefile10
-rw-r--r--www/linux-c6-qt47-webkit/Makefile9
-rw-r--r--www/linux-f10-flashplugin11/Makefile4
-rw-r--r--www/linux-firefox/Makefile2
-rw-r--r--www/linux-firefox/pkg-plist4
-rw-r--r--www/linux-opera/Makefile5
-rw-r--r--www/linux-seamonkey/Makefile2
-rw-r--r--www/linux-seamonkey/Makefile.common41
-rw-r--r--www/linux-seamonkey/pkg-plist4
-rw-r--r--www/nspluginwrapper/Makefile5
-rw-r--r--www/opera-linuxplugins/Makefile5
11 files changed, 20 insertions, 71 deletions
diff --git a/www/linux-c6-flashplugin11/Makefile b/www/linux-c6-flashplugin11/Makefile
index 33951af73f7d..ef59120c6cd1 100644
--- a/www/linux-c6-flashplugin11/Makefile
+++ b/www/linux-c6-flashplugin11/Makefile
@@ -15,8 +15,8 @@ MAINTAINER= emulation@FreeBSD.org
COMMENT= Adobe Flash Player NPAPI Plugin
ONLY_FOR_ARCHS= amd64 i386
-USE_LINUX?= c6
-USE_LINUX_APPS= curl cyrus-sasl2 gdkpixbuf2 gtk2 nspr nss
+USES?= linux:c6
+USE_LINUX= curl cyrus-sasl2 gdkpixbuf2 gtk2 nspr nss
RESTRICTED= Redistribution not allowed
RESTRICTED_FILES= ${DISTFILES:Nlinux-f10-flashsupport*:C/:[^:]+$//}
@@ -24,15 +24,15 @@ RESTRICTED_FILES= ${DISTFILES:Nlinux-f10-flashsupport*:C/:[^:]+$//}
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USES= webplugin:linux desktop-file-utils cpe
+USES+= webplugin:linux desktop-file-utils cpe
WEBPLUGIN_FILES= libflashplayer.so
OPTIONS_DEFINE= ALSA
OPTIONS_SUB= yes
ALSA_DESC= ALSA audio output (broken, needs lemul)
-ALSA_USE= LINUX_APPS=alsalib,alsa-plugins-oss
-ALSA_USE_OFF?= LINUX_APPS=openssl-compat
+ALSA_USE= LINUX=alsalib,alsa-plugins-oss
+ALSA_USE_OFF?= LINUX=openssl-compat
ALSA_DISTFILES_OFF= linux-f10-flashsupport-9.0.1.i386.tar.gz:suplib
ALSA_PLIST_SUB_OFF= LINUXBASE="${LINUXBASE}"
diff --git a/www/linux-c6-qt47-webkit/Makefile b/www/linux-c6-qt47-webkit/Makefile
index acb17a239f1f..a0b42f67c5a7 100644
--- a/www/linux-c6-qt47-webkit/Makefile
+++ b/www/linux-c6-qt47-webkit/Makefile
@@ -13,14 +13,13 @@ DIST_SUBDIR= rpm/${LINUX_RPM_ARCH}/atrpms/6
MAINTAINER= emulation@FreeBSD.org
COMMENT= RPM of QT4 (Linux CentOS 6)
-ONLY_FOR_ARCHS= i386 amd64
RPMVERSION= 1_18.el6
-USE_LINUX= c6
-USE_LINUX_APPS= fontconfig png xorglibs sqlite3 qt47 qt47-x11
-USE_LINUX_RPM= yes
+USES= linux:c6
USE_LDCONFIG= yes
+USE_LINUX= fontconfig png xorglibs sqlite3 qt47 qt47-x11
+USE_LINUX_RPM= yes
DESCR= ${.CURDIR}/../../www/webkit-gtk3/pkg-descr # contains no GTK references, reuse
-SRC_DISTFILES:= # unretrievable
+SRC_DISTFILES= # unretrievable
.include <bsd.port.mk>
diff --git a/www/linux-f10-flashplugin11/Makefile b/www/linux-f10-flashplugin11/Makefile
index c5d8cdda18b6..5b5aa79d0992 100644
--- a/www/linux-f10-flashplugin11/Makefile
+++ b/www/linux-f10-flashplugin11/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PKGNAMEPREFIX= linux-f10-
-USE_LINUX= f10
+USES= linux:f10
MASTERDIR= ${.CURDIR}/../linux-c6-flashplugin11
-ALSA_USE_OFF= LINUX_APPS=openssl
+ALSA_USE_OFF= LINUX=openssl
.include "${MASTERDIR}/Makefile"
diff --git a/www/linux-firefox/Makefile b/www/linux-firefox/Makefile
index 176ecfdb2504..161f8fc5af2e 100644
--- a/www/linux-firefox/Makefile
+++ b/www/linux-firefox/Makefile
@@ -14,8 +14,6 @@ COMMENT= Web browser based on the browser portion of Mozilla
USES= tar:bzip2
-WANT_GTK218= yes
-
PREFS_FILE= ${WRKSRC}/${APP_SUBDIR}defaults/preferences/browser-prefs.js
APP_SUBDIR= browser/ # plugins, extensions
diff --git a/www/linux-firefox/pkg-plist b/www/linux-firefox/pkg-plist
index 11dd868ec1ae..a1b1f4e79ab1 100644
--- a/www/linux-firefox/pkg-plist
+++ b/www/linux-firefox/pkg-plist
@@ -29,10 +29,6 @@ lib/%%APP_NAME%%/gmp-clearkey/0.1/libclearkey.so
lib/%%APP_NAME%%/icons/updater.png
lib/%%APP_NAME%%/libfreebl3.chk
lib/%%APP_NAME%%/libfreebl3.so
-%%GTK218%%lib/%%APP_NAME%%/libgdk-x11-2.0.so.0
-%%GTK218%%lib/%%APP_NAME%%/libgio-2.0.so.0
-%%GTK218%%lib/%%APP_NAME%%/libglib-2.0.so.0
-%%GTK218%%lib/%%APP_NAME%%/libgtk-x11-2.0.so.0
lib/%%APP_NAME%%/liblgpllibs.so
lib/%%APP_NAME%%/libmozsqlite3.so
lib/%%APP_NAME%%/libnspr4.so
diff --git a/www/linux-opera/Makefile b/www/linux-opera/Makefile
index b4c7a6572711..521cd22b3b13 100644
--- a/www/linux-opera/Makefile
+++ b/www/linux-opera/Makefile
@@ -20,10 +20,9 @@ COMMENT= Blazingly fast, full-featured, standards-compliant browser
RUN_DEPENDS= update-mime-database:misc/shared-mime-info
-USE_LINUX= yes
-USE_LINUX_APPS= gtk2 naslibs png sqlite3 xorglibs
+USES= desktop-file-utils linux shared-mime-info tar:xz
+USE_LINUX= gtk2 naslibs png sqlite3 xorglibs
ONLY_FOR_ARCHS= i386 amd64
-USES= desktop-file-utils shared-mime-info tar:xz
WANT_GNOME= yes
INSTALLS_ICONS= yes
diff --git a/www/linux-seamonkey/Makefile b/www/linux-seamonkey/Makefile
index 3ee945676b8b..a30acab46ff9 100644
--- a/www/linux-seamonkey/Makefile
+++ b/www/linux-seamonkey/Makefile
@@ -12,7 +12,5 @@ COMMENT= The open source, standards compliant web browser
USES= tar:bzip2
-WANT_GTK218= yes
-
.include "${.CURDIR}/Makefile.common"
.include <bsd.port.mk>
diff --git a/www/linux-seamonkey/Makefile.common b/www/linux-seamonkey/Makefile.common
index 286ed96ad05d..6bb0576de639 100644
--- a/www/linux-seamonkey/Makefile.common
+++ b/www/linux-seamonkey/Makefile.common
@@ -1,35 +1,19 @@
# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-.if !defined(OVERRIDE_LINUX_NONBASE_PORTS) || \
- ${OVERRIDE_LINUX_NONBASE_PORTS} != "f10"
-.undef WANT_GTK218
-.endif
CATEGORIES+= linux
MASTER_SITES?= MOZILLA/${PORTNAME}/releases/${PORTVERSION}esr/linux-i686/en-US
PKGNAMEPREFIX?= linux-
-.if defined(WANT_GTK218)
-MASTER_SITES+= https://archives.fedoraproject.org/pub/archive/fedora/linux/releases/12/Everything/i386/os/Packages/:f12
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- glib2-2.22.2-2.fc12.i686.rpm:f12 \
- gtk2-2.18.3-19.fc12.i686.rpm:f12
-GTK218_FILES= lib/libgio-2.0.so.0 \
- lib/libglib-2.0.so.0 \
- usr/lib/libgdk-x11-2.0.so.0 \
- usr/lib/libgtk-x11-2.0.so.0
-.endif
-
-USES+= cpe
+USES+= cpe linux
CPE_VENDOR?= mozilla
CPE_TARGET_SW?= linux
+USE_LINUX+= alsalib alsa-plugins-oss atk dbusglib dbuslibs \
+ fontconfig gtk2 hicontheme pango
NO_BUILD= yes
ONLY_FOR_ARCHS= i386 amd64
APP_NAME= ${PKGBASE}
BIN_NAME?= ${PORTNAME}
-USE_LINUX= yes
-USE_LINUX_APPS+=alsalib alsa-plugins-oss atk dbusglib dbuslibs \
- fontconfig gtk2 hicontheme pango
WRKSRC?= ${WRKDIR}/${BIN_NAME}
FDIR= ${STAGEDIR}${PREFIX}/lib/${APP_NAME}
@@ -46,12 +30,6 @@ DESKTOP_SUFFIX?= (Linux, devel)
.endif
DESKTOP_SUFFIX?= (Linux)
-.if defined(WANT_GTK218)
-PLIST_SUB+= GTK218=""
-.else
-PLIST_SUB+= GTK218="@comment "
-.endif
-
_A= >> ${TMPPLIST}
_Q= 2>/dev/null || true
@@ -60,14 +38,6 @@ post-extract:
@${RM} -rf ${WRKSRC}/updates
@${LN} -sf ${LOCALBASE}/lib/browser_plugins/symlinks/${APP_NAME} \
${WRKSRC}/${APP_SUBDIR}plugins
-. if defined(WANT_GTK218)
-. for f in ${GTK218_FILES}
- @${CP} -p ${WRKDIR}/${f} ${WRKSRC}
- @${ECHO_CMD} ${f:T} >>${WRKSRC}/dependentlibs.list
-. endfor
- @${REINPLACE_CMD} -i '' '/libxul/ { h; d; }; $$G' \
- ${WRKSRC}/dependentlibs.list
-. endif
.endif
@@ -121,11 +91,6 @@ create-plist: build
%D/lib/%%APP_NAME%%/${APP_SUBDIR}extensions/ ${_Q}' >> ${PLIST}
${ECHO_CMD} '@unexec ${FIND} %D/lib/%%APP_NAME%%/${APP_SUBDIR}extensions/ \
-depth 1 -type l -delete ${_Q}' >> ${PLIST}
-.if defined(WANT_GTK218)
-. for f in ${GTK218_FILES}
- ${REINPLACE_CMD} -i '' '/${f:T}/s/^/%%GTK218%%/' ${PLIST}
-. endfor
-.endif
snatch-desktop:
${SED} -E -e 's/${PORTNAME}/${APP_NAME}/' \
diff --git a/www/linux-seamonkey/pkg-plist b/www/linux-seamonkey/pkg-plist
index 27d9c8784d6b..c79bfe75cb94 100644
--- a/www/linux-seamonkey/pkg-plist
+++ b/www/linux-seamonkey/pkg-plist
@@ -81,10 +81,6 @@ lib/%%APP_NAME%%/isp/movemail.rdf
lib/%%APP_NAME%%/isp/rss.rdf
lib/%%APP_NAME%%/libfreebl3.chk
lib/%%APP_NAME%%/libfreebl3.so
-%%GTK218%%lib/%%APP_NAME%%/libgdk-x11-2.0.so.0
-%%GTK218%%lib/%%APP_NAME%%/libgio-2.0.so.0
-%%GTK218%%lib/%%APP_NAME%%/libglib-2.0.so.0
-%%GTK218%%lib/%%APP_NAME%%/libgtk-x11-2.0.so.0
lib/%%APP_NAME%%/libldap60.so
lib/%%APP_NAME%%/libldif60.so
lib/%%APP_NAME%%/liblgpllibs.so
diff --git a/www/nspluginwrapper/Makefile b/www/nspluginwrapper/Makefile
index 4989bb98c428..8c222756289d 100644
--- a/www/nspluginwrapper/Makefile
+++ b/www/nspluginwrapper/Makefile
@@ -26,12 +26,11 @@ BINFILE= ${PORTNAME}-i386-${PORTVERSION}-${BINBUILD}${EXTRACT_SUFX}
ONLY_FOR_ARCHS= i386 amd64
HAS_CONFIGURE= yes
+USES= gmake gnome linux pkgconfig
USE_GNOME= glib20 gtk20
USE_LDCONFIG= yes
-USE_LINUX= yes
-USE_LINUX_APPS= gtk2
+USE_LINUX= gtk2
USE_XORG= x11 xext xt
-USES= gmake pkgconfig
CFLAGS+= -std=c99
diff --git a/www/opera-linuxplugins/Makefile b/www/opera-linuxplugins/Makefile
index 476d4d2c5243..ae266711af5c 100644
--- a/www/opera-linuxplugins/Makefile
+++ b/www/opera-linuxplugins/Makefile
@@ -23,9 +23,8 @@ OPERA_VER?= 12.16
OPERA_BUILD?= 1860
MASTER_SITES_VER_PATH= linux/${OPERA_VER:S/.//}/
-USES= tar:xz
-USE_LINUX= yes
-USE_LINUX_APPS= xorglibs
+USES= linux tar:xz
+USE_LINUX= xorglibs
ONLY_FOR_ARCHS= i386 amd64