aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-11-25 01:40:44 +0800
committermat <mat@FreeBSD.org>2013-11-25 01:40:44 +0800
commit636603b4256acd6500e9ea55ddd74f51e9ed605d (patch)
treef9d8301a9f6d3b115d6bf94c75a45e2ab5278877 /www
parentc9f522e23f02154df2d9ac4a762e4f63f9333137 (diff)
downloadfreebsd-ports-gnome-636603b4256acd6500e9ea55ddd74f51e9ed605d.tar.gz
freebsd-ports-gnome-636603b4256acd6500e9ea55ddd74f51e9ed605d.tar.zst
freebsd-ports-gnome-636603b4256acd6500e9ea55ddd74f51e9ed605d.zip
- Wrap up cd && foo in parenthesis, it'd break with bmake -j
- Replace some FIND ... CPIO with COPYTREE_SHARE.
Diffstat (limited to 'www')
-rw-r--r--www/p5-WWW-Mechanize-Shell/Makefile8
-rw-r--r--www/p5-WWW-Mechanize/Makefile4
2 files changed, 6 insertions, 6 deletions
diff --git a/www/p5-WWW-Mechanize-Shell/Makefile b/www/p5-WWW-Mechanize-Shell/Makefile
index f51dbd374a44..2c08b0a9d616 100644
--- a/www/p5-WWW-Mechanize-Shell/Makefile
+++ b/www/p5-WWW-Mechanize-Shell/Makefile
@@ -34,13 +34,13 @@ EXAMPLES= banking.postbank.de.mech hotmail.signup.mech wwwshell.pl
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}/
- cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
- cd ${WRKSRC}/bin/ && ${INSTALL_DATA} ${EXAMPLES} ${STAGEDIR}${EXAMPLESDIR}/
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/bin && ${INSTALL_DATA} ${EXAMPLES} ${STAGEDIR}${EXAMPLESDIR})
@${ECHO_MSG} "===> Documentation installed in ${EXAMPLESDIR}."
.endif
diff --git a/www/p5-WWW-Mechanize/Makefile b/www/p5-WWW-Mechanize/Makefile
index 6ffc0104582b..e9a00fe3f3c0 100644
--- a/www/p5-WWW-Mechanize/Makefile
+++ b/www/p5-WWW-Mechanize/Makefile
@@ -33,8 +33,8 @@ PORTDOCS= ${DOCS:T}
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${STAGEDIR}${DOCSDIR}/
- cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif