aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-05-28 01:34:05 +0800
committermiwi <miwi@FreeBSD.org>2007-05-28 01:34:05 +0800
commit69600b5ab245e11e5fbf3265f8324a44dd66081a (patch)
tree5f16bb35d420cba92fd710e9da3fb8eb06acd529 /www
parent8f21ffc80fb116ce0093091f59bee36b99737a20 (diff)
downloadfreebsd-ports-gnome-69600b5ab245e11e5fbf3265f8324a44dd66081a.tar.gz
freebsd-ports-gnome-69600b5ab245e11e5fbf3265f8324a44dd66081a.tar.zst
freebsd-ports-gnome-69600b5ab245e11e5fbf3265f8324a44dd66081a.zip
This is a release of the SARA package email2trac that contains utilities that
we use to convert emails to trac tickets. The initial setup was made by Daniel Lundin from Edgewall Software. SARA has extend the initial setup, with the following extensions: * HTML messages * Attachments * Use commandline options * Use config file to change the behaviour of the email2trac.py program * unicode support for special characters in the headers of an email message WWW: https://subtrac.sara.nl/oss/email2trac Submitted by: Gerrit Beine <gerrit.beine at gmx.de>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-email2trac/Makefile31
-rw-r--r--www/trac-email2trac/distinfo3
-rw-r--r--www/trac-email2trac/pkg-descr12
-rw-r--r--www/trac-email2trac/pkg-plist4
5 files changed, 51 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index cb279bfac458..9f86dcbbaf1b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1154,6 +1154,7 @@
SUBDIR += trac-codetags
SUBDIR += trac-ctxtnavadd
SUBDIR += trac-down
+ SUBDIR += trac-email2trac
SUBDIR += trac-gantt
SUBDIR += trac-hierwiki
SUBDIR += trac-iniadmin
diff --git a/www/trac-email2trac/Makefile b/www/trac-email2trac/Makefile
new file mode 100644
index 000000000000..4013a52b7065
--- /dev/null
+++ b/www/trac-email2trac/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: trac-email2trac
+# Date created: May 18 2007
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= email2trac
+PORTVERSION= 0.9.5
+CATEGORIES= www devel python
+MASTER_SITES= ftp://ftp.sara.nl/pub/outgoing/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Convert email to trac tickets
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+GNU_CONFIGURE= yes
+USE_PYTHON= 2.3+
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/delete_spam.py ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/email2trac.py ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/run_email2trac ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/email2trac.conf ${PREFIX}/etc
+
+.include <bsd.port.mk>
diff --git a/www/trac-email2trac/distinfo b/www/trac-email2trac/distinfo
new file mode 100644
index 000000000000..a2b3e6e6aa47
--- /dev/null
+++ b/www/trac-email2trac/distinfo
@@ -0,0 +1,3 @@
+MD5 (email2trac.tar.gz) = 6703f63beb2024f14cb55f6ea672d836
+SHA256 (email2trac.tar.gz) = 33b1eedfdfd4d09a16d8a99ab3f2ec702b59662176c7d05ba13e81c17a7e47f3
+SIZE (email2trac.tar.gz) = 72000
diff --git a/www/trac-email2trac/pkg-descr b/www/trac-email2trac/pkg-descr
new file mode 100644
index 000000000000..f9d88d51595c
--- /dev/null
+++ b/www/trac-email2trac/pkg-descr
@@ -0,0 +1,12 @@
+This is a release of the SARA package email2trac that contains utilities that
+we use to convert emails to trac tickets. The initial setup was made by Daniel
+Lundin from Edgewall Software. SARA has extend the initial setup, with the
+following extensions:
+
+* HTML messages
+* Attachments
+* Use commandline options
+* Use config file to change the behaviour of the email2trac.py program
+* unicode support for special characters in the headers of an email message
+
+WWW: https://subtrac.sara.nl/oss/email2trac
diff --git a/www/trac-email2trac/pkg-plist b/www/trac-email2trac/pkg-plist
new file mode 100644
index 000000000000..1bf22d97d91c
--- /dev/null
+++ b/www/trac-email2trac/pkg-plist
@@ -0,0 +1,4 @@
+bin/delete_spam.py
+bin/email2trac.py
+bin/run_email2trac
+etc/email2trac.conf