aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2013-10-04 06:24:34 +0800
committerohauer <ohauer@FreeBSD.org>2013-10-04 06:24:34 +0800
commit77c4253664ee9db13cc32f73c2d1b0edd612cd5d (patch)
tree7fc89c8c51c4e8af62fd68dc504735f34e02b43f /www
parent1e591f1a09a27d1c2471b1fb642798dfff687f82 (diff)
downloadfreebsd-ports-gnome-77c4253664ee9db13cc32f73c2d1b0edd612cd5d.tar.gz
freebsd-ports-gnome-77c4253664ee9db13cc32f73c2d1b0edd612cd5d.tar.zst
freebsd-ports-gnome-77c4253664ee9db13cc32f73c2d1b0edd612cd5d.zip
- revert r275666 (gsed is really not required)
- adjust PORTSCOUD
Diffstat (limited to 'www')
-rw-r--r--www/mod_auth_kerb2/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/www/mod_auth_kerb2/Makefile b/www/mod_auth_kerb2/Makefile
index 0dc5a690730b..4ad5a25782de 100644
--- a/www/mod_auth_kerb2/Makefile
+++ b/www/mod_auth_kerb2/Makefile
@@ -18,20 +18,21 @@ USE_APACHE= 22
USE_GMAKE= yes
GNU_CONFIGURE= yes
-BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
-
-PORTSCOUT= limit:^5.3
+PORTSCOUT= limit:^5.4
.if defined(KRB5_HOME)
BUILD_DEPENDS+= ${KRB5_HOME}/lib/libgssapi_krb5.so:${PORTSDIR}/security/krb5
RUN_DEPENDS+= ${KRB5_HOME}/lib/libgssapi_krb5.so:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME} --without-krb4
+
.elif defined(HEIMDAL_HOME)
BUILD_DEPENDS+= ${HEIMDAL_HOME}/lib/libgssapi.so:${PORTSDIR}/security/heimdal
RUN_DEPENDS+= ${HEIMDAL_HOME}/lib/libgssapi.so:${PORTSDIR}/security/heimdal
CONFIGURE_ARGS+= --with-krb5=${HEIMDAL_HOME} --without-krb4
+
.elif exists(${DESTDIR}/usr/lib/libkrb5.a) && exists(${DESTDIR}/usr/bin/krb5-config)
CONFIGURE_ARGS+= --with-krb5=${DESTDIR}/usr --without-krb4
+
.else
LIB_DEPENDS+= gssapi_krb5:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+= --with-krb5=${LOCALBASE} --without-krb4