aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2008-05-13 15:37:54 +0800
committertobez <tobez@FreeBSD.org>2008-05-13 15:37:54 +0800
commit8a38cfe287f13177fbedacdbc795473fa258e772 (patch)
tree7890b79ed6e4d0e9404514825c5e83e8ce0c9df6 /www
parent740dc0e9b57e17471944869d9a3824d53cfee43b (diff)
downloadfreebsd-ports-gnome-8a38cfe287f13177fbedacdbc795473fa258e772.tar.gz
freebsd-ports-gnome-8a38cfe287f13177fbedacdbc795473fa258e772.tar.zst
freebsd-ports-gnome-8a38cfe287f13177fbedacdbc795473fa258e772.zip
Fix spurious warnings that appear when working with POST forms.
Bump portrevision. Requested by: sat See also: http://rt.cpan.org/Public/Bug/Display.html?id=34551
Diffstat (limited to 'www')
-rw-r--r--www/p5-CGI.pm/Makefile1
-rw-r--r--www/p5-CGI.pm/files/patch-bug-3455111
2 files changed, 12 insertions, 0 deletions
diff --git a/www/p5-CGI.pm/Makefile b/www/p5-CGI.pm/Makefile
index 1d47546f260a..43eb6c6d1fb0 100644
--- a/www/p5-CGI.pm/Makefile
+++ b/www/p5-CGI.pm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= CGI.pm
PORTVERSION= 3.37
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
diff --git a/www/p5-CGI.pm/files/patch-bug-34551 b/www/p5-CGI.pm/files/patch-bug-34551
new file mode 100644
index 000000000000..4701387beaca
--- /dev/null
+++ b/www/p5-CGI.pm/files/patch-bug-34551
@@ -0,0 +1,11 @@
+--- CGI.pm.orig 2008-05-13 09:32:19.000000000 +0200
++++ CGI.pm 2008-05-13 09:32:59.000000000 +0200
+@@ -3387,7 +3387,7 @@ sub read_multipart {
+ # content-disposition parsing fail.
+ my ($filename) = $header{'Content-Disposition'}
+ =~/ filename=(("[^"]*")|([a-z\d!\#'\*\+,\.^_\`\{\}\|\~]*))/i;
+- $filename =~ s/^"([^"]*)"$/$1/;
++ $filename =~ s/^"([^"]*)"$/$1/ if defined $filename;
+ # Test for Opera's multiple upload feature
+ my($multipart) = ( defined( $header{'Content-Type'} ) &&
+ $header{'Content-Type'} =~ /multipart\/mixed/ ) ?