aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2006-04-23 05:28:53 +0800
committerahze <ahze@FreeBSD.org>2006-04-23 05:28:53 +0800
commit9d7ef25dd936719ee0b730bb3579546d3ad2b417 (patch)
tree1c38c6c26032c96e5fe8a0f89e5285261dfbd30a /www
parentc2a3fccd0e3ed3e55ea38e4dcd0e546dd88121ec (diff)
downloadfreebsd-ports-gnome-9d7ef25dd936719ee0b730bb3579546d3ad2b417.tar.gz
freebsd-ports-gnome-9d7ef25dd936719ee0b730bb3579546d3ad2b417.tar.zst
freebsd-ports-gnome-9d7ef25dd936719ee0b730bb3579546d3ad2b417.zip
- Convert from using mozconfig.in to using generic mozconfig
- Make firefox10 work in tinderbox [1] Reported by: kris mail [1]
Diffstat (limited to 'www')
-rw-r--r--www/firefox10/Makefile4
-rw-r--r--www/firefox10/files/mozconfig.in82
-rw-r--r--www/firefox10/files/patch-config::mkdepend::Makefile.in10
3 files changed, 13 insertions, 83 deletions
diff --git a/www/firefox10/Makefile b/www/firefox10/Makefile
index 1077248f62c4..63055b6b4051 100644
--- a/www/firefox10/Makefile
+++ b/www/firefox10/Makefile
@@ -37,9 +37,11 @@ FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
MOZILLA= ${PORTNAME}${MOZILLA_SUFX}
MOZILLA_SUFX= 10
+MOZ_EXTENSIONS+=cookie,xml-rpc,xmlextras,pref,transformiix,universalchardet,webservices,inspector,p3p,gnomevfs,negotiateauth
MOZ_EXPORT+= MOZ_INTERNAL_LIBART_LGPL=1
MOZ_MK_OPTIONS+=MOZ_INTERNAL_LIBART_LGPL=1
-MOZ_OPTIONS= --enable-application=browser \
+MOZ_OPTIONS= --disable-ldap \
+ --enable-application=browser \
--enable-official-branding \
--program-transform-name='s/firefox/${MOZILLA}/' \
--enable-svg \
diff --git a/www/firefox10/files/mozconfig.in b/www/firefox10/files/mozconfig.in
deleted file mode 100644
index 0ca3dff21f93..000000000000
--- a/www/firefox10/files/mozconfig.in
+++ /dev/null
@@ -1,82 +0,0 @@
-# .mozconfig.in -*-shell-script-*-
-# $FreeBSD$
-######################################################################
-# standard opts from README
-export MOZ_PHOENIX=1
-mk_add_options MOZ_PHOENIX=1
-ac_add_options --enable-crypto
-ac_add_options --disable-tests
-ac_add_options --disable-mailnews
-ac_add_options --disable-composer
-ac_add_options --enable-default-toolkit=gtk2
-# See the following URL for approval email for using official branding
-# http://people.freebsd.org/~ahze/firefox_thunderbird-approved.txt
-ac_add_options --enable-official-branding
-######################################################################
-# FBSD specific
-export CPPFLAGS="@CPPFLAGS@"
-export CFLAGS="@CFLAGS@"
-export LIBS="@LIBS@"
-export LDFLAGS="@LDFLAGS@"
-export CONFIG_SH=/bin/sh
-export XP_UNIX=1
-mk_add_options XP_UNIX=1
-export PERL="@PERL@"
-mk_add_options PERL=$PERL
-# Configure options for installation
-ac_add_options --prefix=@FAKEDIR@
-ac_add_options --x-includes=@X11BASE@/include
-ac_add_options --x-libraries=@X11BASE@/lib
-######################################################################
-# Use ports for these libraries
-ac_add_options --with-system-jpeg=@LOCALBASE@
-ac_add_options --with-system-zlib
-ac_add_options --with-system-png=@LOCALBASE@
-ac_add_options --with-system-nspr
-ac_add_options --with-gssapi=@KRB5_HOME@
-######################################################################
-# set compile/link features
-ac_add_options --with-pthreads
-######################################################################
-# disable unneeded/unavailable
-ac_add_options --disable-auto-deps
-ac_add_options --disable-bidi
-ac_add_options --disable-dtd-debug
-ac_add_options --disable-jsd
-ac_add_options --disable-ldap
-ac_add_options --disable-pedantic
-ac_add_options --disable-profilesharing
-ac_add_options --disable-installer
-ac_add_options --enable-single-profile
-ac_add_options --disable-profilesharing
-ac_add_options --enable-image-decoders=all
-ac_add_options --enable-extensions="cookie,xml-rpc,xmlextras,pref,transformiix,universalchardet,webservices,inspector,p3p,gnomevfs,negotiateauth"
-######################################################################
-# conditional from port Makefile
-#if test -n "$WITH_REORDER"; then
-# ac_add_options --enable-reorder
-#else
-# ac_add_options --disable-reorder
-#fi # test -n "$WITH_REORDER"
-if test -n "$WITH_DEBUG"; then
- ac_add_options --enable-debug
- ac_add_options --disable-strip
-else
- ac_add_options --disable-debug
- ac_add_options --enable-optimize=${WITH_OPTIMIZE}
- ac_add_options --enable-strip
-fi # test -n "$WITH_DEBUG"
-if test -n "$WITH_LOGGING"; then
- ac_add_options --enable-logging
-else
- ac_add_options --disable-logging
-fi # test -n "$WITH_LOGGING"
-if test -z "$WITHOUT_XFT"; then
- ac_add_options --enable-xft
-else
- ac_add_options --disable-xft
-fi # test -z "$WITHOUT_XFT"
-if test -z "$WITH_SMB"; then
- ac_add_options --disable-gnomevfs
-fi # test -z "$WITH_SMB"
-######################################################################
diff --git a/www/firefox10/files/patch-config::mkdepend::Makefile.in b/www/firefox10/files/patch-config::mkdepend::Makefile.in
new file mode 100644
index 000000000000..bace012a282e
--- /dev/null
+++ b/www/firefox10/files/patch-config::mkdepend::Makefile.in
@@ -0,0 +1,10 @@
+--- config/mkdepend/Makefile.in.orig Sun Dec 12 07:36:57 2004
++++ config/mkdepend/Makefile.in Sun Dec 12 07:37:55 2004
+@@ -57,6 +57,7 @@
+ include $(topsrcdir)/config/rules.mk
+
+ HOST_CFLAGS += -DINCLUDEDIR=\"/usr/include\" -DOBJSUFFIX=\".$(OBJ_SUFFIX)\"
++HOST_CFLAGS += $(XCFLAGS)
+
+ ifdef GNU_CC
+ _GCCDIR = $(shell $(CC) -print-file-name=include)