aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-09-30 12:47:36 +0800
committerlinimon <linimon@FreeBSD.org>2007-09-30 12:47:36 +0800
commitc07b3d06f74c2b1f5144739f606ea2f60e5c4125 (patch)
tree75bc18c02ad45658df6e53d5864baec96c002730 /www
parent980b4f867dba0a997b3f1336459072e6da844359 (diff)
downloadfreebsd-ports-gnome-c07b3d06f74c2b1f5144739f606ea2f60e5c4125.tar.gz
freebsd-ports-gnome-c07b3d06f74c2b1f5144739f606ea2f60e5c4125.tar.zst
freebsd-ports-gnome-c07b3d06f74c2b1f5144739f606ea2f60e5c4125.zip
Switch autoconf dependencies from 2.53 or 2.59 to 2.61.
PR: ports/116639 Submitted by: aDe
Diffstat (limited to 'www')
-rw-r--r--www/apache20/Makefile4
-rw-r--r--www/apache21/Makefile5
-rw-r--r--www/apache22/Makefile4
-rw-r--r--www/asterisk-gui/Makefile3
-rw-r--r--www/asterisk-gui/files/patch-bootstrap.sh2
-rw-r--r--www/flood/Makefile4
-rw-r--r--www/gforge/Makefile4
-rw-r--r--www/libapreq2/Makefile3
-rw-r--r--www/libapreq2/files/patch-glue-perl-Makefile.PL27
-rw-r--r--www/mod_cplusplus/Makefile3
-rw-r--r--www/mod_webapp/Makefile4
-rw-r--r--www/oops/Makefile4
-rw-r--r--www/privoxy/Makefile4
-rw-r--r--www/squid30/Makefile1
-rw-r--r--www/squid31/Makefile1
-rw-r--r--www/tidy-devel/Makefile3
-rw-r--r--www/websh/Makefile3
17 files changed, 49 insertions, 30 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index f986c7d3d8aa..b7d73fd578e8 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.0.61
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITE_LOCAL:S/$/:powerlogo/}
@@ -49,7 +49,7 @@ SCRIPTS_ENV+= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${LIBTOOL_VERSION}.m4 \
AUTOHEADER=${AUTOHEADER}
USE_ICONV= yes
-USE_AUTOTOOLS= autoconf:259 libtool:15
+USE_AUTOTOOLS= autoconf:261 libtool:15
USE_PERL5= yes
USE_RC_SUBR= apache2.sh
SUB_LIST+= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX}
diff --git a/www/apache21/Makefile b/www/apache21/Makefile
index 8dc492cda11e..d7058e360cde 100644
--- a/www/apache21/Makefile
+++ b/www/apache21/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.1.9
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITE_LOCAL:S/%SUBDIR%/clement/}:powerlogo
@@ -37,6 +37,7 @@ CONFLICTS= apache+mod_ssl-1.* apache+mod_ssl+ipv6-1.* apache+mod_ssl+modsnmp-1.*
DEPRECATED= No longer supported, please use www/apache22 instead
EXPIRES= 2007-12-09
+BROKEN= Fails with autoconf-2.61
SCRIPTS_ENV+= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
LIBTOOL_VERSION=${LIBTOOL_VERSION} AUTOCONF=${AUTOCONF} \
@@ -46,7 +47,7 @@ SCRIPTS_ENV+= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
USE_APACHE= common21
USE_BZIP2= yes
USE_ICONV= yes
-USE_AUTOTOOLS= autoconf:259 libtool:15
+USE_AUTOTOOLS= autoconf:261 libtool:15
USE_PERL5= yes
USE_RC_SUBR= yes
LIBTOOLFILES= configure
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index fc13d8138eda..c2356d4cad1f 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -9,7 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.2.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= httpd-${PORTVERSION}
@@ -39,7 +39,7 @@ SCRIPTS_ENV+= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
USE_APACHE= common22
USE_BZIP2= yes
USE_ICONV= yes
-USE_AUTOTOOLS= autoconf:259 libtool:15
+USE_AUTOTOOLS= autoconf:261 libtool:15
USE_PERL5= yes
USE_RC_SUBR= apache22.sh htcacheclean.sh
SUB_LIST+= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX}
diff --git a/www/asterisk-gui/Makefile b/www/asterisk-gui/Makefile
index 8e397e10ef95..0fe3f80833f8 100644
--- a/www/asterisk-gui/Makefile
+++ b/www/asterisk-gui/Makefile
@@ -7,6 +7,7 @@
PORTNAME= asterisk-gui
PORTVERSION= 0.0.1r20070801
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://asterisk-bsd.googlecode.com/files/
DISTNAME= ${PORTNAME}-snap-2007-08-01
@@ -16,7 +17,7 @@ COMMENT= An asterisk ajax web manager
RUN_DEPENDS= asterisk:${PORTSDIR}/net/asterisk
-USE_AUTOTOOLS= autoconf:259 automake:19
+USE_AUTOTOOLS= autoconf:261 automake:19
USE_GMAKE= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
diff --git a/www/asterisk-gui/files/patch-bootstrap.sh b/www/asterisk-gui/files/patch-bootstrap.sh
index 09e125ca7465..0bc24b636e92 100644
--- a/www/asterisk-gui/files/patch-bootstrap.sh
+++ b/www/asterisk-gui/files/patch-bootstrap.sh
@@ -6,7 +6,7 @@
if [ $? = 0 ] ; then # FreeBSD case
- MY_AC_VER=259
- MY_AM_VER=19
-+ MY_AC_VER=-2.59
++ MY_AC_VER=-2.61
+ MY_AM_VER=-1.9
else # linux case
MY_AC_VER=
diff --git a/www/flood/Makefile b/www/flood/Makefile
index 18fae3d5eca3..410c8467e66e 100644
--- a/www/flood/Makefile
+++ b/www/flood/Makefile
@@ -7,7 +7,7 @@
PORTNAME= flood
PORTVERSION= 0.20041105
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://dist.bsdlab.org/
DISTNAME= httpd-test_20041105052051
@@ -19,7 +19,7 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
apr-1:${PORTSDIR}/devel/apr
WRKSRC= ${WRKDIR}/httpd-test/flood
-USE_AUTOTOOLS= autoconf:253 libtool:15:env
+USE_AUTOTOOLS= autoconf:261 libtool:15:env
CONFIGURE_ARGS= --disable-shared \
--with-apr=${LOCALBASE}/bin/apr-1-config \
--with-apr-util=${LOCALBASE}/bin/apu-1-config
diff --git a/www/gforge/Makefile b/www/gforge/Makefile
index 138d3da232e2..0d40e71839b3 100644
--- a/www/gforge/Makefile
+++ b/www/gforge/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gforge
PORTVERSION= 4.5.16
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www devel
MASTER_SITES= http://gforge.org/frs/download.php/236/
@@ -20,7 +20,7 @@ USE_BZIP2= YES
USE_PERL5= YES
HAS_CONFIGURE= YES
USE_APACHE= YES
-USE_AUTOTOOLS= autoconf:253
+USE_AUTOTOOLS= autoconf:261
NO_BUILD= YES
USE_PHP= pgsql session pcre
WANT_PHP_CLI= YES
diff --git a/www/libapreq2/Makefile b/www/libapreq2/Makefile
index 40ab063b29ca..44a26ff4d395 100644
--- a/www/libapreq2/Makefile
+++ b/www/libapreq2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libapreq2
PORTVERSION= 2.08
+PORTREVISION= 1
CATEGORIES= www devel
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR=libapreq
@@ -16,7 +17,7 @@ COMMENT= Generic Apache2 Request Library
USE_APACHE= 2.0+
USE_LDCONFIG= yes
-USE_AUTOTOOLS= autoconf:259 libtool:15
+USE_AUTOTOOLS= autoconf:261 libtool:15
CONFIGURE_ARGS+= --with-apache2-apxs=${APXS} --with-expat=${LOCALBASE}
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
diff --git a/www/libapreq2/files/patch-glue-perl-Makefile.PL b/www/libapreq2/files/patch-glue-perl-Makefile.PL
index f8515fd7ec69..f7a8b96c8ce1 100644
--- a/www/libapreq2/files/patch-glue-perl-Makefile.PL
+++ b/www/libapreq2/files/patch-glue-perl-Makefile.PL
@@ -1,13 +1,24 @@
---- glue/perl/Makefile.PL Mon May 2 20:24:29 2005
-+++ glue/perl/Makefile.PL Sat May 21 17:57:39 2005
-@@ -443,8 +443,8 @@
- 'NAME' => '$class',
- 'VERSION' => '$version',
+--- glue/perl/Makefile.PL.orig 2006-08-08 21:26:45.000000000 -0700
++++ glue/perl/Makefile.PL 2007-09-22 20:12:05.000000000 -0700
+@@ -71,2 +71,3 @@
+ $apache_includes .= " $1";
++ $apache_includes =~ s,\|\#_!!_\#\|,,g;
+
+@@ -84,3 +85,3 @@
+ die "Can't find apreq libname";
+- $apreq_libname = $1;
++ $apreq_libname = $1; $apreq_libname =~ s,^\|\#_!!_\#\|,,;
+
+@@ -88,4 +89,3 @@
+ die "Can't find package version";
+- $version = $1;
+-
++ $version = $1; $version =~ s,^\|\#_!!_\#\|,,;
+ }
+@@ -417,4 +417,4 @@
'TYPEMAPS' => [qw(@$mp2_typemaps $typemap)],
- 'INC' => "-I$base_dir/glue/perl/xs -I$inc_dir -I$xs_dir $apache_includes",
- 'LIBS' => "$apreq_libs $apr_libs",
-+ 'INC' => "-I$base_dir/glue/perl/xs -I$inc_dir -I$xs_dir $apache_includes -I\\\$(PREFIX)/%%APACHEINCLUDEDIR%%/modules/perl",
++ 'INC' => "-I$base_dir/glue/perl/xs -I$inc_dir -I$xs_dir $apache_includes -I\\\$(PREFIX)/include/apache2/modules/perl",
+ 'LIBS' => "$apreq_libs $apr_libs -L\\\$(PREFIX)/lib",
} ;
- $txt .= "'depend' => $deps,\n" if ($deps) ;
- $txt .= qq{
diff --git a/www/mod_cplusplus/Makefile b/www/mod_cplusplus/Makefile
index 7be828dcee2b..6125d9de4416 100644
--- a/www/mod_cplusplus/Makefile
+++ b/www/mod_cplusplus/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_cplusplus
PORTVERSION= 1.5.3
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= modcplusplus
@@ -15,7 +16,7 @@ MAINTAINER= durian@shadetreesoftware.com
COMMENT= Apache module for loading C++ objects as handlers
USE_APACHE= 2.0+
-USE_AUTOTOOLS= autoconf:259 autoheader:259 libtool:15 automake:19 aclocal:19
+USE_AUTOTOOLS= autoconf:261 autoheader:261 libtool:15 automake:19 aclocal:19
ACLOCAL_ARGS+= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS+= -a
GNU_CONFIGURE= yes
diff --git a/www/mod_webapp/Makefile b/www/mod_webapp/Makefile
index 7dd02507e057..18f1ce2ed9e2 100644
--- a/www/mod_webapp/Makefile
+++ b/www/mod_webapp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mod_webapp
PORTVERSION= 4.1.24
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://jakarta.apache.org/%SUBDIR%/
MASTER_SITE_SUBDIR= builds/jakarta-tomcat-4.0/release/v${TOMCAT_RELEASE}/src
@@ -21,7 +21,7 @@ BUILD_DEPENDS= ${NONEXISTANT}:${PORTSDIR}/devel/apr:configure
USE_APACHE= yes
USE_PYTHON_BUILD=yes
-USE_AUTOTOOLS= automake:19:env autoconf:259:env libtool:15:env
+USE_AUTOTOOLS= automake:19:env autoconf:261:env libtool:15:env
GNU_CONFIGURE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
diff --git a/www/oops/Makefile b/www/oops/Makefile
index 9969fd5cc5f2..972c43b214c4 100644
--- a/www/oops/Makefile
+++ b/www/oops/Makefile
@@ -7,7 +7,7 @@
PORTNAME= oops
PORTVERSION= ${OOPSVERSION}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= http://oops-cache.org/ \
ftp://kucha.ru/pub/misc/oops/
@@ -21,7 +21,7 @@ BUILD_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
OOPSVERSION= 1.5.24
USE_SUBMAKE= yes
-USE_AUTOTOOLS= autoconf:259
+USE_AUTOTOOLS= autoconf:261
CONFIGURE_ARGS?=--sbindir=${PREFIX}/sbin \
--sysconfdir=${PREFIX}/etc/oops \
--localstatedir=${OOPSVAR} \
diff --git a/www/privoxy/Makefile b/www/privoxy/Makefile
index 76dc34547755..0621bd14455a 100644
--- a/www/privoxy/Makefile
+++ b/www/privoxy/Makefile
@@ -7,7 +7,7 @@
PORTNAME= privoxy
PORTVERSION= 3.0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ijbswa
@@ -19,7 +19,7 @@ COMMENT= Privoxy is a web proxy with advanced filtering capabilities
WRKSRC= ${WRKDIR}/privoxy-${PORTVERSION}-stable
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:253
+USE_AUTOTOOLS= autoconf:261
USE_RC_SUBR= privoxy
SUB_FILES= pkg-message
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index a811e13343fc..96cfb4ea43cb 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -61,6 +61,7 @@
# together with other code that adds custom HTTP headers to the
# requests.
+PORTREVISION= 1
PORTNAME= squid
PORTVERSION= 3.0.p7.${PATCHSET_DATE}
CATEGORIES= www
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index a811e13343fc..96cfb4ea43cb 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -61,6 +61,7 @@
# together with other code that adds custom HTTP headers to the
# requests.
+PORTREVISION= 1
PORTNAME= squid
PORTVERSION= 3.0.p7.${PATCHSET_DATE}
CATEGORIES= www
diff --git a/www/tidy-devel/Makefile b/www/tidy-devel/Makefile
index c2f09e905f33..27d191b2e746 100644
--- a/www/tidy-devel/Makefile
+++ b/www/tidy-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= tidy
DISTVERSION= 070813-cvs
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_LOCAL}
#MASTER_SITES= http://tidy.sourceforge.net/src/%SUBDIR%/ \
@@ -28,7 +29,7 @@ USE_GMAKE= yes
PLIST_SUB= SHLIB="@comment " NSHLIB=""
CONFLICTS= tidy-20000804* tidy-lib-[0-9]*
.else
-USE_AUTOTOOLS= automake:15 autoconf:253 libtool:15
+USE_AUTOTOOLS= automake:15 autoconf:261 libtool:15
AUTOMAKE_ARGS+= -a -c --foreign
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_LDCONFIG= yes
diff --git a/www/websh/Makefile b/www/websh/Makefile
index 8062010e27bd..484bef8f5d71 100644
--- a/www/websh/Makefile
+++ b/www/websh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= websh
PORTVERSION= 3.6.0b4
+PORTREVISION= 1
CATEGORIES= www tcl84
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR=tcl/${PORTNAME}/source
@@ -21,7 +22,7 @@ OPTIONS+= WSSTATIC "Link the objects into the module statically" off
TCL_DVER= ${TCL_VER:S/.//}
USE_TCL= yes
-USE_AUTOTOOLS= autoconf:259
+USE_AUTOTOOLS= autoconf:261
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src/unix
CONFIGURE_ARGS+=--with-tclinclude=${TCL_INCLUDEDIR} \
--with-tcl=${TCL_LIBDIR}