aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-06-15 14:53:33 +0800
committermarcus <marcus@FreeBSD.org>2003-06-15 14:53:33 +0800
commitc5a4070eb0bd3fc91136fb9c706bcea8bd4f8f25 (patch)
treeea4cfc522b0f536d4b414844fb4823e01c362eba /www
parent426a5f72f72faaeaa6ab2d96ce2addeab9ba5ea6 (diff)
downloadfreebsd-ports-gnome-c5a4070eb0bd3fc91136fb9c706bcea8bd4f8f25.tar.gz
freebsd-ports-gnome-c5a4070eb0bd3fc91136fb9c706bcea8bd4f8f25.tar.zst
freebsd-ports-gnome-c5a4070eb0bd3fc91136fb9c706bcea8bd4f8f25.zip
Add a hack to remove CORBA stub files so that Galeon builds with ORBit2-2.7.2.
Diffstat (limited to 'www')
-rw-r--r--www/galeon2/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index f2ff4eaa5a4b..be5fbf545e17 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -53,6 +53,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_C
MAN1= galeon.1
FLASHPLAYER= ${LOCALBASE}/lib/libflashplayer.so.1
+XXX_FILES= GaleonAutomation-common.c GaleonAutomation-skels.c \
+ GaleonAutomation-stubs.c GaleonAutomation.h
.include <bsd.port.pre.mk>
@@ -74,6 +76,11 @@ pre-everything::
@${ECHO_MSG} " mozilla-devel-gtk2 "
@${ECHO_MSG} ""
+post-extract:
+.for i in ${XXX_FILES}
+ @${RM} -f ${WRKSRC}/src/${i}
+.endfor
+
post-patch:
@${REINPLACE_CMD} -e 's|mozilla-gtkmozembed|mozilla-gtkmozembed${HEADERS_SUFX}|g' \
${WRKSRC}/configure