aboutsummaryrefslogtreecommitdiffstats
path: root/x11-clocks/asclock-xlib
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2000-08-08 16:14:16 +0800
committerkuriyama <kuriyama@FreeBSD.org>2000-08-08 16:14:16 +0800
commit1d6389b1eb64555dbbf8be6a6c6dd63717afcd50 (patch)
tree635622e7803113899262a4d27a3ce337a7bf6af6 /x11-clocks/asclock-xlib
parent58192e1f59075c30d9dcdb197c7ec0ca90398dc3 (diff)
downloadfreebsd-ports-gnome-1d6389b1eb64555dbbf8be6a6c6dd63717afcd50.tar.gz
freebsd-ports-gnome-1d6389b1eb64555dbbf8be6a6c6dd63717afcd50.tar.zst
freebsd-ports-gnome-1d6389b1eb64555dbbf8be6a6c6dd63717afcd50.zip
Use USE_IMAKE when BATCH=YES.
Reported by: bento Suggested by: PW
Diffstat (limited to 'x11-clocks/asclock-xlib')
-rw-r--r--x11-clocks/asclock-xlib/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/x11-clocks/asclock-xlib/Makefile b/x11-clocks/asclock-xlib/Makefile
index 11580f77de67..4d800a16363e 100644
--- a/x11-clocks/asclock-xlib/Makefile
+++ b/x11-clocks/asclock-xlib/Makefile
@@ -12,22 +12,28 @@ MASTER_SITES= http://www.asclock.org/tar/
MAINTAINER= kuriyama@FreeBSD.org
-HAS_CONFIGURE= YES
WRKSRC= ${WRKDIR}/asclock-xlib
-USE_X_PREFIX= YES
USE_XPM= YES
+.include <bsd.port.pre.mk>
+
+.if defined(BATCH)
+USE_IMAKE= YES
+.else
+USE_X_PREFIX= YES
+HAS_CONFIGURE= YES
+.endif
+
post-patch:
@(cd ${WRKSRC}; \
${MV} config.c config.c.tmp; \
${SED} -e s@/usr/local/@${X11BASE}/@ -e s@/usr/share/asclock@${LOCALBASE}/share/asclock@ < config.c.tmp > config.c )
.if defined(BATCH)
-do-configure:
+pre-configure:
@(cd ${WRKSRC}; \
${RM} -rf default_theme; \
- ${LN} -s themes/Orb default_theme; \
- ${XMKMF} )
+ ${LN} -s themes/Orb default_theme)
.endif
post-install:
@@ -37,4 +43,4 @@ post-install:
${INSTALL_DATA} *.xpm config ${PREFIX}/share/asclock/${i}/ )
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>