aboutsummaryrefslogtreecommitdiffstats
path: root/x11-clocks/kdetoys4
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
committertcberner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
commita5fddeafcdb2cab1016827038e317a262dad4857 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /x11-clocks/kdetoys4
parent3832b190ef3ea2bbefdd61450bff8af422a2e9ae (diff)
downloadfreebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.tar.gz
freebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.tar.zst
freebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.zip
Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks and
Plasma5 ports At the moment KDE ports use bsd.kde4.mk to handle their dependencies. When working on the ports for KDE Frameworks and Plasma5 it seemed to be more reasonable to create a new kde.mk instead of adding an bsd.kde5.mk. The kde.mk in this review is a stripped down version of the one we are using in the KDE Test repositories plasma5 branch [1] to only contain the parts relevant to the current KDE4 ports in the portstree [2]. Changes to the KDE Ports needed by this: Replace USE_KDE4 by USE_KDE [3] Add USES=kde:4 [4] [1] http://src.mouf.net/area51/view/branches/plasma5/KDE/Mk/Uses/kde.mk [2] The version in the plasma5 branch also handles frameworks/plasma5 and handles MASTER_SITES via a KDE_DIST variable similar to bsd.qt.mk for Qt Ports -- I chose to leave this out for now, as the diff is already large enough. [3] I chose USE_KDE instead of USE_KDE4, USE_KDE5, USE_KDEX as the version we want is already specified as argument to kde:<arg> [4] For KDE Frameworks and Plasma5 ports this would be kde:5 PR: 210667 Approved by: portmgr, mat (mentor), rakuco (mentor) Reviewed by: mat, rakuco Differential Revision: https://reviews.freebsd.org/D6961
Diffstat (limited to 'x11-clocks/kdetoys4')
-rw-r--r--x11-clocks/kdetoys4/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/x11-clocks/kdetoys4/Makefile b/x11-clocks/kdetoys4/Makefile
index 93750e4eef7e..85c11f725ede 100644
--- a/x11-clocks/kdetoys4/Makefile
+++ b/x11-clocks/kdetoys4/Makefile
@@ -7,19 +7,18 @@ CATEGORIES= x11-clocks kde
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE miscellaneous applications (meta port)
-USE_KDE4= # blank, needed to get KDE4_VERSION
-USES= metaport
+USES= kde:4 metaport
OPTIONS_DEFINE= AMOR KTEATIME KTUX
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
AMOR_DESC= Small animation which sits on top of active window
-AMOR_RUN_DEPENDS= ${KDE4_PREFIX}/bin/amor:x11-clocks/amor
+AMOR_RUN_DEPENDS= ${KDE_PREFIX}/bin/amor:x11-clocks/amor
KTEATIME_DESC= Handy timer for steeping tea
-KTEATIME_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kteatime:x11-clocks/kteatime
+KTEATIME_RUN_DEPENDS= ${KDE_PREFIX}/bin/kteatime:x11-clocks/kteatime
KTUX_DESC= Tux-in-a-Spaceship screen saver
-KTUX_RUN_DEPENDS= ${KDE4_PREFIX}/bin/ktux:x11-clocks/ktux
+KTUX_RUN_DEPENDS= ${KDE_PREFIX}/bin/ktux:x11-clocks/ktux
.include <bsd.port.mk>