aboutsummaryrefslogtreecommitdiffstats
path: root/x11-clocks/sanduhr/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-02 23:52:20 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-02 23:52:20 +0800
commite8dfc443f677310ebc0acc5347aec91249bfe5f1 (patch)
treebabf43464f7254f7d9d0c67b984de34bafcbd141 /x11-clocks/sanduhr/Makefile
parent1f474fd683f7bd134e5ab985c2ecdea69df56a2c (diff)
downloadfreebsd-ports-gnome-e8dfc443f677310ebc0acc5347aec91249bfe5f1.tar.gz
freebsd-ports-gnome-e8dfc443f677310ebc0acc5347aec91249bfe5f1.tar.zst
freebsd-ports-gnome-e8dfc443f677310ebc0acc5347aec91249bfe5f1.zip
Update to 1.0.
Diffstat (limited to 'x11-clocks/sanduhr/Makefile')
-rw-r--r--x11-clocks/sanduhr/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-clocks/sanduhr/Makefile b/x11-clocks/sanduhr/Makefile
index 6ebe0bd6ba0a..84af5bbdb4f5 100644
--- a/x11-clocks/sanduhr/Makefile
+++ b/x11-clocks/sanduhr/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sanduhr
-PORTVERSION= 0.3.52
+PORTVERSION= 1.0
CATEGORIES= x11-clocks gnome
MASTER_SITES= http://www.mathematik.uni-kl.de/~wwwstoch/voss/
@@ -15,6 +15,7 @@ MAINTAINER= sobomax@FreeBSD.org
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -23,10 +24,10 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= sanduhr.1
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
+ s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>