aboutsummaryrefslogtreecommitdiffstats
path: root/x11-clocks
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-09-03 10:40:23 +0800
committervanilla <vanilla@FreeBSD.org>2014-09-03 10:40:23 +0800
commit7fc97802fda4a8a4cd10e9e18def259ece3e1731 (patch)
tree7a6d1e8e6d165cea48e74b98e81a5e98e77601fb /x11-clocks
parent437fe18cd9c113702dfbff94b794a77e70e8cdf4 (diff)
downloadfreebsd-ports-gnome-7fc97802fda4a8a4cd10e9e18def259ece3e1731.tar.gz
freebsd-ports-gnome-7fc97802fda4a8a4cd10e9e18def259ece3e1731.tar.zst
freebsd-ports-gnome-7fc97802fda4a8a4cd10e9e18def259ece3e1731.zip
Support STAGEDIR
PR: ports/193172 Submitted by: Ports Fury.
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/gdesklets-countdown/Makefile36
1 files changed, 19 insertions, 17 deletions
diff --git a/x11-clocks/gdesklets-countdown/Makefile b/x11-clocks/gdesklets-countdown/Makefile
index 1c0041640186..8ee7e4cc2312 100644
--- a/x11-clocks/gdesklets-countdown/Makefile
+++ b/x11-clocks/gdesklets-countdown/Makefile
@@ -14,10 +14,11 @@ COMMENT= Countdown the remaining time until a configurable date
RUN_DEPENDS= gdesklets:${PORTSDIR}/deskutils/gdesklets
+NO_BUILD= yes
+
WRKSRC= ${WRKDIR}/juju-countdown
-NO_BUILD= yes
-USE_PYTHON= yes
+USES= python
SUB_FILES= pkg-message
SUB_LIST= NAME="${NAME}"
@@ -25,21 +26,22 @@ SUB_LIST= NAME="${NAME}"
DATADIR= ${PREFIX}/share/gdesklets
NAME= Countdown
-NO_STAGE= yes
do-install:
- @${MKDIR} ${DATADIR}/Displays/${NAME}
- ${INSTALL_DATA} ${WRKSRC}/*.display ${DATADIR}/Displays/${NAME}
- ${INSTALL_DATA} ${WRKSRC}/README ${DATADIR}/Displays/${NAME}
- @${MKDIR} ${DATADIR}/Displays/${NAME}/gfx
- ${INSTALL_DATA} ${WRKSRC}/gfx/*.png ${DATADIR}/Displays/${NAME}/gfx
- @${MKDIR} ${DATADIR}/Sensors/${NAME}
- ${INSTALL_DATA} ${WRKSRC}/Sensors/${NAME}/*.py ${DATADIR}/Sensors/${NAME}
- @${MKDIR} ${DATADIR}/Sensors/LTVFontSelector
- ${INSTALL_DATA} ${WRKSRC}/Sensors/LTVFontSelector/*.py ${DATADIR}/Sensors/LTVFontSelector
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/Sensors/${NAME}
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/Sensors/${NAME}
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/Sensors/LTVFontSelector
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/Sensors/LTVFontSelector
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${DATADIR}/Displays/${NAME}
+ (cd ${WRKSRC} && ${INSTALL_DATA} README *.display \
+ ${STAGEDIR}${DATADIR}/Displays/${NAME})
+ @${MKDIR} ${STAGEDIR}${DATADIR}/Displays/${NAME}/gfx
+ (cd ${WRKSRC}/gfx && ${INSTALL_DATA} *.png \
+ ${STAGEDIR}${DATADIR}/Displays/${NAME}/gfx)
+ @${MKDIR} ${STAGEDIR}${DATADIR}/Sensors/${NAME}
+ (cd ${WRKSRC}/Sensors/${NAME} && ${INSTALL_DATA} *.py \
+ ${STAGEDIR}${DATADIR}/Sensors/${NAME})
+ @${MKDIR} ${STAGEDIR}${DATADIR}/Sensors/LTVFontSelector
+ (cd ${WRKSRC}/Sensors/LTVFontSelector && ${INSTALL_DATA} *.py \
+ ${STAGEDIR}${DATADIR}/Sensors/LTVFontSelector)
+ @(cd ${STAGEDIR}${PREFIX} && ${PYTHON_CMD} -m compileall \
+ -d ${DATADIR} -f ${DATADIR_REL})
+ @(cd ${STAGEDIR}${PREFIX} && ${PYTHON_CMD} -O -m compileall \
+ -d ${DATADIR} -f ${DATADIR_REL})
.include <bsd.port.mk>