aboutsummaryrefslogtreecommitdiffstats
path: root/x11-clocks
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-02-15 05:44:17 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-02-15 05:44:17 +0800
commita1b9decd51340ee602ba9603ce7856567aae1728 (patch)
tree23ba5e396b55b1219bb0edb024d43b7b7c018123 /x11-clocks
parent1ee407f25c880936371481847648630fdae6b319 (diff)
downloadfreebsd-ports-gnome-a1b9decd51340ee602ba9603ce7856567aae1728.tar.gz
freebsd-ports-gnome-a1b9decd51340ee602ba9603ce7856567aae1728.tar.zst
freebsd-ports-gnome-a1b9decd51340ee602ba9603ce7856567aae1728.zip
- Add LICENSE
- Switch to options helpers - Regenerate patches with `make makepatch`
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/mouseclock/Makefile5
-rw-r--r--x11-clocks/mouseclock/files/patch-Imakefile14
-rw-r--r--x11-clocks/mouseclock/files/patch-mouseclock.c12
3 files changed, 17 insertions, 14 deletions
diff --git a/x11-clocks/mouseclock/Makefile b/x11-clocks/mouseclock/Makefile
index e9da221b6f6a..4849a43c3b71 100644
--- a/x11-clocks/mouseclock/Makefile
+++ b/x11-clocks/mouseclock/Makefile
@@ -10,12 +10,15 @@ MASTER_SITES= SUNSITE/X11/clocks
MAINTAINER= ports@FreeBSD.org
COMMENT= Display the current time using the X root cursor
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= imake:notall
USE_XORG= x11
OPTIONS_DEFINE= DOCS
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
diff --git a/x11-clocks/mouseclock/files/patch-Imakefile b/x11-clocks/mouseclock/files/patch-Imakefile
index f380fd00b7cf..6b7f826c98ae 100644
--- a/x11-clocks/mouseclock/files/patch-Imakefile
+++ b/x11-clocks/mouseclock/files/patch-Imakefile
@@ -1,20 +1,20 @@
---- Imakefile.orig 1996-05-05 18:51:27.000000000 +0200
-+++ Imakefile 2013-09-01 17:04:26.000000000 +0200
+--- Imakefile.orig 1996-05-05 16:51:27 UTC
++++ Imakefile
@@ -1,16 +1,10 @@
-#define IHaveSubdirs
-#define PassCDebugFlags 'CDEBUGFLAGS=$(CDEBUGFLAGS)'
-+OBJS = mouseclock.o
-+SRCS = mouseclock.c
-+SYS_LIBRARIES = $(XONLYLIB)
-
+-
- DEPLIBS = $(DEPXLIB)
-LOCAL_LIBRARIES = $(XLIB)
- CDEBUGFLAGS =
- CCOPTIONS = -O3 -s -pipe -Wall
++OBJS = mouseclock.o
++SRCS = mouseclock.c
++SYS_LIBRARIES = $(XONLYLIB)
-AllTarget(mouseclock)
--
+
-MakeMakeSubdirs($(SUBDIRS),install)
-SimpleProgramTarget(mouseclock)
+ComplexProgramTargetNoMan(mouseclock)
diff --git a/x11-clocks/mouseclock/files/patch-mouseclock.c b/x11-clocks/mouseclock/files/patch-mouseclock.c
index 00b230a5ac00..5bb0647f1eff 100644
--- a/x11-clocks/mouseclock/files/patch-mouseclock.c
+++ b/x11-clocks/mouseclock/files/patch-mouseclock.c
@@ -1,6 +1,6 @@
---- mouseclock.c.orig Sun May 5 09:47:18 1996
-+++ mouseclock.c Mon Oct 6 23:09:43 1997
-@@ -31,6 +31,7 @@
+--- mouseclock.c.orig 1996-05-05 16:47:18 UTC
++++ mouseclock.c
+@@ -31,6 +31,7 @@ int Scr;
Window Root;
int shadow_size = 2;
int shadow_mode = 1;
@@ -8,7 +8,7 @@
/* ---------------------------------------------------------------- */
void
-@@ -56,6 +57,7 @@
+@@ -56,6 +57,7 @@ usage (const char *nom)
printf ("-display <dpy> display name\n");
printf ("-fg <color> foreground color\n");
printf ("-fn <font_name> font to use\n");
@@ -16,7 +16,7 @@
exit (1);
}
-@@ -266,6 +268,11 @@
+@@ -266,6 +268,11 @@ main (int argc, char **argv)
shadow_mode = 0;
continue;
}
@@ -28,7 +28,7 @@
usage (argv[0]);
}
-@@ -295,7 +302,7 @@
+@@ -295,7 +302,7 @@ main (int argc, char **argv)
struct tm *now_tm = localtime (&now);
Cursor cur;