aboutsummaryrefslogtreecommitdiffstats
path: root/x11-clocks
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
committerbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
commitba5181b4c873c984e4559cfddf3b6ce79362a9a2 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /x11-clocks
parent39c24b55b95207275ceec7228fd4470225c94152 (diff)
downloadfreebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.gz
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.zst
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/asclock/Makefile2
-rw-r--r--x11-clocks/bclock/Makefile8
-rw-r--r--x11-clocks/lmclock/Makefile2
-rw-r--r--x11-clocks/mouseclock/Makefile3
-rw-r--r--x11-clocks/swisswatch/Makefile10
-rw-r--r--x11-clocks/t3d/Makefile2
6 files changed, 9 insertions, 18 deletions
diff --git a/x11-clocks/asclock/Makefile b/x11-clocks/asclock/Makefile
index 6f1ab290dc8e..75539e7ede56 100644
--- a/x11-clocks/asclock/Makefile
+++ b/x11-clocks/asclock/Makefile
@@ -17,8 +17,8 @@ CONFLICTS= asclock-gtk-[0-9]* asclock-xlib-[0-9]*
# clang's cpp destroys whitespace, particularly hard tabs in makefiles,
# which is fatal for imake.
+USES= imake
USE_GCC= any
-USE_IMAKE= yes
USE_XORG= xpm xext x11
MAN1= asclock.1
PLIST_FILES= bin/asclock
diff --git a/x11-clocks/bclock/Makefile b/x11-clocks/bclock/Makefile
index 2e3224698a24..e45268bc0105 100644
--- a/x11-clocks/bclock/Makefile
+++ b/x11-clocks/bclock/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bclock
-# Date created: 13 May 1997
-# Whom: Brian Handy <handy@physics.montana.edu>
-#
+# Created by: Brian Handy <handy@physics.montana.edu>
# $FreeBSD$
-#
PORTNAME= bclock
PORTVERSION= 1.0
@@ -15,7 +11,7 @@ MASTER_SITE_SUBDIR= X11/clocks
MAINTAINER= ports@FreeBSD.org
COMMENT= Round, analog X11 clock with Bezier curve hands
-USE_IMAKE= yes
+USES= imake
USE_XORG= ice sm x11 xext xmu xt
MAN1= bclock.1
diff --git a/x11-clocks/lmclock/Makefile b/x11-clocks/lmclock/Makefile
index 16ad7b5e91c7..e9efd9e75f34 100644
--- a/x11-clocks/lmclock/Makefile
+++ b/x11-clocks/lmclock/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= CRITICAL
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Xerox Lisp machine clock clone
-USE_IMAKE= yes
+USES= imake
USE_XORG= x11 xext
MAKE_JOBS_SAFE= yes
diff --git a/x11-clocks/mouseclock/Makefile b/x11-clocks/mouseclock/Makefile
index cd45b2025b92..416880fc84d6 100644
--- a/x11-clocks/mouseclock/Makefile
+++ b/x11-clocks/mouseclock/Makefile
@@ -11,10 +11,9 @@ MASTER_SITE_SUBDIR= X11/clocks
MAINTAINER= ports@FreeBSD.org
COMMENT= Display the current time using the X root cursor
+USES= imake
USE_GMAKE= yes
-USE_IMAKE= yes
USE_XORG= x11 xext
-XMKMF= xmkmf
NO_INSTALL_MANPAGES= yes
post-configure:
diff --git a/x11-clocks/swisswatch/Makefile b/x11-clocks/swisswatch/Makefile
index 2f7acaa1e128..952b83433f6a 100644
--- a/x11-clocks/swisswatch/Makefile
+++ b/x11-clocks/swisswatch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: swisswatch
-# Date created: 16 December 1995
-# Whom: Yoshiro MIHIRA <sanpei@yy.cs.keio.ac.jp>
-#
+# Created by: Yoshiro MIHIRA <sanpei@yy.cs.keio.ac.jp>
# $FreeBSD$
-#
PORTNAME= swisswatch
PORTVERSION= 0.06
@@ -13,10 +9,10 @@ MASTER_SITES= ${MASTER_SITE_PORTS_JP}
EXTRACT_SUFX= .tar.Z
MAINTAINER= sanpei@FreeBSD.org
-COMMENT= A Swiss railway clock emulation, and a fancy default appearance
+COMMENT= Swiss railway clock emulation, and a fancy default appearance
+USES= imake
USE_GCC= any
-USE_IMAKE= yes
USE_XORG= ice sm x11 xext xmu xt
MAN1= swisswatch.1
diff --git a/x11-clocks/t3d/Makefile b/x11-clocks/t3d/Makefile
index 482415a2e16b..7231d8f84eca 100644
--- a/x11-clocks/t3d/Makefile
+++ b/x11-clocks/t3d/Makefile
@@ -19,7 +19,7 @@ EXTRACT_BEFORE_ARGS= -dc
EXTRACT_AFTER_ARGS= | ${SH}
NO_WRKSUBDIR= yes
-USE_IMAKE= yes
+USES= imake
USE_XORG= x11 xext
MAN1= t3d.1