aboutsummaryrefslogtreecommitdiffstats
path: root/x11-drivers/input-wacom/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-07-10 18:07:57 +0800
committermiwi <miwi@FreeBSD.org>2010-07-10 18:07:57 +0800
commit81e29c9fce36897989f70dd62090f56488435954 (patch)
tree7e1dd6fb2203c836a1496dee792294d5d271060f /x11-drivers/input-wacom/Makefile
parent5aa504d48e3285c2135714619b008aac18b5c8da (diff)
downloadfreebsd-ports-gnome-81e29c9fce36897989f70dd62090f56488435954.tar.gz
freebsd-ports-gnome-81e29c9fce36897989f70dd62090f56488435954.tar.zst
freebsd-ports-gnome-81e29c9fce36897989f70dd62090f56488435954.zip
- Unbreak with Xorg 1.7X
PR: 146495 (based on) Submitted by: Alex Deiter <alex.deiter@gmail.com> Approved by: maintainer
Diffstat (limited to 'x11-drivers/input-wacom/Makefile')
-rw-r--r--x11-drivers/input-wacom/Makefile33
1 files changed, 15 insertions, 18 deletions
diff --git a/x11-drivers/input-wacom/Makefile b/x11-drivers/input-wacom/Makefile
index afe5bc97070b..1f53c5e27afa 100644
--- a/x11-drivers/input-wacom/Makefile
+++ b/x11-drivers/input-wacom/Makefile
@@ -13,7 +13,6 @@ MASTER_SITES= http://www.chillt.de/bsdwacom/:bsdwacom \
SF/linuxwacom/linuxwacom/${WACOM_VERSION}:linuxwacom
DISTFILES= ${BSDWACOM}.tbz:bsdwacom \
${LINUXWACOM}.tar.bz2:linuxwacom
-EXTRACT_ONLY= ${BSDWACOM}.tbz
MAINTAINER= kamikaze@bsdforen.de
COMMENT= X.Org Wacom tablet driver and kernel module
@@ -23,6 +22,7 @@ MANCOMPRESSED= yes
USE_GMAKE= yes
USE_RC_SUBR= wacom
+USE_LDCONFIG= no
KMODDIR?= /boot/modules
XINPUTMODDIR= lib/xorg/modules/input
@@ -44,20 +44,18 @@ BSDWACOM= bsdwacom-${KLD_VERSION}
WACOM_VERSION= 0.8.2-2
KLD_VERSION= 40
-.include <bsd.port.pre.mk>
+OPTIONS= UWACOMKLD "Install USB kernel module (ignored on 8.x)" ${KMOD_SUPPORTED}
+
+.include <bsd.port.options.mk>
.if ${OSVERSION} >= 800064
-OPTIONS= UWACOMKLD "Install USB kernel module (not supported on 8.x)" Off
+KMOD_SUPPORTED= Off
+.undef WITH_UWACOMKLD
.else
-OPTIONS= UWACOMKLD "Install USB kernel module (not supported on 8.x)" On
+KMOD_SUPPORTED= On
.endif
-.include <bsd.port.options.mk>
-
.if defined(WITH_UWACOMKLD)
-.if ${OSVERSION} >= 800064
-BROKEN= does not build with USB support
-.endif
PLIST_SUB+= UWACOMKLD="uwacom.ko"
PORTTYPE= usb
.else
@@ -65,19 +63,18 @@ PLIST_SUB+= UWACOMKLD="@noinst UWACOMKLD uwacom.ko"
PORTTYPE= serial
.endif
-BROKEN= build failed
+post-patch:
+ @${LN} -s ../${LINUXWACOM} ${WRKDIR}/linuxwacom/
do-configure:
- @cd ${WRKDIR}/linuxwacom \
- && ${LN} -s ${DISTDIR}/${DIST_SUBDIR}/${LINUXWACOM}.tar.bz2 \
- && ${SETENV} ${MAKE_ENV} ./run_configure
+ @cd ${WRKDIR}/linuxwacom && ${SETENV} ${MAKE_ENV} ./run_configure
do-build:
.if defined(WITH_UWACOMKLD)
@cd ${WRKDIR}/uwacom \
&& ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS}
.endif
- @cd ${WRKDIR}/linuxwacom/${LINUXWACOM} \
+ @cd ${WRKDIR}/${LINUXWACOM} \
&& ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS}
do-install:
@@ -87,7 +84,7 @@ do-install:
.endif
@${MKDIR} ${PREFIX}/${XINPUTMODDIR} ${PREFIX}/${MAN4DIR}
@cd ${WRKDIR}/linuxwacom/${LINUXWACOM}/src/util/ \
- && ${SETENV} ${MAKE_ENV} ${GMAKE} install
+ && ${SETENV} ${MAKE_ENV} ${GMAKE} ${INSTALL_TARGET}
@${INSTALL} ${WRKDIR}/linuxwacom/${LINUXWACOM}/src/xdrv/wacom_drv.so \
${PREFIX}/${XINPUTMODDIR}/
@${INSTALL_MAN} ${WRKDIR}/linuxwacom/${LINUXWACOM}/src/wacom.4x.gz \
@@ -100,8 +97,8 @@ plist: clean configure
@cd ${WRKDIR}/linuxwacom \
&& ${SETENV} ${MAKE_ENV} PREFIX=${WRKDIR}/plist ./run_configure
@${MKDIR} ${WRKDIR}/plist
- @cd ${WRKDIR}/linuxwacom/${LINUXWACOM}/src/util \
- && ${SETENV} ${MAKE_ENV} ${GMAKE} install
+ @cd ${WRKDIR}/${LINUXWACOM}/src/util \
+ && ${SETENV} ${MAKE_ENV} ${GMAKE} ${INSTALL_TARGET}
@cd ${WRKDIR}/linuxwacom \
&& ${SETENV} ${MAKE_ENV} ./run_configure
@${FIND} ${WRKDIR}/plist/ -not -type d \
@@ -119,4 +116,4 @@ post-install:
@${ECHO} "===> Displaying pkg-message."
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>