aboutsummaryrefslogtreecommitdiffstats
path: root/x11-drivers/xf86-input-synaptics
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
committertijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
commit55e5c34e31b90aa95311b10bd4a3072f2163ebfe (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /x11-drivers/xf86-input-synaptics
parent0c15193d405451f0e1452ba981c8efb1df1447dd (diff)
downloadfreebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.gz
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.zst
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'x11-drivers/xf86-input-synaptics')
-rw-r--r--x11-drivers/xf86-input-synaptics/Makefile4
-rw-r--r--x11-drivers/xf86-input-synaptics/pkg-plist1
2 files changed, 2 insertions, 3 deletions
diff --git a/x11-drivers/xf86-input-synaptics/Makefile b/x11-drivers/xf86-input-synaptics/Makefile
index 5874922b4f8a..c8e32453989f 100644
--- a/x11-drivers/xf86-input-synaptics/Makefile
+++ b/x11-drivers/xf86-input-synaptics/Makefile
@@ -18,11 +18,11 @@ XORG_CAT= driver
.if defined(WITH_NEW_XORG)
SYNAPTICS_VERSION= 1.7.4
-SYNAPTICS_REVISION= 0
+SYNAPTICS_REVISION= 1
PLIST_SUB+= NEW="" OLD="@comment "
.else
SYNAPTICS_VERSION= 1.6.4
-SYNAPTICS_REVISION= 0
+SYNAPTICS_REVISION= 1
PLIST_SUB+= NEW="@comment " OLD=""
EXTRA_PATCHES+= ${PATCHDIR}/extra-Makefile.in
.endif
diff --git a/x11-drivers/xf86-input-synaptics/pkg-plist b/x11-drivers/xf86-input-synaptics/pkg-plist
index d29caf256087..10ce5a3a27a0 100644
--- a/x11-drivers/xf86-input-synaptics/pkg-plist
+++ b/x11-drivers/xf86-input-synaptics/pkg-plist
@@ -2,7 +2,6 @@ bin/synclient
bin/syndaemon
include/xorg/synaptics-properties.h
%%OLD%%include/xorg/synaptics.h
-lib/xorg/modules/input/synaptics_drv.la
lib/xorg/modules/input/synaptics_drv.so
libdata/pkgconfig/xorg-synaptics.pc
man/man1/synclient.1.gz