aboutsummaryrefslogtreecommitdiffstats
path: root/x11-drivers/xf86-video-intel
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
committertijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
commit55e5c34e31b90aa95311b10bd4a3072f2163ebfe (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /x11-drivers/xf86-video-intel
parent0c15193d405451f0e1452ba981c8efb1df1447dd (diff)
downloadfreebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.gz
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.zst
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'x11-drivers/xf86-video-intel')
-rw-r--r--x11-drivers/xf86-video-intel/Makefile4
-rw-r--r--x11-drivers/xf86-video-intel/pkg-plist8
2 files changed, 2 insertions, 10 deletions
diff --git a/x11-drivers/xf86-video-intel/Makefile b/x11-drivers/xf86-video-intel/Makefile
index 5b343e12265b..afd712611072 100644
--- a/x11-drivers/xf86-video-intel/Makefile
+++ b/x11-drivers/xf86-video-intel/Makefile
@@ -27,7 +27,7 @@ USE_XORG= glproto \
.if defined(WITH_NEW_XORG)
INTEL_VERSION= 2.21.15
-INTEL_REVISION= 2
+INTEL_REVISION= 3
CONFIGURE_ENV+= xorg_cv_cc_flag__Wno_maybe_uninitialized=no
CONFIGURE_ARGS+= --enable-sna
CONFIGURE_ARGS+= --disable-glamor
@@ -39,7 +39,7 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-src__sna__sna_threads.c \
LIB_DEPENDS+= libxcb-util.so:${PORTSDIR}/x11/xcb-util
.else
INTEL_VERSION= 2.7.1
-INTEL_REVISION= 7
+INTEL_REVISION= 8
PLIST_SUB+= OLD=""
EXTRA_PATCHES+= ${PATCHDIR}/extra-src_ch7017_ch7017.c \
diff --git a/x11-drivers/xf86-video-intel/pkg-plist b/x11-drivers/xf86-video-intel/pkg-plist
index 948876757621..a7c967e55356 100644
--- a/x11-drivers/xf86-video-intel/pkg-plist
+++ b/x11-drivers/xf86-video-intel/pkg-plist
@@ -1,22 +1,14 @@
-lib/libI810XvMC.la
lib/libI810XvMC.so
lib/libI810XvMC.so.1
lib/libI810XvMC.so.1.0.0
-lib/libIntelXvMC.la
lib/libIntelXvMC.so.1
lib/libIntelXvMC.so
lib/libIntelXvMC.so.1.0.0
-%%OLD%%lib/xorg/modules/drivers/ch7017.la
%%OLD%%lib/xorg/modules/drivers/ch7017.so
-%%OLD%%lib/xorg/modules/drivers/ch7xxx.la
%%OLD%%lib/xorg/modules/drivers/ch7xxx.so
-lib/xorg/modules/drivers/intel_drv.la
lib/xorg/modules/drivers/intel_drv.so
-%%OLD%%lib/xorg/modules/drivers/ivch.la
%%OLD%%lib/xorg/modules/drivers/ivch.so
-%%OLD%%lib/xorg/modules/drivers/sil164.la
%%OLD%%lib/xorg/modules/drivers/sil164.so
-%%OLD%%lib/xorg/modules/drivers/tfp410.la
%%OLD%%lib/xorg/modules/drivers/tfp410.so
man/man4/intel.4x.gz
@dirrmtry lib/xorg/modules/drivers