aboutsummaryrefslogtreecommitdiffstats
path: root/x11-drivers/xf86-video-rendition
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-10-13 15:45:08 +0800
committerkwm <kwm@FreeBSD.org>2015-10-13 15:45:08 +0800
commitd9066e7f81004ea484da8127e425c71fa8f76268 (patch)
tree5c1588bcc55dc0d528b29233e0611c59fb10d358 /x11-drivers/xf86-video-rendition
parentecb693545fe45f21a6ebef2b47f8bf526a6fd2c4 (diff)
downloadfreebsd-ports-gnome-d9066e7f81004ea484da8127e425c71fa8f76268.tar.gz
freebsd-ports-gnome-d9066e7f81004ea484da8127e425c71fa8f76268.tar.zst
freebsd-ports-gnome-d9066e7f81004ea484da8127e425c71fa8f76268.zip
Xorg-server update to 1.17.2 with related driver updates and bumps.
Update fontproto to 2.1.3. Update libXfont to 1.5.1. Update xf86-input-keyboard 1.8.1. Update xf86-input-vmmouse to 13.1.0. Update xf86-input-void to 1.4.1. Update xf86-video-chips to 1.2.6. Update xf86-video-cirrus to 1.5.3. Update xf86-video-mach64 to 6.9.5. Update xf86-video-neomagic to 1.2.9. Update xf86-video-r128 to 6.10.0. Update xf86-video-s3virge to 1.10.7. Update xf86-video-savage to 2.3.8. Update xf86-video-siliconmotion to 1.7.8. Update xf86-video-sis to 0.10.8. Update xf86-video-trident to 1.3.7. Update xf86-video-vesa to 2.3.4. * All other xf86-* drivers where bump and/or patched to allow them to compile and work with the new xorg-server. * The ATI-ums driver is removed because the API it depends on was removed from the xorg-server. * Add patch to sunffb to make the lack of XAA non-fatal (not build/run tested due to lack of hardware). * Remove the extra patches in xorg-server for arm. The code seems to support it now natively. Please file a bug if this is not the case. * Update the xorg-server support in virtualbox-ose-additions for vboxmouse. [1] Submitted by: jkim@ [1] Obtained from: Graphics devel repo
Diffstat (limited to 'x11-drivers/xf86-video-rendition')
-rw-r--r--x11-drivers/xf86-video-rendition/Makefile2
-rw-r--r--x11-drivers/xf86-video-rendition/files/patch-src_rendition.c45
-rw-r--r--x11-drivers/xf86-video-rendition/files/patch-src_rendition.h25
3 files changed, 66 insertions, 6 deletions
diff --git a/x11-drivers/xf86-video-rendition/Makefile b/x11-drivers/xf86-video-rendition/Makefile
index 9888f66bd602..15949523f523 100644
--- a/x11-drivers/xf86-video-rendition/Makefile
+++ b/x11-drivers/xf86-video-rendition/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xf86-video-rendition
PORTVERSION= 4.2.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-video-rendition/files/patch-src_rendition.c b/x11-drivers/xf86-video-rendition/files/patch-src_rendition.c
index ab994241d18e..5d5bb0047117 100644
--- a/x11-drivers/xf86-video-rendition/files/patch-src_rendition.c
+++ b/x11-drivers/xf86-video-rendition/files/patch-src_rendition.c
@@ -1,5 +1,5 @@
---- src/rendition.c.orig 2012-07-17 05:32:12 UTC
-+++ src/rendition.c
+--- src/rendition.c.orig 2015-10-11 22:31:51.242126000 +0200
++++ src/rendition.c 2015-10-11 22:32:20.465605000 +0200
@@ -1173,7 +1173,6 @@ renditionScreenInit(SCREEN_INIT_ARGS_DEC
fbPictureInit (pScreen, 0, 0);
@@ -8,3 +8,44 @@
/*********************************************************/
/* The actual setup of the driver-specific code */
+@@ -1372,6 +1371,18 @@ renditionMapMem(ScrnInfoPtr pScreenInfo)
+ /* Override on users request */
+ WriteCombine
+ = xf86ReturnOptValBool(pRendition->Options, OPTION_FBWC, WriteCombine);
++#ifdef XSERVER_LIBPCIACCESS
++ mapOption = PCI_DEV_MAP_FLAG_WRITABLE;
++ if (WriteCombine)
++ mapOption |= PCI_DEV_MAP_FLAG_WRITE_COMBINE;
++
++ err = pci_device_map_range(pRendition->PciInfo,
++ pRendition->PciInfo->regions[0].base_addr,
++ pRendition->PciInfo->regions[0].size,
++ mapOption, (void *)&pRendition->board.vmem_base);
++
++ return (err == 0);
++#else
+ if (WriteCombine) {
+ xf86DrvMsg(pScreenInfo->scrnIndex, X_CONFIG,
+ ("Requesting Write-Combined memory access\n"));
+@@ -1382,12 +1393,6 @@ renditionMapMem(ScrnInfoPtr pScreenInfo)
+ mapOption = VIDMEM_MMIO;
+ }
+
+-#ifdef XSERVER_LIBPCIACCESS
+- err = pci_device_map_region(pRendition->PciInfo, 0, TRUE);
+- pRendition->board.vmem_base = pRendition->PciInfo->regions[0].memory;
+-
+- return (err == 0);
+-#else
+ pRendition->board.vmem_base=
+ xf86MapPciMem(pScreenInfo->scrnIndex, mapOption,
+ pRendition->pcitag,
+@@ -1416,7 +1421,7 @@ renditionUnmapMem(ScrnInfoPtr pScreenInf
+ #else
+ pci_device_unmap_range(pRendition->PciInfo,
+ pRendition->board.vmem_base,
+- pScreenInfo->videoRam * 1024);
++ pRendition->PciInfo->regions[0].size);
+ #endif
+ return TRUE;
+ #ifdef DEBUG0
diff --git a/x11-drivers/xf86-video-rendition/files/patch-src_rendition.h b/x11-drivers/xf86-video-rendition/files/patch-src_rendition.h
index 81b528a854d5..75a5fa411b62 100644
--- a/x11-drivers/xf86-video-rendition/files/patch-src_rendition.h
+++ b/x11-drivers/xf86-video-rendition/files/patch-src_rendition.h
@@ -1,6 +1,16 @@
---- src/rendition.h.orig 2012-07-16 02:42:28 UTC
-+++ src/rendition.h
-@@ -28,9 +28,6 @@
+--- src/rendition.h.orig 2015-10-11 22:31:54.085176000 +0200
++++ src/rendition.h 2015-10-11 22:32:12.657760000 +0200
+@@ -14,9 +14,6 @@
+ /* Everything using inb/outb, etc needs "compiler.h" */
+ #include "compiler.h"
+
+-/* Drivers for PCI hardware need this */
+-#include "xf86PciInfo.h"
+-
+ /* Drivers that need to access the PCI config space directly need this */
+ #include "xf86Pci.h"
+
+@@ -28,9 +25,6 @@
/* All drivers initialising the SW cursor need this */
#include "mipointer.h"
@@ -10,3 +20,12 @@
/* All drivers using the mi colormap manipulation need this */
#include "micmap.h"
+@@ -69,4 +63,8 @@
+
+ #include "compat-api.h"
+ /* end of __RENDITION_H__ */
++
++#define PCI_CHIP_V1000 0x0001
++#define PCI_CHIP_V2x00 0x2000
++
+ #endif