aboutsummaryrefslogtreecommitdiffstats
path: root/x11-drivers/xf86-video-scfb
diff options
context:
space:
mode:
authorrezny <rezny@FreeBSD.org>2017-02-11 22:17:58 +0800
committerrezny <rezny@FreeBSD.org>2017-02-11 22:17:58 +0800
commit9004f2aae7a927dec3bc5dbf5d535579ea43c7aa (patch)
treef850017ca906c1f973d599485b77a7dceb60e2fc /x11-drivers/xf86-video-scfb
parentc2a7c09121f564be99490587def8740af67dc2ef (diff)
downloadfreebsd-ports-gnome-9004f2aae7a927dec3bc5dbf5d535579ea43c7aa.tar.gz
freebsd-ports-gnome-9004f2aae7a927dec3bc5dbf5d535579ea43c7aa.tar.zst
freebsd-ports-gnome-9004f2aae7a927dec3bc5dbf5d535579ea43c7aa.zip
Xorg-servers update to 1.18.4 with driver updates and revision bumps.
Update xf86-video-ati to 7.8.0 Update xf86-video-intel to 2.99.917.20170103 Update xf86-input-synaptics to 1.9.0 Update xf86-input-evdev to 2.10.5 Update xf86-video-r128 to 6.10.2 Update xf86-video-rendition to 4.2.6 New port: xf86-video-geode PR: 214591,216269,214687,214593,214715,216276,216277,216278,216287, 216288,216292,216298,214560,216299,216300,216301,216302 Approved by: swills (mentor, portmgr) Differential Revision: https://reviews.freebsd.org/D9436
Diffstat (limited to 'x11-drivers/xf86-video-scfb')
-rw-r--r--x11-drivers/xf86-video-scfb/Makefile12
-rw-r--r--x11-drivers/xf86-video-scfb/files/patch-src_scfb__driver.c11
2 files changed, 13 insertions, 10 deletions
diff --git a/x11-drivers/xf86-video-scfb/Makefile b/x11-drivers/xf86-video-scfb/Makefile
index 5ffdfcf262ee..a1d9499b5443 100644
--- a/x11-drivers/xf86-video-scfb/Makefile
+++ b/x11-drivers/xf86-video-scfb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xf86-video-scfb
PORTVERSION= 0.0.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-drivers
MAINTAINER= ray@FreeBSD.org
@@ -12,14 +12,6 @@ COMMENT= X.Org syscons display driver
USE_GITHUB= yes
GH_ACCOUNT= rayddteam
-USES= libtool pkgconfig
-GNU_CONFIGURE= yes
-DIST_SUBDIR= xorg/driver
-USE_XORG= xorg-server xproto randrproto xi renderproto xextproto \
- inputproto kbproto fontsproto videoproto dri2proto \
- xf86driproto glproto xineramaproto resourceproto \
- scrnsaverproto presentproto
-CONFIGURE_ENV= DRIVER_MAN_SUFFIX=4x DRIVER_MAN_DIR='$$(mandir)/man4'
-INSTALL_TARGET= install-strip
+XORG_CAT= driver
.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-video-scfb/files/patch-src_scfb__driver.c b/x11-drivers/xf86-video-scfb/files/patch-src_scfb__driver.c
index eee6e58dc527..193b053b64e5 100644
--- a/x11-drivers/xf86-video-scfb/files/patch-src_scfb__driver.c
+++ b/x11-drivers/xf86-video-scfb/files/patch-src_scfb__driver.c
@@ -58,6 +58,17 @@
#endif
return mapaddr;
}
+@@ -366,8 +367,8 @@ ScfbPreInit(ScrnInfoPtr pScrn, int flags
+ struct fbtype fb;
+ int default_depth, wstype;
+ const char *dev;
+- char *mod = NULL, *s;
+- const char *reqSym = NULL;
++ char *mod = NULL;
++ const char *reqSym = NULL, *s;
+ Gamma zeros = {0.0, 0.0, 0.0};
+ DisplayModePtr mode;
+
@@ -633,9 +634,9 @@ ScfbShadowInit(ScreenPtr pScreen)
}