aboutsummaryrefslogtreecommitdiffstats
path: root/x11-drivers
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2008-11-21 10:12:05 +0800
committerpgj <pgj@FreeBSD.org>2008-11-21 10:12:05 +0800
commite1823e0815968518b50685ad339fe8423dcca2fc (patch)
tree87a651050c5cdc5cdd2692d692290b937821c17f /x11-drivers
parent81918e83d15d95c9e80f5b82e0e45d01d7b2a968 (diff)
downloadfreebsd-ports-gnome-e1823e0815968518b50685ad339fe8423dcca2fc.tar.gz
freebsd-ports-gnome-e1823e0815968518b50685ad339fe8423dcca2fc.tar.zst
freebsd-ports-gnome-e1823e0815968518b50685ad339fe8423dcca2fc.zip
- Fix missing shared object issue
- Try to remove XINPUTMODDIR Submitted by: maintainer (partially) Approved by: maintainer, gabor
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/input-wacom/Makefile9
-rw-r--r--x11-drivers/input-wacom/files/patch-linuxwacom-run_configure8
-rw-r--r--x11-drivers/input-wacom/pkg-plist1
3 files changed, 14 insertions, 4 deletions
diff --git a/x11-drivers/input-wacom/Makefile b/x11-drivers/input-wacom/Makefile
index cd1aaa15b354..3638f824c686 100644
--- a/x11-drivers/input-wacom/Makefile
+++ b/x11-drivers/input-wacom/Makefile
@@ -56,7 +56,7 @@ PLIST_SUB+= UWACOMKLD="@noinst UWACOMKLD uwacom.ko"
do-configure:
@cd ${WRKDIR}/linuxwacom \
&& ${LN} -s ${DISTDIR}/${DIST_SUBDIR}/${LINUXWACOM}.tar.bz2 \
- && ./run_configure
+ && ${SETENV} PREFIX=${PREFIX} ./run_configure
do-build:
.if defined(WITH_UWACOMKLD)
@@ -83,12 +83,12 @@ plist: clean configure
@${ECHO} "===> Rebuilding PLIST."
@${TOUCH} ${PLIST}
@${RM} ${PLIST}
- @cd ${WRKDIR}/linuxwacom/${LINUXWACOM} \
- && ./configure --prefix=${WRKDIR}/plist
+ @cd ${WRKDIR}/linuxwacom \
+ && ${SETENV} PREFIX=${WRKDIR}/plist ./run_configure
@${MKDIR} ${WRKDIR}/plist
@cd ${WRKDIR}/linuxwacom/${LINUXWACOM}/src/util && ${GMAKE} install
@cd ${WRKDIR}/linuxwacom \
- && ./run_configure
+ && ${SETENV} PREFIX=${PREFIX} ./run_configure
@${FIND} ${WRKDIR}/plist/ -not -type d \
| ${SED} "s|${WRKDIR}/plist/||1" \
>> ${PLIST}
@@ -96,6 +96,7 @@ plist: clean configure
| ${SED} "s|${WRKDIR}/plist/|@dirrm |1" \
>> ${PLIST}
@${ECHO} "%%XINPUTMODDIR%%/wacom_drv.so" >> ${PLIST}
+ @${ECHO} "@dirrmtry %%XINPUTMODDIR%%" >> ${PLIST}
@${ECHO} "@cwd %%KMODDIR%%" >> ${PLIST}
@${ECHO} "%%UWACOMKLD%%" >> ${PLIST}
diff --git a/x11-drivers/input-wacom/files/patch-linuxwacom-run_configure b/x11-drivers/input-wacom/files/patch-linuxwacom-run_configure
new file mode 100644
index 000000000000..412e7dfde564
--- /dev/null
+++ b/x11-drivers/input-wacom/files/patch-linuxwacom-run_configure
@@ -0,0 +1,8 @@
+--- linuxwacom/run_configure.orig 2008-11-18 22:53:45.000000000 +0100
++++ linuxwacom/run_configure 2008-11-18 22:56:25.000000000 +0100
+@@ -13,4 +13,4 @@
+ cp files/input.h linuxwacom-0.8.1-3/src/xdrv/linux
+ cd linuxwacom-0.8.1-3
+ patch < ../files/patch_configure
+-./configure --with-linux=yes --with-tcl=/usr/local/include/tcl8.4 --with-tk=/usr/local/include/tk8.4 CFLAGS="-I/usr/local/include"
++./configure --with-linux=yes --with-tcl=/usr/local/include/tcl8.4 --with-tk=/usr/local/include/tk8.4 CFLAGS="-I/usr/local/include" --prefix=${PREFIX} --enable-dlloader
diff --git a/x11-drivers/input-wacom/pkg-plist b/x11-drivers/input-wacom/pkg-plist
index 991caac094e7..c47a60dabb78 100644
--- a/x11-drivers/input-wacom/pkg-plist
+++ b/x11-drivers/input-wacom/pkg-plist
@@ -8,5 +8,6 @@ bin/xsetwacom
include/wacomcfg/wacomcfg.h
@dirrm include/wacomcfg
%%XINPUTMODDIR%%/wacom_drv.so
+@dirrmtry %%XINPUTMODDIR%%
@cwd %%KMODDIR%%
%%UWACOMKLD%%