aboutsummaryrefslogtreecommitdiffstats
path: root/x11-drivers
diff options
context:
space:
mode:
authorrnoland <rnoland@FreeBSD.org>2009-01-29 23:49:02 +0800
committerrnoland <rnoland@FreeBSD.org>2009-01-29 23:49:02 +0800
commit8a9c3deada09352cfa61448e892cbad37f79e6d9 (patch)
treead0b405e44c51a766db45558f8d57528fcef2f32 /x11-drivers
parent498dceefed10cd613af27ba7a7a745b2e9653ae1 (diff)
downloadfreebsd-ports-gnome-8a9c3deada09352cfa61448e892cbad37f79e6d9.tar.gz
freebsd-ports-gnome-8a9c3deada09352cfa61448e892cbad37f79e6d9.tar.zst
freebsd-ports-gnome-8a9c3deada09352cfa61448e892cbad37f79e6d9.zip
Take a crack at resolving the mouse blocking issues.
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-mouse/Makefile1
-rw-r--r--x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c17
2 files changed, 13 insertions, 5 deletions
diff --git a/x11-drivers/xf86-input-mouse/Makefile b/x11-drivers/xf86-input-mouse/Makefile
index b3cd5b4e4463..a0d57399107c 100644
--- a/x11-drivers/xf86-input-mouse/Makefile
+++ b/x11-drivers/xf86-input-mouse/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xf86-input-mouse
PORTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c b/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c
index b3258c653ad4..c2c8cade92f6 100644
--- a/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c
+++ b/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c
@@ -1,11 +1,20 @@
---- src/bsd_mouse.c.orig 2008-12-13 18:24:06.000000000 -0500
-+++ src/bsd_mouse.c 2008-12-14 22:50:40.000000000 -0500
+--- src/bsd_mouse.c.orig 2008-11-26 23:11:36.000000000 -0500
++++ src/bsd_mouse.c 2009-01-28 12:52:12.000000000 -0500
@@ -1,4 +1,3 @@
-
/*
* Copyright (c) 1999-2003 by The XFree86 Project, Inc.
*
-@@ -75,11 +74,15 @@
+@@ -28,6 +27,8 @@
+
+ #include <xorg-server.h>
+
++#define XPS2_SUPPORT
++
+ #include <X11/X.h>
+ #include "xf86.h"
+ #include "xf86Priv.h"
+@@ -75,11 +76,13 @@
#define DEFAULT_MOUSE_DEV "/dev/mouse"
#define DEFAULT_SYSMOUSE_DEV "/dev/sysmouse"
#define DEFAULT_PS2_DEV "/dev/psm0"
@@ -14,10 +23,8 @@
static const char *mouseDevs[] = {
DEFAULT_MOUSE_DEV,
DEFAULT_SYSMOUSE_DEV,
-+#ifndef CONFIG_HAL
DEFAULT_PS2_DEV,
+ DEFAULT_USB_DEV,
-+#endif
NULL
};
#elif (defined(__OpenBSD__) || defined(__NetBSD__)) && defined(WSCONS_SUPPORT)