aboutsummaryrefslogtreecommitdiffstats
path: root/x11-drivers
diff options
context:
space:
mode:
authorrobak <robak@FreeBSD.org>2015-03-13 23:03:26 +0800
committerrobak <robak@FreeBSD.org>2015-03-13 23:03:26 +0800
commit2064228916524717fe91e03cefd355f01faa9f5c (patch)
tree9be2e4b72769271f54620be096121a818c473faf /x11-drivers
parent74d825d6590d67213de6d4741bbd53ba54760e6f (diff)
downloadfreebsd-ports-gnome-2064228916524717fe91e03cefd355f01faa9f5c.tar.gz
freebsd-ports-gnome-2064228916524717fe91e03cefd355f01faa9f5c.tar.zst
freebsd-ports-gnome-2064228916524717fe91e03cefd355f01faa9f5c.zip
x11-drivers/xf86-input-wacom: update 0.27.0 -> 0.28.0
- Add RC script - Add moused(8) workaround PR: 196539 Submitted by: Jan Beich <jbeich@FreeBSD.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/Makefile4
-rw-r--r--x11-drivers/xf86-input-wacom/distinfo4
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-configure29
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.c2
-rw-r--r--x11-drivers/xf86-input-wacom/files/pkg-message.in5
-rw-r--r--x11-drivers/xf86-input-wacom/files/wacom.in39
6 files changed, 78 insertions, 5 deletions
diff --git a/x11-drivers/xf86-input-wacom/Makefile b/x11-drivers/xf86-input-wacom/Makefile
index debea23fe337..cb2ff8359653 100644
--- a/x11-drivers/xf86-input-wacom/Makefile
+++ b/x11-drivers/xf86-input-wacom/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-input-wacom
-PORTVERSION= 0.27.0
-PORTREVISION= 1
+PORTVERSION= 0.28.0
CATEGORIES= x11-drivers
MASTER_SITES= SF/linuxwacom/${PORTNAME}
@@ -17,6 +16,7 @@ RUN_DEPENDS= webcamd>0:${PORTSDIR}/multimedia/webcamd
USES= tar:bzip2 pathfix pkgconfig libtool
USE_XORG= xrandr xinerama
XORG_CAT= driver
+USE_RC_SUBR= wacom
SUB_FILES= pkg-message
CONFIGURE_ARGS= --without-systemd-unit-dir \
--without-udev-rules-dir \
diff --git a/x11-drivers/xf86-input-wacom/distinfo b/x11-drivers/xf86-input-wacom/distinfo
index f49723c85921..babf95753895 100644
--- a/x11-drivers/xf86-input-wacom/distinfo
+++ b/x11-drivers/xf86-input-wacom/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/driver/xf86-input-wacom-0.27.0.tar.bz2) = d1280361595f28c273d237cb234c28ca77617f875207ee0424a385a41407ec42
-SIZE (xorg/driver/xf86-input-wacom-0.27.0.tar.bz2) = 594818
+SHA256 (xorg/driver/xf86-input-wacom-0.28.0.tar.bz2) = 7c19008ef727a5437d300fc297325953ad2b30a23163fba19adda2aa9ad6243b
+SIZE (xorg/driver/xf86-input-wacom-0.28.0.tar.bz2) = 595621
diff --git a/x11-drivers/xf86-input-wacom/files/patch-configure b/x11-drivers/xf86-input-wacom/files/patch-configure
new file mode 100644
index 000000000000..a7c15fdfe3cf
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/files/patch-configure
@@ -0,0 +1,29 @@
+To workaround the following error
+
+ $ clang conftest.c -I/usr/local/include/xorg
+ In file included from conftest.c:3:
+ In file included from /usr/local/include/xorg/xf86Optionstr.h:27:
+ /usr/local/include/xorg/list.h:216:15: error: unknown type name 'Bool'; did you mean
+ '_Bool'?
+ static inline Bool
+ ^~~~
+ _Bool
+ 1 error generated.
+
+ $ gcc conftest.c -I/usr/local/include/xorg
+ In file included from /usr/local/include/xorg/xf86Optionstr.h:27,
+ from conftest.c:3:
+ /usr/local/include/xorg/list.h:217: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'xorg_list_is_empty'
+
+cf. http://cgit.freedesktop.org/xorg/xserver/commit/?id=13b5074
+
+--- configure~
++++ configure
+@@ -18788,6 +18788,7 @@ CFLAGS="$XORG_CFLAGS $CFLAGS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
++ typedef int Bool;
+ #include <xf86Optionstr.h>
+ int
+ main ()
diff --git a/x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.c b/x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.c
index 38f72b713dc6..434afaf0dc84 100644
--- a/x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.c
+++ b/x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.c
@@ -48,7 +48,7 @@
@@ -506,6 +518,7 @@ xf86UnblockSIGIO (int wasset)
/* This is not the same as the X server one, but it'll do for the tests */
- #if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 14
+ #if HAVE_XF86OPTIONPTR
+#define InputOption InputOption_custom
typedef struct _InputOption {
struct _InputOption *next;
diff --git a/x11-drivers/xf86-input-wacom/files/pkg-message.in b/x11-drivers/xf86-input-wacom/files/pkg-message.in
index 248e28d8ef17..f3c3350647e5 100644
--- a/x11-drivers/xf86-input-wacom/files/pkg-message.in
+++ b/x11-drivers/xf86-input-wacom/files/pkg-message.in
@@ -11,3 +11,8 @@ into xorg.conf and add the following lines to ServerLayout section
InputDevice "wacom eraser"
InputDevice "wacom touch"
InputDevice "wacom pad"
+
+If moused(8) interferes with tablet input try adding the following
+line to /etc/rc.conf
+
+ wacom_enable="YES"
diff --git a/x11-drivers/xf86-input-wacom/files/wacom.in b/x11-drivers/xf86-input-wacom/files/wacom.in
new file mode 100644
index 000000000000..e4ee87bdbff7
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/files/wacom.in
@@ -0,0 +1,39 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: wacom
+# REQUIRE: mountcritlocal
+# KEYWORD: nojail
+#
+# Add the following lines to /etc/rc.conf to enable this service:
+#
+# wacom_enable (bool): Set it to YES to add Wacom USB quirks on startup.
+# Default: NO
+
+. /etc/rc.subr
+
+name="wacom"
+rcvar="wacom_enable"
+
+load_rc_config "$name"
+
+: ${wacom_enable:="NO"}
+
+start_precmd="wacom_prepare"
+start_cmd="wacom_start"
+stop_cmd=":"
+
+wacom_prepare()
+{
+ kldload -n usb_quirk
+}
+
+wacom_start()
+{
+ # Prevent moused(8) from picking up bogus /dev/umsN
+ usbconfig add_dev_quirk_vplh 0x056a 0 0 0xffff UQ_MATCH_VENDOR_ONLY
+ usbconfig add_dev_quirk_vplh 0x056a 0 0 0xffff UQ_UMS_IGNORE
+}
+
+run_rc_command "$1"