aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/nautilus/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-02-02 04:16:40 +0800
committersobomax <sobomax@FreeBSD.org>2001-02-02 04:16:40 +0800
commit71b991d8850fb51f86110d12f0ab3847922c70b5 (patch)
tree1b152603adf72077a0ca4bc551161ec8cb3a9e6a /x11-fm/nautilus/Makefile
parentefb0f35e37af6b06ac5196ba545b69d2271c4d80 (diff)
downloadfreebsd-ports-gnome-71b991d8850fb51f86110d12f0ab3847922c70b5.tar.gz
freebsd-ports-gnome-71b991d8850fb51f86110d12f0ab3847922c70b5.tar.zst
freebsd-ports-gnome-71b991d8850fb51f86110d12f0ab3847922c70b5.zip
Update to 0.8. Unfortunately it doesn't work apart from setup wizard, so
use it cautiously and don't forget to let me know if you managed to fix it.
Diffstat (limited to 'x11-fm/nautilus/Makefile')
-rw-r--r--x11-fm/nautilus/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/x11-fm/nautilus/Makefile b/x11-fm/nautilus/Makefile
index 8a803bdcdbfe..5dd1fb57279f 100644
--- a/x11-fm/nautilus/Makefile
+++ b/x11-fm/nautilus/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nautilus
-PORTVERSION= 0.5
+PORTVERSION= 0.8
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/nautilus
@@ -21,7 +21,7 @@ LIB_DEPENDS= medusa.0:${PORTSDIR}/sysutils/medusa \
freetype.6:${PORTSDIR}/print/freetype2
.if defined(WITH_MOZILLA)
-MOZILLA= mozilla-embedded
+MOZILLA= mozilla
BUILD_DEPENDS= ${X11BASE}/include/mozilla/gtkmozembed.h:${PORTSDIR}/www/mozilla-headers \
${X11BASE}/lib/${MOZILLA}/libgtkembedmoz.so:${PORTSDIR}/www/${MOZILLA}
RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/libgtkembedmoz.so:${PORTSDIR}/www/${MOZILLA}
@@ -32,7 +32,7 @@ USE_X_PREFIX= yes
USE_GNOME= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -fno-rtti -fno-exceptions" \
LIBS="-pthread -L${LOCALBASE}/lib" \
LIBPNG="-L${LOCALBASE}/lib -lpng -lz ${MOZILLA_LIBS}"
CONFIGURE_ARGS= --with-freetype2-lib-place=${LOCALBASE}/lib \