aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/thunar
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2012-12-15 02:53:31 +0800
committerolivierd <olivierd@FreeBSD.org>2012-12-15 02:53:31 +0800
commitff5b6ec46ba82e25ac5e0326f3148371d6f33978 (patch)
tree091353aec14fff9a48c2e5529652d4ba58a3deb7 /x11-fm/thunar
parentcbbfcc79beda164bc8d2fadae115fd030f95a0e0 (diff)
downloadfreebsd-ports-gnome-ff5b6ec46ba82e25ac5e0326f3148371d6f33978.tar.gz
freebsd-ports-gnome-ff5b6ec46ba82e25ac5e0326f3148371d6f33978.tar.zst
freebsd-ports-gnome-ff5b6ec46ba82e25ac5e0326f3148371d6f33978.zip
- Update to 1.6.1
- Sort options - Use OPTIONS_GROUP for plugins, PLUG_* - Remove ABI version numbers from LIB_DEPENDS - Add patches for GLib 2.28 Approved by: rene, miwi (mentors, implicit)
Diffstat (limited to 'x11-fm/thunar')
-rw-r--r--x11-fm/thunar/Makefile50
-rw-r--r--x11-fm/thunar/distinfo4
-rw-r--r--x11-fm/thunar/files/patch-thunar__thunar-gio-extensions.c37
-rw-r--r--x11-fm/thunar/files/patch-thunar__thunar-size-label.c91
-rw-r--r--x11-fm/thunar/pkg-plist3
5 files changed, 156 insertions, 29 deletions
diff --git a/x11-fm/thunar/Makefile b/x11-fm/thunar/Makefile
index ea0a3c9c63ce..384103fab2b2 100644
--- a/x11-fm/thunar/Makefile
+++ b/x11-fm/thunar/Makefile
@@ -3,14 +3,14 @@
#
PORTNAME= Thunar
-PORTVERSION= 1.4.0
-PORTREVISION= 4
+PORTVERSION= 1.6.1
CATEGORIES= x11-fm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
+MASTER_SITE_SUBDIR= src/xfce/${PORTNAME:L}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
-COMMENT= Xfce 4 file manager
+COMMENT= Xfce file manager
LIB_DEPENDS= tumbler-1:${PORTSDIR}/deskutils/xfce4-tumbler
@@ -25,13 +25,16 @@ USE_XFCE= configenv libexo libmenu libutil
USE_XORG= sm x11
USE_PKGCONFIG= build
-OPTIONS_DEFINE= STARTUP DBUS NOTIFY NLS DOCS PLUG_APR PLUG_APR_EXIF PLUG_SBR PLUG_SBR_PCRE PLUG_TPA PLUG_UCA PLUG_WALL GVFS
-OPTIONS_DEFAULT= STARTUP DBUS NOTIFY PLUG_APR PLUG_SBR PLUG_SBR_PCRE PLUG_UCA PLUG_WALL GVFS
-STARTUP_DESC= Enable startup notification support
+OPTIONS_DEFINE= DBUS DOCS GVFS NLS NOTIFY STARTUP
+OPTIONS_MULTI= PLUGINS
+OPTIONS_MULTI_PLUGINS= PLUG_APR PLUG_SBR PLUG_TPA PLUG_UCA PLUG_WALL
+OPTIONS_DEFAULT= DBUS GVFS NOTIFY PLUG_APR PLUG_SBR PLUG_UCA PLUG_WALL STARTUP
+
+# Override NOTIFY_DESC
+NOTIFY_DESC= Display notifications
+STARTUP_DESC= Startup notification
PLUG_APR_DESC= Thunar Advanced Properties plugin
-PLUG_APR_EXIF_DESC= Exif support for the APR plugin
PLUG_SBR_DESC= Thunar Simple Builtin Renamers plugin
-PLUG_SBR_PCRE_DESC= Regular expression support for the SBR plugin
PLUG_TPA_DESC= Thunar Trash Panel Applet plugin
PLUG_UCA_DESC= Thunar User Customizable Actions plugin
PLUG_WALL_DESC= Thunar Wallpaper plugin
@@ -45,7 +48,7 @@ MAN1= Thunar.1
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS+=--enable-dbus
PLIST_SUB+= WITH_DBUS=""
.else
@@ -63,7 +66,7 @@ PLIST_SUB+= NLS="@comment "
.endif
.if ${PORT_OPTIONS:MNOTIFY}
-LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--enable-notifications
.else
CONFIGURE_ARGS+=--disable-notifications
@@ -78,28 +81,18 @@ PLIST_SUB+= APIDOCS="@comment "
.endif
.if ${PORT_OPTIONS:MPLUG_APR}
-CONFIGURE_ARGS+=--enable-apr-plugin
+LIB_DEPENDS+= exif:${PORTSDIR}/graphics/libexif
+CONFIGURE_ARGS+=--enable-apr-plugin --enable-exif
PLIST_SUB+= PLUGIN_APR=""
-.if ${PORT_OPTIONS:MPLUG_APR_EXIF}
-LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
-CONFIGURE_ARGS+=--enable-exif
-.else
-CONFIGURE_ARGS+=--disable-exif
-.endif
.else
CONFIGURE_ARGS+=--disable-apr-plugin --disable-exif
PLIST_SUB+= PLUGIN_APR="@comment "
.endif
.if ${PORT_OPTIONS:MPLUG_SBR}
-CONFIGURE_ARGS+=--enable-sbr-plugin
-PLIST_SUB+= PLUGIN_SBR=""
-.if ${PORT_OPTIONS:MPLUG_SBR_PCRE}
LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
-CONFIGURE_ARGS+=--enable-pcre
-.else
-CONFIGURE_ARGS+=--disable-pcre
-.endif
+CONFIGURE_ARGS+=--enable-sbr-plugin --enable-pcre
+PLIST_SUB+= PLUGIN_SBR=""
.else
CONFIGURE_ARGS+=--disable-sbr-plugin --disable-pcre
PLIST_SUB+= PLUGIN_SBR="@comment "
@@ -131,7 +124,7 @@ PLIST_SUB+= PLUGIN_WALL="@comment "
.endif
.if ${PORT_OPTIONS:MSTARTUP}
-LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+LIB_DEPENDS+= startup-notification-1:${PORTSDIR}/x11/startup-notification
CONFIGURE_ARGS+=--enable-startup-notification
.else
CONFIGURE_ARGS+=--disable-startup-notification
@@ -141,6 +134,13 @@ CONFIGURE_ARGS+=--disable-startup-notification
USE_GNOME+=gvfs
.endif
+post-patch:
+# Downgrade GLib to 2.28
+ @${REINPLACE_CMD} -e 's|2.30.|2.28.|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name '*.c' -type f \
+ | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|g_format_size (|g_format_size_for_display (|g'
+
post-install:
@-update-desktop-database
diff --git a/x11-fm/thunar/distinfo b/x11-fm/thunar/distinfo
index 25f90b0d0ae7..41cfa75198aa 100644
--- a/x11-fm/thunar/distinfo
+++ b/x11-fm/thunar/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/Thunar-1.4.0.tar.bz2) = 2c11a19e64cef708a264fb4d5d933389899c3d132fe7b1e313dd6e37bfe4c8ba
-SIZE (xfce4/Thunar-1.4.0.tar.bz2) = 1915160
+SHA256 (xfce4/Thunar-1.6.1.tar.bz2) = a81021af558802b8c2c6cd7db47cca262477c4f3d2b6d8cfa8dbba88568048f1
+SIZE (xfce4/Thunar-1.6.1.tar.bz2) = 1975665
diff --git a/x11-fm/thunar/files/patch-thunar__thunar-gio-extensions.c b/x11-fm/thunar/files/patch-thunar__thunar-gio-extensions.c
new file mode 100644
index 000000000000..b6094e5f5880
--- /dev/null
+++ b/x11-fm/thunar/files/patch-thunar__thunar-gio-extensions.c
@@ -0,0 +1,37 @@
+--- ./thunar/thunar-gio-extensions.c.orig 2012-12-09 17:28:23.000000000 +0000
++++ ./thunar/thunar-gio-extensions.c 2012-12-10 21:43:55.000000000 +0000
+@@ -569,15 +569,34 @@
+ thunar_g_app_info_should_show (GAppInfo *info)
+ {
+ #ifdef HAVE_GIO_UNIX
++#if GLIB_CHECK_VERSION (2, 28, 0)
++ const gchar *filename;
++
++ _thunar_return_val_if_fail (G_IS_APP_INFO (info), FALSE);
++
++ if (g_app_info_should_show (info))
++ return TRUE;
++#else
+ _thunar_return_val_if_fail (G_IS_APP_INFO (info), FALSE);
++#endif
+
+ if (G_IS_DESKTOP_APP_INFO (info))
++ /* g_desktop_app_info_get_show_in() appears from GLib 2.30 */
++#if GLIB_CHECK_VERSION (2, 28, 0)
++ {
++ filename = g_desktop_app_info_get_filename (G_DESKTOP_APP_INFO (info));
++ if (filename != NULL
++ && g_str_has_prefix (filename, g_get_user_data_dir ()))
++ return TRUE;
++ }
++#else
+ {
+ /* NoDisplay=true files should be visible in the interface,
+ * because this key is intent to hide mime-helpers from the
+ * application menu. Hidden=true is never returned by GIO. */
+ return g_desktop_app_info_get_show_in (G_DESKTOP_APP_INFO (info), NULL);
+ }
++#endif
+
+ return TRUE;
+ #else
diff --git a/x11-fm/thunar/files/patch-thunar__thunar-size-label.c b/x11-fm/thunar/files/patch-thunar__thunar-size-label.c
new file mode 100644
index 000000000000..5cb57b7292e6
--- /dev/null
+++ b/x11-fm/thunar/files/patch-thunar__thunar-size-label.c
@@ -0,0 +1,91 @@
+--- ./thunar/thunar-size-label.c.orig 2012-10-14 13:01:38.000000000 +0000
++++ ./thunar/thunar-size-label.c 2012-10-21 00:27:16.000000000 +0000
+@@ -259,6 +259,51 @@
+ return FALSE;
+ }
+
++#if GLIB_CHECK_VERSION (2, 28, 0)
++static gchar*
++tsl_format_size_string (guint64 size)
++{
++ GString *result;
++ gchar *grouping;
++ gchar *thousep;
++ gint ndigits = 0;
++
++#ifdef HAVE_LOCALECONV
++ grouping = localeconv ()->grouping;
++ thousep = localeconv ()->thousands_sep;
++#else
++ grouping = "\3\0";
++ thousep = ",";
++#endif
++
++ result = g_string_sized_new (32);
++ do
++ {
++ /* prepend the next digit to the string */
++ g_string_prepend_c (result, '0' + (size % 10));
++ ++ndigits;
++
++ /* check if we should add the thousands separator */
++ if (ndigits == *grouping && *grouping != CHAR_MAX && size > 9)
++ {
++ g_string_prepend (result, thousep);
++ ndigits = 0;
++
++ /* if *(grouping+1) == '\0' then we have to use the
++ * *grouping character (last grouping rule) for all
++ * following cases.
++ */
++ if (*(grouping + 1) != '\0')
++ ++grouping;
++ }
++
++ size /= 10;
++ }
++ while (size > 0);
++
++ return g_string_free (result, FALSE);
++}
++#endif
+
+
+ static void
+@@ -266,6 +311,10 @@
+ {
+ gchar *size_string;
+ guint64 size;
++#if GLIB_CHECK_VERSION (2, 28, 0)
++ gchar *size_humanized;
++ gchar *text;
++#endif
+
+ _thunar_return_if_fail (THUNAR_IS_SIZE_LABEL (size_label));
+ _thunar_return_if_fail (size_label->files != NULL);
+@@ -308,7 +357,25 @@
+ size = thunar_file_get_size (THUNAR_FILE (size_label->files->data));
+
+ /* setup the new label */
++#if GLIB_CHECK_VERSION (2, 30, 0)
+ size_string = g_format_size_full (size, G_FORMAT_SIZE_LONG_FORMAT);
++#else
++ /* determine the size in bytes */
++ text = tsl_format_size_string (size);
++ size_string = g_strdup_printf (_("%s Bytes"), text);
++ g_free (text);
++
++ /* check if the file is larger that 1kB */
++ if (G_LIKELY (size > 1024ul))
++ {
++ /* prepend the humanized size */
++ size_humanized = g_format_size_for_display (size);
++ text = g_strdup_printf ("%s (%s)", size_humanized, size_string);
++ g_free (size_humanized);
++ g_free (size_string);
++ size_string = text;
++ }
++#endif
+ gtk_label_set_text (GTK_LABEL (size_label->label), size_string);
+ g_free (size_string);
+ }
diff --git a/x11-fm/thunar/pkg-plist b/x11-fm/thunar/pkg-plist
index 9658f24b8f91..2a6749af5658 100644
--- a/x11-fm/thunar/pkg-plist
+++ b/x11-fm/thunar/pkg-plist
@@ -73,7 +73,6 @@ share/icons/hicolor/16x16/apps/Thunar.png
share/icons/hicolor/16x16/stock/navigation/stock_folder-copy.png
share/icons/hicolor/16x16/stock/navigation/stock_folder-move.png
share/icons/hicolor/16x16/stock/navigation/stock_thunar-shortcuts.png
-share/icons/hicolor/16x16/stock/navigation/stock_thunar-templates.png
share/icons/hicolor/24x24/apps/Thunar.png
share/icons/hicolor/24x24/stock/navigation/stock_folder-copy.png
share/icons/hicolor/24x24/stock/navigation/stock_folder-move.png
@@ -81,6 +80,7 @@ share/icons/hicolor/48x48/apps/Thunar.png
share/icons/hicolor/64x64/apps/Thunar.png
share/icons/hicolor/128x128/apps/Thunar.png
share/icons/hicolor/scalable/apps/Thunar.svg
+%%NLS%%share/locale/am/LC_MESSAGES/Thunar.mo
%%NLS%%share/locale/ar/LC_MESSAGES/Thunar.mo
%%NLS%%share/locale/ast/LC_MESSAGES/Thunar.mo
%%NLS%%share/locale/be/LC_MESSAGES/Thunar.mo
@@ -176,4 +176,3 @@ share/pixmaps/Thunar/Thunar-about-logo.png
@dirrm include/thunarx-2/thunarx
@dirrm include/thunarx-2
%%PLUGIN_UCA%%@dirrm etc/xdg/Thunar
-%%PLUGIN_UCA%%@dirrmtry etc/xdg