aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/xnc/Makefile
diff options
context:
space:
mode:
authortaoka <taoka@FreeBSD.org>1999-04-30 17:44:34 +0800
committertaoka <taoka@FreeBSD.org>1999-04-30 17:44:34 +0800
commit1a6f58a920a05f059754b23be025c64be70f69bd (patch)
tree69ebc4c7db7cf0a3e918e4d6a538c37be4f44a77 /x11-fm/xnc/Makefile
parent846181c0a6e5be380c7fcd8e4488152e4c9c1625 (diff)
downloadfreebsd-ports-gnome-1a6f58a920a05f059754b23be025c64be70f69bd.tar.gz
freebsd-ports-gnome-1a6f58a920a05f059754b23be025c64be70f69bd.tar.zst
freebsd-ports-gnome-1a6f58a920a05f059754b23be025c64be70f69bd.zip
File manager for X Window
PR: 9920 Submitted by: Dima Sivachenko <dima@chg.ru>
Diffstat (limited to 'x11-fm/xnc/Makefile')
-rw-r--r--x11-fm/xnc/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/x11-fm/xnc/Makefile b/x11-fm/xnc/Makefile
new file mode 100644
index 000000000000..feb8fb71062f
--- /dev/null
+++ b/x11-fm/xnc/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: xnc
+# Version required: 4.0.8
+# Date created: 5 February 1999
+# Whom: Dima Sivachenko <dima@chg.ru>
+#
+# $Id$
+#
+
+DISTNAME= xnc-4.0.8.src
+PKGNAME= xnc-4.0.8
+CATEGORIES= x11-fm
+MASTER_SITES= ftp://ftp.chg.ru/pub/Linux/sunsite/X11/desktop/ \
+ ftp://sunsite.unx.edu/pub/Linux/X11/desktop/
+
+MAINTAINER= dima@chg.ru
+
+RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+ unzip:${PORTSDIR}/archivers/unzip \
+ rpm:${PORTSDIR}/misc/rpm \
+ rar:${PORTSDIR}/archivers/rar \
+ unarj:${PORTSDIR}/archivers/unarj \
+ lha:${PORTSDIR}/archivers/lha \
+ bzip2:${PORTSDIR}/archivers/bzip2
+
+USE_X_PREFIX= yes
+WRKSRC= ${WRKDIR}/${PKGNAME}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+do-install:
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/findslave.xnc ${PREFIX}/bin
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/users.xnc ${PREFIX}/bin
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/groups.xnc ${PREFIX}/bin
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/rpm.xnc ${PREFIX}/bin
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/zips.xnc ${PREFIX}/bin
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/gzip.xnc ${PREFIX}/bin
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/bzip.xnc ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/nc ${PREFIX}/bin/xnc
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/ives/ives ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/ives/es ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/ives/vs ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/xsetup/xncsetup ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/xjroot/xjpegroot ${PREFIX}/bin
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/launch/xnlaunch ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/xnc.1 ${MAN1PREFIX}/man/cat1
+ @ ${GZIP_CMD} ${MAN1PREFIX}/man/cat1/xnc.1
+ @ ${INSTALL_MAN} ${WRKSRC}/ives/ives.1 ${MAN1PREFIX}/man/cat1
+ @ ${GZIP_CMD} ${MAN1PREFIX}/man/cat1/ives.1
+ @ ${INSTALL_MAN} ${WRKSRC}/xjroot/xjpegroot.1 ${MAN1PREFIX}/man/cat1
+ @ ${GZIP_CMD} ${MAN1PREFIX}/man/cat1/xjpegroot.1
+ @ ${INSTALL_MAN} ${WRKSRC}/launch/xnlaunch.1 ${MAN1PREFIX}/man/cat1
+ @ ${GZIP_CMD} ${MAN1PREFIX}/man/cat1/xnlaunch.1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/xnc
+ ${INSTALL_DATA} ${WRKSRC}/Docs/* ${PREFIX}/share/doc/xnc
+.endif
+
+.include <bsd.port.mk>