aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-02-11 17:44:47 +0800
committergahr <gahr@FreeBSD.org>2013-02-11 17:44:47 +0800
commit6e8ba6d593c8f3098cf0512941bf27f3003aa163 (patch)
treea83d83aa7d90127f9e84d1b61cabea816c445edf /x11-fm
parentabee9bf4039928c12e483a572571edb87567f357 (diff)
downloadfreebsd-ports-gnome-6e8ba6d593c8f3098cf0512941bf27f3003aa163.tar.gz
freebsd-ports-gnome-6e8ba6d593c8f3098cf0512941bf27f3003aa163.tar.zst
freebsd-ports-gnome-6e8ba6d593c8f3098cf0512941bf27f3003aa163.zip
- Update to 1.34
This release improves the overall look and feel of the program. Scrollbar color can now be customized and a Clearlooks theme has been added. Many bugs and some regressions were fixed. Brazilian and czsech translations were also updated.
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/xfe/Makefile9
-rw-r--r--x11-fm/xfe/distinfo4
-rw-r--r--x11-fm/xfe/files/patch-src_DirList.cpp13
3 files changed, 18 insertions, 8 deletions
diff --git a/x11-fm/xfe/Makefile b/x11-fm/xfe/Makefile
index 16ae86b9a787..a8c5b557f1bd 100644
--- a/x11-fm/xfe/Makefile
+++ b/x11-fm/xfe/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xfe
-PORTVERSION= 1.33
-PORTREVISION= 1
+PORTVERSION= 1.34
CATEGORIES= x11-fm
MASTER_SITES= SF
@@ -17,8 +16,8 @@ USE_GNOME= gnomehack intltool
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -pthread
MAN1= xfe.1 xfi.1 xfp.1 xfv.1 xfw.1
@@ -27,7 +26,5 @@ post-patch:
${WRKSRC}/src/XFileExplorer.cpp \
${WRKSRC}/src/help.h \
${WRKSRC}/src/xfedefs.h
- @${REINPLACE_CMD} 's/unsigned FXchar/FXuchar/' \
- ${WRKSRC}/src/xfeutils.cpp
.include <bsd.port.mk>
diff --git a/x11-fm/xfe/distinfo b/x11-fm/xfe/distinfo
index 5105ecde8465..9f0297a5bb20 100644
--- a/x11-fm/xfe/distinfo
+++ b/x11-fm/xfe/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfe-1.33.tar.gz) = e8a40f259d1b48943460ab53c177c5f570e01d2b605db04c8a78c4a4b20372d0
-SIZE (xfe-1.33.tar.gz) = 2320451
+SHA256 (xfe-1.34.tar.gz) = 5e311b0609349ca5ad2c34d32ccb79863eb48f6b8a9fddcecf37f0dd368acf78
+SIZE (xfe-1.34.tar.gz) = 2356801
diff --git a/x11-fm/xfe/files/patch-src_DirList.cpp b/x11-fm/xfe/files/patch-src_DirList.cpp
new file mode 100644
index 000000000000..5e77199a09c5
--- /dev/null
+++ b/x11-fm/xfe/files/patch-src_DirList.cpp
@@ -0,0 +1,13 @@
+--- src/DirList.cpp.orig 2013-02-11 08:59:54.000000000 +0100
++++ src/DirList.cpp 2013-02-11 09:03:05.000000000 +0100
+@@ -1954,8 +1954,10 @@
+ if (prevMinimized == FALSE && minimized == TRUE)
+ {
+ onCmdRefreshTimer(0,0,0);
++#if defined(linux)
+ onMtdevicesRefresh(0,0,0);
+ onUpdevicesRefresh(0,0,0);
++#endif
+ }
+
+ return 1;