aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
committermarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
commit5cc9328814fb9b8e64ff3588af7e6031c1d3514b (patch)
treedf0b6bb8e4e84920da9881d421090dc67f70c629 /x11-fm
parente058c31decaf84a24b7ab7306f65221b33ada080 (diff)
downloadfreebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.gz
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.zst
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.zip
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port. Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of the included version. To restore previous behavior, use the new macro, USE_INC_LIBTOOL_VER. Both macros accept the same argument: a libtool version. For example, to use the ports version of libtool-1.5, add the following to your Makefile: USE_LIBTOOL_VER= 15 To use the included version of libtool with extra hacks provided by libtool-1.5, add the following to your Makefile: USE_INC_LIBTOOL_VER= 15 With this change, ports that had to add additional libtool hacks to prevent .la files from being installed or to fix certain threading issues can now delete those hacks (after appropriate testing, of course). PR: 63944 Based on work by:eik and marcus Approved by: ade (autotools maintainer) Tested by: kris on pointyhat Bound to be hidden problems: You bet
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/krusader/Makefile2
-rw-r--r--x11-fm/krusader2/Makefile2
-rw-r--r--x11-fm/xfce4-fm/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/x11-fm/krusader/Makefile b/x11-fm/krusader/Makefile
index 0bd4f623ee9f..ff0b871e8972 100644
--- a/x11-fm/krusader/Makefile
+++ b/x11-fm/krusader/Makefile
@@ -24,7 +24,7 @@ KDEDIR?=${LOCALBASE}/bin
CONFIGURE_TARGET=
CONFIGURE_ENV+=QTDIR=${QTDIR} KDEDIR=${KDEDIR}
CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
MAN1= krusader.1
diff --git a/x11-fm/krusader2/Makefile b/x11-fm/krusader2/Makefile
index 0bd4f623ee9f..ff0b871e8972 100644
--- a/x11-fm/krusader2/Makefile
+++ b/x11-fm/krusader2/Makefile
@@ -24,7 +24,7 @@ KDEDIR?=${LOCALBASE}/bin
CONFIGURE_TARGET=
CONFIGURE_ENV+=QTDIR=${QTDIR} KDEDIR=${KDEDIR}
CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
MAN1= krusader.1
diff --git a/x11-fm/xfce4-fm/Makefile b/x11-fm/xfce4-fm/Makefile
index e8920c6946cb..eeeeb750547e 100644
--- a/x11-fm/xfce4-fm/Makefile
+++ b/x11-fm/xfce4-fm/Makefile
@@ -28,7 +28,7 @@ USE_GNOME= gtk20
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_XPM= yes
-USE_LIBTOOL_VER=15
+USE_INC_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \