aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-24 20:27:13 +0800
committertijl <tijl@FreeBSD.org>2014-09-24 20:27:13 +0800
commit8702f8b23d41bdfec7ec6c71ba6f077d9e40242f (patch)
tree08bc9cf46148fda9df7d38013cea64004d43f74b /x11-fm
parent152a1bcc9c429c7fbf18923873ba04e3302216cb (diff)
downloadfreebsd-ports-gnome-8702f8b23d41bdfec7ec6c71ba6f077d9e40242f.tar.gz
freebsd-ports-gnome-8702f8b23d41bdfec7ec6c71ba6f077d9e40242f.tar.zst
freebsd-ports-gnome-8702f8b23d41bdfec7ec6c71ba6f077d9e40242f.zip
Patch configure instead of configure.in to avoid USE_AUTOTOOLS
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/rox-filer/Makefile2
-rw-r--r--x11-fm/rox-filer/files/patch-ROX-Filer_src_configure13
-rw-r--r--x11-fm/rox-filer/files/patch-ROX-Filer_src_configure.in28
3 files changed, 14 insertions, 29 deletions
diff --git a/x11-fm/rox-filer/Makefile b/x11-fm/rox-filer/Makefile
index 091d78c1147f..d9888695ba8a 100644
--- a/x11-fm/rox-filer/Makefile
+++ b/x11-fm/rox-filer/Makefile
@@ -14,11 +14,11 @@ RUN_DEPENDS= ${LOCALBASE}/share/mime/packages/freedesktop.org.xml:${PORTSDIR}/mi
PLIST_SUB+= LOCALBASE=${LOCALBASE}
-USE_AUTOTOOLS= autoconf213
USE_XORG= x11 sm xaw xproto
USE_GNOME= atk gconf2 glib20 gnomevfs2 gtk20 libglade2 libidl libxml2 orbit2 pango
USES= gmake pkgconfig shared-mime-info tar:bzip2
+GNU_CONFIGURE= yes
CONFIGURE_ENV= APP_DIR=${WRKSRC}/ROX-Filer
CONFIGURE_ARGS= --enable-rox --with-platform=FreeBSD
CONFIGURE_WRKSRC= ${WRKSRC}/ROX-Filer/src
diff --git a/x11-fm/rox-filer/files/patch-ROX-Filer_src_configure b/x11-fm/rox-filer/files/patch-ROX-Filer_src_configure
new file mode 100644
index 000000000000..4a582d2ec1a2
--- /dev/null
+++ b/x11-fm/rox-filer/files/patch-ROX-Filer_src_configure
@@ -0,0 +1,13 @@
+--- ROX-Filer/src/configure.orig
++++ ROX-Filer/src/configure
+@@ -2134,10 +2134,6 @@
+ ac_config_headers="$ac_config_headers config.h"
+
+
+- if [ -f configure ]; then
+- as_fn_error $? "Please run configure from the build directory (try ../AppRun --compile)" "$LINENO" 5
+- exit 1
+-fi
+
+ ac_ext=c
+ ac_cpp='$CPP $CPPFLAGS'
diff --git a/x11-fm/rox-filer/files/patch-ROX-Filer_src_configure.in b/x11-fm/rox-filer/files/patch-ROX-Filer_src_configure.in
deleted file mode 100644
index 539e68d011ab..000000000000
--- a/x11-fm/rox-filer/files/patch-ROX-Filer_src_configure.in
+++ /dev/null
@@ -1,28 +0,0 @@
-
-$FreeBSD$
-
---- ROX-Filer/src/configure.in.orig
-+++ ROX-Filer/src/configure.in
-@@ -2,11 +2,6 @@
- AC_INIT(main.c)
- AC_CONFIG_HEADER(config.h)
-
--[ if [ -f configure ]; then ]
-- AC_MSG_ERROR([Please run configure from the build directory (try ../AppRun --compile)])
-- exit 1
--fi
--
- dnl Checks for programs.
- AC_PROG_CC
-
-@@ -129,10 +124,6 @@
- AC_HEADER_SYS_WAIT
- AC_CHECK_HEADERS(fcntl.h sys/time.h unistd.h mntent.h sys/ucred.h sys/mntent.h apsymbols.h apbuild/apsymbols.h sys/statvfs.h sys/vfs.h wctype.h libintl.h)
-
--AC_CHECK_HEADER([X11/SM/SMlib.h], [],
-- [AC_MSG_ERROR([Session management library (libsm) missing. It is part of the X server distribution. Try installing the libsm-dev package.])]
--)
--
- dnl Checks for typedefs, structures, and compiler characteristics.
- AC_C_CONST
- AC_TYPE_UID_T