aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2018-02-19 22:01:41 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2018-02-19 22:01:41 +0800
commit27c63cb5e57dc272aba6e669d90c20cc5ab22b3a (patch)
treef6b80cf70664c939dd4ccf1368d6d5352754ef10 /x11-fm
parentb426f3c4aef7b8080c33f1f358d987e3d1f26f7e (diff)
downloadfreebsd-ports-gnome-27c63cb5e57dc272aba6e669d90c20cc5ab22b3a.tar.gz
freebsd-ports-gnome-27c63cb5e57dc272aba6e669d90c20cc5ab22b3a.tar.zst
freebsd-ports-gnome-27c63cb5e57dc272aba6e669d90c20cc5ab22b3a.zip
Fix bunch of ports by TundraWare, which share a common set of problems
- Add LICENSE It explicitly requires user agreement (thus no-auto-accept) and forbids distribution for a fee `beyond reasonable duplication charges` which is too vague I don't think can be guaranteed in any case (thus no-*-sell) tdir port uses another variant of license, which also forbids modification, and since the port requires shebangfix and Makefile patching, also mark it no-pkg-mirror and BROKEN. - Don't install licenses with documentation, since our license framework already handles this - Fix python shebangs - Limit python version to 2.7, as no port is compatible with python3 - Add NO_ARCH - User options targets helpers - Simplify installation in a few cases Approved by: portmgr blanket
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/twander/Makefile21
-rw-r--r--x11-fm/twander/files/patch-Makefile14
-rw-r--r--x11-fm/twander/pkg-plist1
3 files changed, 19 insertions, 17 deletions
diff --git a/x11-fm/twander/Makefile b/x11-fm/twander/Makefile
index fac991ec721c..81b7c366c7fe 100644
--- a/x11-fm/twander/Makefile
+++ b/x11-fm/twander/Makefile
@@ -3,32 +3,31 @@
PORTNAME= twander
PORTVERSION= 3.231
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-fm
MASTER_SITES= http://www.tundraware.com/Software/twander/
MAINTAINER= twander@tundraware.com
COMMENT= Better Filesystem Browser
+LICENSE= TundraWare
+LICENSE_NAME= TundraWare license
+LICENSE_FILE= ${WRKSRC}/twander-license.txt
+LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell no-auto-accept
+
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
-USES= python:2.7
+USES= python:2.7 shebangfix
+SHEBANG_FILES= twander.py
+MAKE_ENV= PYTHON_CMD="${PYTHON_CMD}"
NO_ARCH= yes
OPTIONS_DEFINE= DOCS
-post-patch:
- @${REINPLACE_CMD} \
- -e 's|/usr/bin/env python|${PYTHON_CMD}|' \
- ${WRKSRC}/twander.py
- @${REINPLACE_CMD} \
- -e 's|python |${PYTHON_CMD} |' \
- ${WRKSRC}/Makefile
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in READ-1ST.txt WHATSNEW.txt .twander twander-license.txt twander.html twander.pdf twander.ps twander.txt
+.for f in READ-1ST.txt WHATSNEW.txt .twander twander.html twander.pdf twander.ps twander.txt
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
diff --git a/x11-fm/twander/files/patch-Makefile b/x11-fm/twander/files/patch-Makefile
index f4d274c935a2..ced9ead6831d 100644
--- a/x11-fm/twander/files/patch-Makefile
+++ b/x11-fm/twander/files/patch-Makefile
@@ -1,13 +1,17 @@
---- Makefile.orig 2014-07-01 21:05:14.490108757 +0800
-+++ Makefile 2014-07-01 21:05:33.578108694 +0800
-@@ -6,7 +6,7 @@ all: # Just need to create the compiled
- @python -OOOO -c"import py_compile;py_compile.compile('twander.py')"
+--- Makefile.orig 2009-07-14 17:12:38 UTC
++++ Makefile
+@@ -3,10 +3,10 @@
+
+
+ all: # Just need to create the compiled image
+- @python -OOOO -c"import py_compile;py_compile.compile('twander.py')"
++ @${PYTHON_CMD} -OOOO -c"import py_compile;py_compile.compile('twander.py')"
install:
- ${BSD_INSTALL_SCRIPT} ./twander.py ${PREFIX}/bin
- ${BSD_INSTALL_SCRIPT} ./twander.pyo ${PREFIX}/bin
- ${BSD_INSTALL_MAN} ./twander.1.gz ${PREFIX}/man/man1
+ ${BSD_INSTALL_SCRIPT} ./twander.py $(DESTDIR)${PREFIX}/bin
-+ ${BSD_INSTALL_SCRIPT} ./twander.pyo $(DESTDIR)${PREFIX}/bin
++ ${BSD_INSTALL_DATA} ./twander.pyo $(DESTDIR)${PREFIX}/bin
+ ${BSD_INSTALL_MAN} ./twander.1.gz $(DESTDIR)${PREFIX}/man/man1
diff --git a/x11-fm/twander/pkg-plist b/x11-fm/twander/pkg-plist
index b046c67f395e..8dc817aadb3b 100644
--- a/x11-fm/twander/pkg-plist
+++ b/x11-fm/twander/pkg-plist
@@ -3,7 +3,6 @@ bin/twander.pyo
man/man1/twander.1.gz
%%PORTDOCS%%%%DOCSDIR%%/READ-1ST.txt
%%PORTDOCS%%%%DOCSDIR%%/WHATSNEW.txt
-%%PORTDOCS%%%%DOCSDIR%%/twander-license.txt
%%PORTDOCS%%%%DOCSDIR%%/.twander
%%PORTDOCS%%%%DOCSDIR%%/twander.html
%%PORTDOCS%%%%DOCSDIR%%/twander.pdf