aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
committertcberner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
commit49081780dbf920e309ccc96ab737f85e04f46c66 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /x11-fm
parent08b2e1c36dfd47eb173836d5b9826e537512dc18 (diff)
downloadfreebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.gz
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.tar.zst
freebsd-ports-gnome-49081780dbf920e309ccc96ab737f85e04f46c66.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/dolphin/Makefile2
-rw-r--r--x11-fm/konqueror/Makefile2
-rw-r--r--x11-fm/krusader2-kde4/Makefile2
-rw-r--r--x11-fm/krusader2/Makefile2
-rw-r--r--x11-fm/pcmanfm-qt/Makefile2
-rw-r--r--x11-fm/pcmanfmqt-l10n/Makefile2
-rw-r--r--x11-fm/wcmcommander/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/x11-fm/dolphin/Makefile b/x11-fm/dolphin/Makefile
index 59d0bc0e5b96..a8fad7371b5a 100644
--- a/x11-fm/dolphin/Makefile
+++ b/x11-fm/dolphin/Makefile
@@ -14,7 +14,7 @@ RUN_DEPENDS= ${QT_PLUGINDIR}/ffmpegthumbs.so:multimedia/kdemultimedia-ffmpegthum
${QT_PLUGINDIR}/gsthumbnail.so:graphics/kdegraphics-thumbnailers \
${QT_PLUGINDIR}/audiothumbnail.so:devel/kio-extras
-USES= cmake:outsource compiler:c++11-lib gettext kde:5 qt:5 tar:xz
+USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
USE_KDE= activities attica auth baloo baloo-widgets bookmarks codecs \
completion config configwidgets coreaddons crash dbusaddons \
doctools ecm emoticons filemetadata i18n iconthemes init \
diff --git a/x11-fm/konqueror/Makefile b/x11-fm/konqueror/Makefile
index 576f194ad771..8a8f1b98708b 100644
--- a/x11-fm/konqueror/Makefile
+++ b/x11-fm/konqueror/Makefile
@@ -9,7 +9,7 @@ COMMENT= KDE system log application
LIB_DEPENDS= libtidy.so:www/tidy-lib
-USES= cmake:outsource desktop-file-utils gettext kde:5 pkgconfig qt:5 tar:xz
+USES= cmake desktop-file-utils gettext kde:5 pkgconfig qt:5 tar:xz
USE_KDE= activities archive auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons guiaddons i18n iconthemes \
itemviews jobwidgets js kcmutils kdelibs4support \
diff --git a/x11-fm/krusader2-kde4/Makefile b/x11-fm/krusader2-kde4/Makefile
index e6af2353674c..7bff61199a1c 100644
--- a/x11-fm/krusader2-kde4/Makefile
+++ b/x11-fm/krusader2-kde4/Makefile
@@ -19,7 +19,7 @@ EXPIRATION_DATE= 2018-12-31
CONFLICTS_INSTALL= krusader2-2.*
-USES= cmake:outsource gettext kde:4 qt:4 tar:bzip2
+USES= cmake gettext kde:4 qt:4 tar:bzip2
USE_KDE= kdelibs automoc4
USE_QT= moc_build qmake_build rcc_build uic_build
diff --git a/x11-fm/krusader2/Makefile b/x11-fm/krusader2/Makefile
index 35edc9233a54..125f73d942ee 100644
--- a/x11-fm/krusader2/Makefile
+++ b/x11-fm/krusader2/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS_INSTALL= krusader2-kde4
-USES= cmake:outsource gettext kde:5 qt:5 tar:xz
+USES= cmake gettext kde:5 qt:5 tar:xz
USE_KDE= archive auth auth bookmarks codecs completion config \
configwidgets coreaddons doctools ecm guiaddons i18n \
iconthemes itemviews jobwidgets kio notifications parts \
diff --git a/x11-fm/pcmanfm-qt/Makefile b/x11-fm/pcmanfm-qt/Makefile
index c342e5cb4f74..3bf883f46e1f 100644
--- a/x11-fm/pcmanfm-qt/Makefile
+++ b/x11-fm/pcmanfm-qt/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libmenu-cache.so:x11/menu-cache \
libfm.so:x11/libfm \
libexif.so:graphics/libexif
-USES= cmake:outsource compiler:c++11-lib desktop-file-utils \
+USES= cmake compiler:c++11-lib desktop-file-utils \
gettext-runtime localbase:ldflags lxqt pkgconfig kde:5 qt:5 tar:xz
USE_QT= buildtools_build qmake_build core dbus gui linguisttools \
widgets x11extras
diff --git a/x11-fm/pcmanfmqt-l10n/Makefile b/x11-fm/pcmanfmqt-l10n/Makefile
index 587a6fbe5ae0..59d571d0cefa 100644
--- a/x11-fm/pcmanfmqt-l10n/Makefile
+++ b/x11-fm/pcmanfmqt-l10n/Makefile
@@ -13,7 +13,7 @@ COMMENT= Translations of pcmanfm-qt
LICENSE= LGPL21+
-USES= cmake:outsource lxqt pkgconfig qt:5 tar:xz
+USES= cmake lxqt pkgconfig qt:5 tar:xz
USE_QT= buildtools_build qmake_build linguisttools
USE_LXQT= buildtools
diff --git a/x11-fm/wcmcommander/Makefile b/x11-fm/wcmcommander/Makefile
index 92bea563bfa2..c09c2a4c4fef 100644
--- a/x11-fm/wcmcommander/Makefile
+++ b/x11-fm/wcmcommander/Makefile
@@ -17,7 +17,7 @@ USE_GITHUB= yes
GH_ACCOUNT= corporateshark
GH_PROJECT= WCMCommander
-USES= compiler:c++11-lib cmake:outsource
+USES= compiler:c++11-lib cmake
CMAKE_ARGS= -DDATADIR="${DATADIR_REL}"
USE_XORG= x11