aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-12-22 03:39:32 +0800
committermarino <marino@FreeBSD.org>2015-12-22 03:39:32 +0800
commit91f143897e68bda46a5f53484497c05a006e3780 (patch)
treee8fd553b2c3044b0b313bb596a38c34240922a1b /x11-fm
parent6e06b8246fe2d64379fcea09e4d3ccdb16852eb8 (diff)
downloadfreebsd-ports-gnome-91f143897e68bda46a5f53484497c05a006e3780.tar.gz
freebsd-ports-gnome-91f143897e68bda46a5f53484497c05a006e3780.tar.zst
freebsd-ports-gnome-91f143897e68bda46a5f53484497c05a006e3780.zip
x11-fm/doublecmd: Make less broken, then set BROKEN
After the upgrade to FPC 3.0.0, the port failed the build depends stage. I've fixed that, and it compiles pretty far until this error: doublecmd.lpr(18,3) Fatal: (10022) Can't find unit uOverlayScrollBarFix I suspect that is a Lazarus unit and it might be a missing path. In the meantime, the port can't build so we have to mark it BROKEN.
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/doublecmd/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/x11-fm/doublecmd/Makefile b/x11-fm/doublecmd/Makefile
index acd2b0981d9a..adfd6e851c60 100644
--- a/x11-fm/doublecmd/Makefile
+++ b/x11-fm/doublecmd/Makefile
@@ -13,6 +13,9 @@ COMMENT= Total Commander like file manager for the X Window System
LICENSE= GPLv2
+BROKEN= fails with FPC-3.0.0-built Lazarus\
+ (Can't find unit uOverlayScrollBarFix)
+
BUILD_DEPENDS= lazbuild:${PORTSDIR}/editors/lazarus \
fpcres:${PORTSDIR}/lang/fpc-utils
@@ -21,8 +24,8 @@ ONLY_FOR_ARCHS= i386 amd64
PORTDOCS= *
USES= dos2unix
-USE_FPC= cairo fcl-base fcl-db fcl-image fcl-json fcl-process fcl-registry \
- fcl-xml hash iconvenc pasjpeg paszlib x11
+USE_FPC= cairo fcl-base fcl-db fcl-image fcl-json fcl-registry \
+ fcl-xml iconvenc pasjpeg rtl-extra x11
DOS2UNIX_FILES= src/dmhelpmanager.pas
WANT_GNOME= yes
@@ -32,6 +35,7 @@ PROJECT_FILE= src/doublecmd.lpi
LAZARUS_VER= 1.4.2
LAZBUILD_CMD= ${LOCALBASE}/bin/lazbuild -d --pcp=${WRKSRC}/tmppcp
LAZARUS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}
+MAKE_ENV+= LDVER=ld.bfd # for DragonFly
HELPVERSION= 0.6.0
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}