aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2019-07-12 10:25:07 +0800
committerlinimon <linimon@FreeBSD.org>2019-07-12 10:25:07 +0800
commit59bb9171a907de6de27397b000cf6807bcd5cbe7 (patch)
treeae010486371dd984317b78c829a6c1566d322249 /x11-fm
parent37e2eea0c32d87940ca94d66a1af7811ebab434a (diff)
downloadfreebsd-ports-gnome-59bb9171a907de6de27397b000cf6807bcd5cbe7.tar.gz
freebsd-ports-gnome-59bb9171a907de6de27397b000cf6807bcd5cbe7.tar.zst
freebsd-ports-gnome-59bb9171a907de6de27397b000cf6807bcd5cbe7.zip
Prepare for powerpc-on-clang by deleting hard-coded tests for libstdc++.so
as a stand-in for "are we running on gcc". For people already testing powerpc on clang, it is possible that they already have both compilers in base. Thus, the assumption that "gcc is in base" (e.g. libstdc++.so exists) always means "force use of GCC" is already broken. It will be for everyone on -CURRENT once the switch is made. While here, standardize on compiler:c++11-lang instead of -lib (they are equivalent these days), pet portlint, and do some other cleanup. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/worker/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-fm/worker/Makefile b/x11-fm/worker/Makefile
index 68e4d41038ea..e6e6f54551f7 100644
--- a/x11-fm/worker/Makefile
+++ b/x11-fm/worker/Makefile
@@ -45,4 +45,10 @@ LUA_USES= lua:51
XFT_CONFIGURE_OFF= --disable-xft
XFT_USE= xorg=xft
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc
+CXXFLAGS+= -Wno-error=narrowing
+.endif
+
+.include <bsd.port.post.mk>