aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2000-10-04 13:15:34 +0800
committertrevor <trevor@FreeBSD.org>2000-10-04 13:15:34 +0800
commit5eb13430b3e52dc7a4dfd5daee0b1b701f080548 (patch)
treea756ac6193ff98041254a96d3cc1c722894dcc87 /x11-fm
parentc90e1163f1d0a22eec768fed48a08562e279559b (diff)
downloadfreebsd-ports-gnome-5eb13430b3e52dc7a4dfd5daee0b1b701f080548.tar.gz
freebsd-ports-gnome-5eb13430b3e52dc7a4dfd5daee0b1b701f080548.tar.zst
freebsd-ports-gnome-5eb13430b3e52dc7a4dfd5daee0b1b701f080548.zip
Add x11-fm/xdiskusage, a graphical front-end to du.
PR: 21505 Approved by: will
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/Makefile1
-rw-r--r--x11-fm/xdiskusage/Makefile37
-rw-r--r--x11-fm/xdiskusage/distinfo1
-rw-r--r--x11-fm/xdiskusage/pkg-comment1
-rw-r--r--x11-fm/xdiskusage/pkg-descr10
-rw-r--r--x11-fm/xdiskusage/pkg-plist3
6 files changed, 53 insertions, 0 deletions
diff --git a/x11-fm/Makefile b/x11-fm/Makefile
index 2b5c13b4c650..d64bcde1c191 100644
--- a/x11-fm/Makefile
+++ b/x11-fm/Makefile
@@ -19,6 +19,7 @@
SUBDIR += workplace
SUBDIR += x-files
SUBDIR += xcruise
+ SUBDIR += xdiskusage
SUBDIR += xfm
SUBDIR += xnc
diff --git a/x11-fm/xdiskusage/Makefile b/x11-fm/xdiskusage/Makefile
new file mode 100644
index 000000000000..c1ace826a7f0
--- /dev/null
+++ b/x11-fm/xdiskusage/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: xdiskusage
+# Date created: 2000-09-23
+# Whom: Trevor Johnson <trevor@jpj.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xdiskusage
+PORTVERSION= 1.41
+CATEGORIES= x11-fm
+MASTER_SITES= http://xdiskusage.sourceforge.net/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= trevor@FreeBSD.org
+
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+
+USE_GMAKE= yes
+USE_MESA= yes
+USE_X_PREFIX= yes
+
+do-build:
+.for i in panels xdiskusage
+ ${CXX} ${CXXFLAGS} -I${X11BASE}/include -c ${WRKSRC}/${i}.C \
+ -o ${WRKSRC}/${i}.o
+.endfor
+ ${CXX} ${CXXFLAGS} -L${X11BASE}/lib -o ${WRKSRC}/xdiskusage \
+ ${WRKSRC}/panels.o ${WRKSRC}/xdiskusage.o -lfltk -lm -lMesaGL
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xdiskusage ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/xdiskusage
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xdiskusage
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-fm/xdiskusage/distinfo b/x11-fm/xdiskusage/distinfo
new file mode 100644
index 000000000000..5ea062a43e2f
--- /dev/null
+++ b/x11-fm/xdiskusage/distinfo
@@ -0,0 +1 @@
+MD5 (xdiskusage-1.41.tgz) = dca6c32cf3d67cd480b7157df3ddc109
diff --git a/x11-fm/xdiskusage/pkg-comment b/x11-fm/xdiskusage/pkg-comment
new file mode 100644
index 000000000000..e91eb277be27
--- /dev/null
+++ b/x11-fm/xdiskusage/pkg-comment
@@ -0,0 +1 @@
+Show where disk space is taken up
diff --git a/x11-fm/xdiskusage/pkg-descr b/x11-fm/xdiskusage/pkg-descr
new file mode 100644
index 000000000000..3175cd5a9bf3
--- /dev/null
+++ b/x11-fm/xdiskusage/pkg-descr
@@ -0,0 +1,10 @@
+This utility runs "du" to scan directories of your choosing, then displays a
+graph which emphasizes the subdirectories where the largest files are kept, and
+optionally lists the files themselves. You can descend into the directory
+tree, or back out, by clicking on the graph. If you save the output of "du" in
+a file, xdiskusage can analyze that too. PostScript output is available.
+
+WWW: http://xdiskusage.sourceforge.net/
+
+Trevor Johnson
+trevor@freebsd.org
diff --git a/x11-fm/xdiskusage/pkg-plist b/x11-fm/xdiskusage/pkg-plist
new file mode 100644
index 000000000000..b2d2369f8a31
--- /dev/null
+++ b/x11-fm/xdiskusage/pkg-plist
@@ -0,0 +1,3 @@
+bin/xdiskusage
+share/doc/xdiskusage/README
+@dirrm share/doc/xdiskusage