aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2006-11-17 01:52:49 +0800
committermezz <mezz@FreeBSD.org>2006-11-17 01:52:49 +0800
commita7c498cb3ed6bc732a08f05630f5b630c366e292 (patch)
tree5a0938f9bf0cecf8dfb051db035c8231b3b068dc /x11-fm
parent17f7ecd88a5759954de0cc70bc3e13f2e86dfebf (diff)
downloadfreebsd-ports-gnome-a7c498cb3ed6bc732a08f05630f5b630c366e292.tar.gz
freebsd-ports-gnome-a7c498cb3ed6bc732a08f05630f5b630c366e292.tar.zst
freebsd-ports-gnome-a7c498cb3ed6bc732a08f05630f5b630c366e292.zip
Add a patch fo fix the desktop icons(computer,home,trash)'s position that
couldn't load from ~/.nautilus/metafiles/. This patch was took from in this bugzilla by Luis Medinas. Bump the PORTREVISION. Reviewed by: marcus Reported by: a few of people in freebsd-gnome both mailing list and IRC Bugzilla: http://bugzilla.gnome.org/show_bug.cgi?id=373895
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/nautilus/Makefile1
-rw-r--r--x11-fm/nautilus/files/patch-fix-desktop-icon-position25
2 files changed, 26 insertions, 0 deletions
diff --git a/x11-fm/nautilus/Makefile b/x11-fm/nautilus/Makefile
index 4a95ff6aecbc..e7d7e3189343 100644
--- a/x11-fm/nautilus/Makefile
+++ b/x11-fm/nautilus/Makefile
@@ -8,6 +8,7 @@
PORTNAME= nautilus
PORTVERSION= 2.16.2
+PORTREVISION= 1
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/x11-fm/nautilus/files/patch-fix-desktop-icon-position b/x11-fm/nautilus/files/patch-fix-desktop-icon-position
new file mode 100644
index 000000000000..935864c5d13a
--- /dev/null
+++ b/x11-fm/nautilus/files/patch-fix-desktop-icon-position
@@ -0,0 +1,25 @@
+--- src/file-manager/fm-icon-view.c.orig 2006-11-14 16:35:04.304162544 +0000
++++ src/file-manager/fm-icon-view.c 2006-11-14 16:51:02.820445920 +0000
+@@ -531,12 +531,20 @@
+ file_has_lazy_position (FMDirectoryView *view,
+ NautilusFile *file)
+ {
++ gboolean lazy_position;
++
+ /* For volumes (i.e. cdrom icon) we use lazy positioning so that when
+ * an old cdrom gets re-mounted in a place that now has another
+ * icon we don't overlap that one.
+ */
+-
+- return NAUTILUS_IS_DESKTOP_ICON_FILE (file);
++ lazy_position = nautilus_file_has_volume (file);
++ if (lazy_position && fm_directory_view_get_loading (view)) {
++ /* if volumes are loaded during directory load, don't mark them
++ * as lazy. This is wrong for files that were mounted during user
++ * log-off, but it is right for files that were mounted during login. */
++ lazy_position = FALSE;
++ }
++ return lazy_position;
+ }
+
+ static void