aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/XFree86-4-font75dpi/Makefile
diff options
context:
space:
mode:
authorlesi <lesi@FreeBSD.org>2006-02-07 17:56:51 +0800
committerlesi <lesi@FreeBSD.org>2006-02-07 17:56:51 +0800
commit802cbea2e1bdf9bbd3dd1b0f610965a54b9f6c5b (patch)
treec367f72cc56c051a2420e7573a9b542390e57fc2 /x11-fonts/XFree86-4-font75dpi/Makefile
parentccd66d950b36b313da2c3716e11a4584aca162da (diff)
downloadfreebsd-ports-gnome-802cbea2e1bdf9bbd3dd1b0f610965a54b9f6c5b.tar.gz
freebsd-ports-gnome-802cbea2e1bdf9bbd3dd1b0f610965a54b9f6c5b.tar.zst
freebsd-ports-gnome-802cbea2e1bdf9bbd3dd1b0f610965a54b9f6c5b.zip
Take care of font cache files on installation and uninstallation of port:
On installation try running fc-cache for directory where fonts from this port are installed and don't complain if fc-cache (from fontconfig) is missing. Do a bit more dancing on uninstall, just in case users have their own fonts installed in same directory: - first remove fonts.cache-1 if it is there since it won't be accurate after fonts from this port are gone anyway, - next try to regenerate cache with fc-cache for this directory - if previous step generates empty cache file, remove it If directory contained only fonts from this port, it should get properly removed at the end. If there were other fonts there and fontconfig is installed, this will leave proper cache file for remaining fonts behind after uninstall of this port.
Diffstat (limited to 'x11-fonts/XFree86-4-font75dpi/Makefile')
-rw-r--r--x11-fonts/XFree86-4-font75dpi/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/x11-fonts/XFree86-4-font75dpi/Makefile b/x11-fonts/XFree86-4-font75dpi/Makefile
index 2b94b1ac1ce7..d053307b77cd 100644
--- a/x11-fonts/XFree86-4-font75dpi/Makefile
+++ b/x11-fonts/XFree86-4-font75dpi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= font75dpi
PORTVERSION= 4.5.0
+PORTREVISION= 1
CATEGORIES= x11-fonts
MASTER_SITES= ${MASTER_SITE_XFREE}
MASTER_SITE_SUBDIR= ${PORTVERSION}
@@ -44,6 +45,9 @@ pre-build:
(cd ${WRKDIR}/xc/fonts/encodings && \
${MAKE} all)
+post-install:
+ @command fc-cache -v ${PREFIX}/lib/X11/fonts/75dpi || true
+
.include <bsd.port.pre.mk>
.if ${X_WINDOW_SYSTEM:L} != xfree86-4
IGNORE= is part of XFree86 and you have ${X_WINDOW_SYSTEM} set for X11\