aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/fontconfig
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2012-04-24 05:05:05 +0800
committerkwm <kwm@FreeBSD.org>2012-04-24 05:05:05 +0800
commitb24da4ef1bc0d1d1e24206605d6fda6b88769347 (patch)
treea0350432d1ff33ec889b90e189fc922882eb02a3 /x11-fonts/fontconfig
parentfecec0b5b0fce45e4cc1090fac02aede12f9d750 (diff)
downloadfreebsd-ports-gnome-b24da4ef1bc0d1d1e24206605d6fda6b88769347.tar.gz
freebsd-ports-gnome-b24da4ef1bc0d1d1e24206605d6fda6b88769347.tar.zst
freebsd-ports-gnome-b24da4ef1bc0d1d1e24206605d6fda6b88769347.zip
Add patch from upstream to fix a C++11 issue in fontconfig. This fixes the
build of libreoffice with Clang on current. And possible other C++ users of fontconfig. Submitted by: Buganini (via bapt@) on #freebsd-office Obtained by: fontconfig git
Diffstat (limited to 'x11-fonts/fontconfig')
-rw-r--r--x11-fonts/fontconfig/Makefile2
-rw-r--r--x11-fonts/fontconfig/files/patch-fontconfig_fontconfig.h26
2 files changed, 27 insertions, 1 deletions
diff --git a/x11-fonts/fontconfig/Makefile b/x11-fonts/fontconfig/Makefile
index 41aad3726b29..74b90fa51b33 100644
--- a/x11-fonts/fontconfig/Makefile
+++ b/x11-fonts/fontconfig/Makefile
@@ -8,7 +8,7 @@
PORTNAME= fontconfig
PORTVERSION= 2.8.0
-PORTREVISION?= 1
+PORTREVISION?= 2
PORTEPOCH?= 1
CATEGORIES= x11-fonts
MASTER_SITES= http://www.freedesktop.org/software/fontconfig/release/
diff --git a/x11-fonts/fontconfig/files/patch-fontconfig_fontconfig.h b/x11-fonts/fontconfig/files/patch-fontconfig_fontconfig.h
new file mode 100644
index 000000000000..3434d003b24f
--- /dev/null
+++ b/x11-fonts/fontconfig/files/patch-fontconfig_fontconfig.h
@@ -0,0 +1,26 @@
+From 7069d717e982adcf8e1d300cbd10eec6322a65c9 Mon Sep 17 00:00:00 2001
+From: Akira TAGOH <akira@tagoh.org>
+Date: Sun, 22 Apr 2012 12:40:44 +0000
+Subject: C++11 requires a space between literal and identifier
+
+Reported by Buganini
+---
+diff --git a/fontconfig/fontconfig.h b/fontconfig/fontconfig.h
+index 0e2ca50..b27ccb5 100644
+--- fontconfig/fontconfig.h
++++ fontconfig/fontconfig.h
+@@ -112,9 +112,9 @@ typedef int FcBool;
+ #define FC_DECORATIVE "decorative" /* Bool - true if style is a decorative variant */
+ #define FC_LCD_FILTER "lcdfilter" /* Int */
+
+-#define FC_CACHE_SUFFIX ".cache-"FC_CACHE_VERSION
+-#define FC_DIR_CACHE_FILE "fonts.cache-"FC_CACHE_VERSION
+-#define FC_USER_CACHE_FILE ".fonts.cache-"FC_CACHE_VERSION
++#define FC_CACHE_SUFFIX ".cache-" FC_CACHE_VERSION
++#define FC_DIR_CACHE_FILE "fonts.cache-" FC_CACHE_VERSION
++#define FC_USER_CACHE_FILE ".fonts.cache-" FC_CACHE_VERSION
+
+ /* Adjust outline rasterizer */
+ #define FC_CHAR_WIDTH "charwidth" /* Int */
+--
+cgit v0.9.0.2-2-gbebe