aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fonts/libXfont/Makefile
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-12-22 07:38:30 +0800
committeranholt <anholt@FreeBSD.org>2003-12-22 07:38:30 +0800
commitd5d5a4d08458f903fb20a220c77b8e4c6e464301 (patch)
treed9c9a5328af8bef07f9f57b4ff33974ce2d04bdd /x11-fonts/libXfont/Makefile
parentc25319f1163e0907293ebd8e78f2c132281a6e39 (diff)
downloadfreebsd-ports-gnome-d5d5a4d08458f903fb20a220c77b8e4c6e464301.tar.gz
freebsd-ports-gnome-d5d5a4d08458f903fb20a220c77b8e4c6e464301.tar.zst
freebsd-ports-gnome-d5d5a4d08458f903fb20a220c77b8e4c6e464301.zip
New port: Prerelease version of libXfont from freedesktop.org:
X font libary Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
Diffstat (limited to 'x11-fonts/libXfont/Makefile')
-rw-r--r--x11-fonts/libXfont/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-fonts/libXfont/Makefile b/x11-fonts/libXfont/Makefile
new file mode 100644
index 000000000000..c42bfdf700a5
--- /dev/null
+++ b/x11-fonts/libXfont/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libXfont
+# Date Created: 29 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXfont
+PORTVERSION= 1.4.1.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X font libary
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS= --enable-freetype
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.4.1
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>